Ethernet doesn't work after unplug/plug cable


If I unplug my Ethernet cable when the HE is up and running, then plug the cable back in, the port seems dead (no link light on the switch). I have to power cycle the HE to get it working again. This is a pain if I need to move some patch cords around or power cycle my switch.

My brother also has an HE, his doesn't have this problem.

Has anyone seen this before?

Reboot your router

1 Like

@gdkramer - thanks for the suggestion.

To explain more, my configuration is like this:

router <=> switch <=> Hubitat

If I boot up the HE connected to the switch (only), I get a link light on the switch (no router in the picture). If I unplug the ethernet cable and plug it back in, there is no link light. Also tried several different brands of switches... no luck. The link light on the switch indicates that the physical layer is connected(10/100/1000), it doesn't have anything to do with DHCP or the router.

I think there is something up with my HE.

Try another ethernet cable.
Just a suggestion.

1 Like

Maybe so. Tagging @bobbyD.

Also, get a bigger switch so you don't have to keep unplugging your HE or any other device. 16 port gigabit switches are going for $30-40.

Any possibility this is related to the link negotiation setting issue?

@aaiyar - thanks for the response.

Haha.. I have a 16-port switch, and in all reality, I hardly ever unplug or power-cycle the switch... but the HE has backup power and the switch does not, so it's a bad combo.

hi @Eric.C.Miller,

I read a little about that, but didn't want to try anything until @bobbyD or someone at HE told me to, I read somewhere it was irreversible.

I actually emailed several weeks ago about this, but haven't heard back yet, they must be really busy... so I took to the forums.

I think your approach is wise.

@bobbyD ??

1 Like

I found a solution / work around.

My Ubiquiti Unifi switch allows me to program some settings to each port of the switch. The port that goes to HE I turned off auto-negotiate and set it to 100 FDX. After doing this, I can unplug and plug my HE ethernet cable and it comes back online every time.

So the root cause seems to be something with the HE auto negotiate.

Side Note: Hubitat hasn't gotten back to me on this issue... I've sent them three emails over the last several months with no reply. I love my Hubitat, but concerning that they are not responding.

1 Like