Errors on a Few RM Rules


#1

@bravenel

I wasn't sure what is causing these errors, I keep seeing these errors on my logs on a few RM rules that is modifying modes. Do you know what might be causing these errors, I already recreated one of these rules and rebooted my hub. I noticed this hub has locked up a few times in the past month as well and this is the only errors I'm seeing in the logs. The Set modes rule below is seeing this error several times a day.

Could it be caused by using the Mode becomes changed on 3 different rules?

Error on RM:

app:11792019-09-08 08:28:55.964 am errorjava.util.ConcurrentModificationException: null on line 3126 (allHandler)

Error on RM:

app:11802019-09-08 08:28:37.890 am errorjava.util.ConcurrentModificationException: null on line 3126 (allHandler)

Error on RM:

app:12132019-09-08 08:29:03.161 am errorjava.util.ConcurrentModificationException: null on line 3126 (allHandler)

app:12132019-09-08 08:28:57.844 am errorjava.util.ConcurrentModificationException: null on line 1594 (allHandler)

app:12132019-09-08 08:28:49.490 am errorjava.util.ConcurrentModificationException: null on line 3126 (allHandler)

app:12132019-09-08 08:28:46.261 am errorjava.util.ConcurrentModificationException: null on line 3126 (allHandler)


#2

Thanks for bringing this to my attention. I will look into it. The "Concurrent Modification Exception" has to do with when code is modifying something that it is using at the same time for something else. Usually, there's an easy fix once the problem is isolated. That's my next step...


#3

I have been seeing the same error in RM on my rules that change dimmers with mode change as the trigger. It only happens on certain modes, not every change, so I figured it was an error on my part.


#4

I am not having any luck replicating this error, although I will continue to look into it.

BTW, I hope you realize that your last rule is a complete waste, and should be done with Mode Manager instead. Checking once a minute to see what time it is doesn't make sense. These changes can be scheduled.

Plus, each of these rules is going to trigger itself when it sets the mode. I suggest you rethink how and why you are doing these.


#5

Thanks, I'll have to try Mode Manager again, I was thinking there was something on Mode Manager that I couldn't do but I could be wrong.


#6

here is the rule and error I am seeing



#7

What version platform software are you running on your hub?


#8

image


#9

OK. Can you turn on all of the logging options in that rule, so I can see more context of when the error is thrown.

Is this error happening when the rule is run, or when you are setting it up?


#10

will do. It happens when the rule is run. I have another rule for a different room that throws the same error and line number, but only when it changes to morning and night mode (I have 8 modes). I am using mode manager to change the modes which are the trigger for changing the CT of the lights in the house and I have the delays staggered so I don't overwhelm the hub or mesh (zigbee); don't know if it matters. I also have a similar rule that gives the same error, but a different line number. It will probably be tomorrow before I can get back to you as the wife won't appreciate the lights going crazy.


#11

The line numbers you've been showing have to do with setting the rule up. So can you confirm that these are happening when the rule actually runs?


#12

without any doubt. It has been going on for weeks, only during a mode change/trigger.


#13

Here is another one. I swear I wasn't even awake at 5am.



and another


this similar rule never has an error


#14

I enabled all logging for the 3 rules and will post back tomorrow with the results.


#15

Here are the logs




#16

I don’t know if you have had a chance to look at these errors yet, but Let me know if you need any more info


#17

Please post the rule that you have shown the errors for, the one with

IF (Dining room color light is on) THEN


#18


#19

I just don’t understand why this happens. Half an hour later it fires without errors and the rule is the same. Also no other errors of any kind in the log since this morning with these rules. It seems to happen at the same time each day for each rule. 5:30am each day for the cat light and 5:00 for the other. I also am getting this error “null on line 1473” on a rule controlling Hue lights that are connected to the Hue bridge at 5:00 am as well. I don’t have logs for that one though.


#20

This one is somewhat of a mystery. We cannot reproduce the failure.

I'm thinking of making a small change to the code for the next release to see if it clears this up. But without being able to really understand why it fails, I'm not sure it will work.


[Released] Rule 4.0