Envisalink Integration no longer working

I have been successfully utilizing the Envisalink Integration for the past three years (using the contact sensors and motion sensors that are part of my DSC security system to also trigger various home automation routines). It has been rock solid reliable until a couple of days ago. I have changed nothing in my system in the last week other than performing the routine software platform updates to my hub (C7). Starting 12/26/2023 my virtual contacts on my dashboards associated with my DSC security system contacts have failed to update their status (open or closed). When I check the contact status in the EyezOn app, Envisalink appears to be responsive and working so I believe it is a problem on the Hubitat end with Hubitat no longer recognizing the status of the contacts (since I can still access the correct status of my contacts via the EyezOn app).

I’m not certain but the timing of this seems to correspond with the next to the last software platform update (I just performed updating to 2.3.7.144 four hours ago thinking that this may correct the problem assuming that it was the previous update that caused the problem but the Envisalink Integration is still “broken”).

Also, although the Enisalink Integration was always a bit “chatty”, I noted that recently the % of busy stat has jumped WAY up to 84% and the CPU % usage is up to 10% (CPU % usage was always pretty steady at around 3-5% in the past but seems to be rather erratic and can spike to 15-20% since my last platform software update).

Has anyone else experienced a recent problem with the Envisalink Integration failing to maintain the correct contact status? I have never encountered this before (as I mentioned before, everything was working and rock solid for three years now and I never had a problem with Hubitat recognizing the status of my security contacts before). TIA for any help or advice.

I have not noticed any recent issues with Envisalink (telnet version). It has been arming/disaming ok. I just checked and the contact statuses are being received. I am running it on a dedicated C-7 using the latest firmware, just updated to 2.3.7.144. I have no other integrations or devices running on the C-7, so the CPU load is always very low and continues to be less than 2%.

There is a recent post about someone trying to install Envisalink for the first time and having problems. Don't know but the issues may be related. Here is the post.....Envisalink Integration - #3 by rn.noodle

Edit: FWIW I am running the Envisalink on a Honeywell Vista 20P panel, but I don't think this makes a difference. Also, one suggestion would be to reboot the Envisalink module under Settings>>General Settings in the mobile app or website.

I'm on 2.3.7.144 on a C-8 that does everything. I just opened a slider, and it worked.
It's been reliable for me. The occasional Telnet error in logs, but hasn't been affecting experience, as far as I can see.
I like the integration.

Mine has been fine for years and yes it is chatty. I edited the code to stop some of the chat but can't find the Telnet input stream one yet.
I have found in the past that the EVL3 will stop working if the TPI status is not ONLINE.
I have had to coax it back with a re-power and toggling this I believe; been a while.
image

I am experiencing the same issue with Envisalink with a C8. It has worked fine for years untouched. Recently, the Envisalink Hubitat device status is no longer reliable. For example, when it is disarmed, the device status shows it is armed. This is new within the past few weeks.

Dan

When I installed this years ago I thought all was good.
I had pistons running and dealing with the alarm, locks etc.
Then I realized the alarm status was always Ready no matter what I tried so it had never worked for me.
I don't test for that anymore and instead check all the contacts in Envisalink and make my own Ready boolean. It has worked fine ever since.

@Dan4,
Out of curiosity, what is your CPU % usage when everything gets non-responsive or out of sync? As the OP, I mentioned that my CPU usage is very high when I noticed that my C7 become unreliable with regards to responsiveness to my Envisalink. Everything reports fine in the EyezON app, and can be controlled via the EyezON app, the state is just not accurately reported on my Hubitat dashboards. Like you, I have been using the Envisalink/Hubitat combo for over three years now and it has been absolutely rock solid until about 3 weeks ago.

I don’t know the CPU % but I get a lot of these now from Envisalink device:

com.hubitat.app.exception.LimitExceededException: Device 61 generates excessive hub load on line 1487

com.hubitat.app.exception.LimitExceededException: Device 61 generates excessive hub load on line 42 (method open)

com.hubitat.app.exception.LimitExceededException: Device 61 generates excessive hub load on line 1388 (method parse)

Luckily I'm limited to this so far:
dev:1522024-01-24 06:28:29.843warntelnet input stream closed

Uses 2.5% of 4.4% total cpu load so 0.11% of my CPU capacity.

Still rock solid

Resurrecting this thread as I am continuing to have recent problems with my Envisalink Integration despite it being rock solid for the last three years. All zone states are reflected accurately in the Envisalink EyezOn app so I know the Envisalink to DSC panel connection is working. It is just that the zone states are no longer reflected accurately on my Hubitat Hub Dashboards. Again, this only started around the beginning of this year (it was always rock solid for the prior three years since I started using the integration). Any step-by-step instructions on how I can trouble shoot and resolve the issue? These are the logs (first for the Integraton app.36, the second for one of my PIR sensors):



Appears that the Hub is being overloaded but again, this has never been a problem in the past and not much else has been added to this hub (C-7). TIA for any specific help as to how to trouble shoot this. This community has always been fantastic!

Did anyone ever find a solution to this?

1 Like

I am having the same problem for about three weeks it seems.

Yes, this continues to be a problem as many of my automations depend upon Hubitat “reacting” to Envisalink status. Both the Envisalink interface as well as Alexa are able to relate the proper state of my sensors so the problem seems to be specifically the link between Envisalink and Hubitat. Again, has anyone found a solution for this (or at least an explanation for why this is no longer working?).

Of no help here, just chiming in.
Mine still only produces the telnet message and the device load for Envisalink is at 2.2% of the total.
This is actually quite lower than it used to be; this was usually #2 on my hit list.
Now it's #11 , Owntracks and Switchbot are beating it down.