Enerwave RSM1-Plus Parse Returned Null

I’ve had a number of these relays installed and functioning correctly for over a year now. In the past week, the one controlling my driveway lights has stopped turning the lights on (they do turn off properly) when a lux rule instructs.

In the logs I can see the rule sending the “on” command then the relay returns “dev:259 2022-01-18 17:02:29.722 gParse returned null”. This same message appears when manually turning the lights on or off and they function properly.

I haven’t made any changes to the system in at least a month and the lights turn off/on flawlessly from the “device” page in the Hubitat control panel and from a dashboard.

If somebody can provide direction on what to check next for troubleshooting, I will be appreciative.

What driver are you using?

Hello, pdupper. Thanks for the reply.

I've been running the erocm123 (Eric Maycock) "Enerwave RSM1-Plus" 2.0 version since installing all of the relays over a year ago. It would be strange for only one of the relays to have an issue, but if there's a better driver you can recommend, I'll definitely give it a shot.

Check out this thread. Its about the RSM2 but using the Eric Maycock RSM2 driver...

Not sure if it will help... I have several of these and used his drivers until recently when I started using built in drivers... About halfway down is a post with similar errors.

It does sound similar. I see that the built in driver is the "Generic Z-Wave Plus Multiswitch" for the RSM2. Which one are you running with your RSM1s?

I'm using the generic z-wave smart switch driver for the RSM1's and the new generic multiswitch driver for the RSM2's. I've been having some z-wave issues lately though and wonder if these enerwave devices might be the problem themselves. They are some of the most physically close devices to the hub, yet all seem to go through repeaters instead of direct to the hub. I did the external antenna mod and it has worked great for all my other devices... I have 7 of these enerwave devices, 3 1's and 4 2's... Anyway, I was interested in seeing if it turns out to be the driver or the device itself in your case... :slight_smile:

I've switched all of mine (including the problem child, of course) to the generic z-wave plus switch driver and will let you know the result when the sun goes down!

1 Like

Same deal, unfortunately. Lights turn on and off flawlessly with the dashboard. They turn off with the rule in the morning. They do not turn on when instructed by the rule in the evening. I'm stumped.

One thing to do is make sure you clear out any scheduled actions or attributes the old driver left behind. I had to do that when I switched to the generic drivers. Eric's drivers had some scheduled items that continued to run after switching... You have to switch to the internal generic device driver and there is a button/command to clear that stuff.

Here is a link to the thread on how to do it...

On it. Thanks!

That didn't do the trick. I've deleted my lux rule and put a simple sunrise/sunset rule in place. I'm curious to see if they'll turn on that way. If not, I'll exclude then add the relay back in.

@pdupper changing the rule to sunrise/sunset did not work either, though I found the cause and the lights came on today (without doing an include/exclude). I failed to give you all the information originally as didn't think it was relevant.

The rule was to turn on the driveway lights (the Enerwave relay) and Christmas lights (an outdoor plug-in z-wave switch). The Christmas light switch has been unplugged for a couple of weeks. In hindsight, this problem must have started the day the switch was unplugged. Removing the disconnected switch from the rule has the driveway lights functioning properly. I didn't think it would be a cause of the issue, as the switch was unplugged after Christmas last year and the driveway lights still worked. A software update must have changed that behaviour.

Thank you for your support. I learned about the new driver for the relays and updated all of mine. I also learned about clearing scheduled actions. Both valuable lessons. You are appreciated in this forum.

Glad you got it figured out... I've experienced similar issues when devices failed. Makes sense if you disconnected a device the mesh thinks should be there, it will cause havoc... Anyway, I'm usually in need of help myself... :slight_smile:

1 Like

Download the Hubitat app