Ecolink zigbee flood sensor

Has anyone had success using this device, and what driver are you using?

1 Like

I am... seems to work fine with the generic zigbee moisture sensor driver. I have a couple of them.

1 Like

Thank you @brad5, just ordered three.

One kind of odd thing... they use AAA batteries, not CR123As... not a big deal just something to note

1 Like

That's a bonus! AAAs are much less expensive than the CR123As.

When I opened the box I thought I was hallucinating, thinking AAA batteries should be larger than what was packed. Turns out they are actually AAAA, about half the size of AAA.

Unfortunately I can't get it to pair with the hub. Tried the factory reset, but nothing. Any suggestions for pairing this thing?

1 Like

Boy thatโ€™s an unusual choice of power source.

1 Like

Agreed, but if they paired I would add some to the battery inventory.

Spoke with an Ecolink tech rep, said to, put hub in pairing mode, put in battery, hold tamper and release, but nada. Device claims to be Zigbee 3.0 ST compatible and that was confirmed by the rep, so I wrongly assumed they would work on Hubitat. I will return these devices rather than resurrect the ST hub.

Hopefully @brad5 has the secret handshake.

1 Like

Weird. I even checked the model number to make sure I was correct before I wrote my comment. Did you try doing a factory reset on the eco link first?

I have an extra one in my "box o' sensors" - I'm going to try it right now

1 Like

Did a factory reset per directions

  1. open case and remove battery
  2. press and hold tamper switch
  3. Install battery while still holding tamper switch
  4. When led illuminates release tamper switch
  5. Led should begin blinking (it does)

OK I am glad I am not crazy. I tried pairing it for 20 min without success and I thought "oh great. I blew it." But then I realized I was using the zwave inclusion instead of zigbee. I tried again and it came right up. It comes up as a contact sensor but I changed the driver and it works just fine.

then just to make sure I wasn't completely insane I tested it in a plate of water...

Here's the tag on the box just to make sure we're talking apples and apples

And you're right about the AAAA vs AAA. Shoot. Now I have to go order some AAAA batteries! Ignore the AAAs in the picture.

But why does yours not work and mine does?

Odd. I'm on 224.158, and you?

Same box, same model, no stick on label here.

How did you pair it, cover on, cover off, tamper switch hold or not?

Yes, as well. Cover off. I did a factory reset, then took out one battery and put it back in, not holding the tamper switch, but with the cover off. I got the solid LED and then the flashing three LED and it came right up.

I don't suppose it's possible you pulled a Brad and did a z-wave inclusion by accident? The ecolink water sensor on the HE compatibility list is a z-wave sensor and I had z-wave on the brain.

@brad5 can you change the driver to "Device" then save, get info, then go to logs, Show past logs and get the device fingerprint. Then post it here and tag @mike.maxwell and he can add it to a future release so you will not have to manually select Generic Zigbee Moisture Sensor when pairing. Of course remember to switch the driver back once you get the requested info.

I tried a Zwave include when it would did not pair, thinking it may be the wrong device in the box. Nothing.

Followed your instructions, but failed again. Just to be sure the hub is OK i had a bunch on Linkind Contact sensors that need to be paired and one immediately connected.

I have to go to Whole Foods with an Amazon Return Locker, these may be on their way back soon.

@mike.maxwell This is the signature from the zigbee 3.0 Ecolink wireless flood sensor model FLZB1-ECO.

2020-12-29 01:09:46.621 pm infofingerprint profileId:"0104", endpointId:"01", inClusters:"0000,0001,0003,0020,0402,0500,0B05", outClusters:"0019", model:"FLZB1-ECO", manufacturer:"Ecolink"

1 Like

I'm sorry I inadvertently led you astray. Still really weird I was able to pair a bunch of them. Could proximity to the hub be a factor? I was pretty close to mine.

Not your fault, perhaps different device firmware.

Pairing was attempted about 2 feet away from the hub.

I looked to see if I can see firmware revisions and I can't... which of course would do you no good if you can't get the thing connected.

Appreciate your assistance, thank you.