Ecolink zigbee flood sensor

On the plus side I now have a spare water leak sensor already connected and ready to deploy! Been meaning to put one up on the third floor.

Enjoy your "new" sensor, and stock up on some AAAA batteries!

Attempted pairing on the other two devices, nothing. They will be returned soon :disappointed:

1 Like

@arnb and @brad5, are you guys both using C7 hubs ??
This thread has been a real strange read.

1 Like

Yeah it does read strangely... and yes I am using a c7 hub but cannot speak for @arnb. I just got another hub dropped on my doorstep - it's going to be my "non-prod" hub. If I get bored tomorrow I'll plug it in, upgrade it to the current revision, and try it. Of course it worked for me the first time so not much of a test.

1 Like

And @arnb is not new to this rodeo, which is what makes it so interesting.
That and knowing that if I was going through what he is, with multiple sensors not pairing to HE, for sure I would have pulled out the ST hub he mentioned he has, just to reassure myself I was not going nuts. LOL

Yes it is strange, works on a C7, but not on my C4. Very weird and frustrating.

When I get the opportunity I'm going to power up the ST hub, attempt to pair on it, remove the device from ST, factory reset, then retry on HE.

Mr Peanut just showed up at my door.


You are running a C4 and I am running a C7? Well at least that's a data point. Otherwise I'd be asking if it was because of the full moon.

1 Like

I have good news and bad news: it pairs on ST. Requested a download "for best results", shows status, temperature, and battery percentage. ST hub returned to HA purgatory. I would wing it with ST but the area of concern, the basement, gets a Zigbee signal from a zigbee plug / repeater paired to HE.

Retried pairing on HE, nada.

What is super odd is the Amazon description says these run on CR123A batteries.. hmm..

1 Like

Hey @brad5, we may have different device models. Your photo shows three AAAA batteries, my device has a slot for two AAAA batteries.

Two AAAAs in mine as well. Those were three AAAs I had sitting out on the counter unrelated to the sensor. Sorry for the confusion.

1 Like

My wife just gifted me this Ecolink zigbee 3.0 for my bday. I was able to install it using the generic Zigbee driver and it worked. I test it in water and it was changing from wet to dry. For the last 4 days I tried to test it again by using the generic Zigbee water sensor driver and I found the zigbee aqara water leak sensor driver works with it as well, but using either driver will work for that day and then stop. Anyone having this issue?

How far is this from your Hubitat? How "solid" is your zigbee mesh? What devices do you have as zigbee repeaters/routers? Some zigbee end-devices are picky about the zigbee repeaters/routers they will use.

Most of my devices are zigbee but as far as repeaters go I have 3 of the Ikea TRADFRI Control Outlet. 1 is in my living room "avg size living room" the hub is on 1 end and the plug is on the other end and I would say it's about 12 feet away. then I have 1 of the outlets in my basement where the leak sensor is. and another in my bedroom, what I notice is that the outlet the outlet in the basement when I check the logs, it's showing that it's hoping on other zigbees, but it ever shows the sensor. How it's setup it's all on the same side of my basement. I have the Tradfri outlet, then a couple feet away it hops onto my peanut plug which is connected to my washer and my utility sink is next to the washer and I have the sensor on the floor under the sink.

I'm using this driver

I'm not sure what that Last Activity at 2/6/21 at 11:51 is about because I tried putting the sensor in water while typing this and it didn't go off.

What driver are you using with yours?

I switched the driver back to the generic, with the 3 recent updates we had I want to see if it helps. so I will know if it' still a dud by tomorrow because it works once I switch drivers the 1st time and then it goes off by the following day.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.