Echo speaks help plz

Hi Adam,

I was wondering if you could look at my post below and offer some advice.

Thanks in advance


Hi Bruce :slight_smile:

Just to confirm, you've got both the Driver and App installed? I presume so, just want to triple check.

Hi Adam,

Thanks for the reply. Yes on the installed driver. Please see attachment 1.

App seems to be loaded and sees all of my amazon universe. This is attachment 2.

Attachment 3 is today's error log. I keep trying random things on the Herku server and even re-out the app.

I'm willing to restart from scratch if you so advise.



Hmm, that's a real peculiar situation—it seems to be communicating fine with heroku... I'm not sure why it wouldn't work.

My only suggestions would be to try and clear your Heroku amazon account settings, and try that part of the process over:

Otherwise, it might be worth to reach out to the developer at his Report Issues page.

Hi Adam,

Thanks for the reply.

Followed suggestion 1. Went to the Heroko login, accessed the login page, cleared the cookie and logged in again. Received confirmation that the cookie had been accepted by Heroku. No change in operation of the app. Please see latest posted logs.

Second... posted the issue to : ... The developers home page. Looks like I've got lots of company...!

Overall, this looks like a protection issue to me somewhere, somehow. Hope the developer can help. Made a donation even. Would be worth it if the app worked for me... still someone went through a lot of effort to make an innovative bridge app.

Even though we seem to be at an impasse, I do appreciate your help!




If you want TTS only, you can manually refresh your cookies every 14 days (at a maximum, 14) and use the other driver in the meantime:

It’ll even let you run a local node server to automatically refresh the cookie, if you’re into that.

Maybe you could get that local part working on Heroku, even!

Hi Adam,

Well... we had a Hubitat update or two over the last few days and the Echo show is starting to respond a little. I cannot determine if this is cause -> effect.

After the update, I went to the device itself and accessed the configuration settings. There I found I can trigger the Echo Show to tell me a joke, tell me an interesting fact, and search for music. I can also remotely control volume. So Hubitat is talking to Alexa and Alexa is speaking through Echo. I'd guess that the app is not talking to Hubitat.

Still no TTL.

My plan for the next iteration is to review what it takes to delete and reinstall the app and retest. Then if it works, it was an install issue or demons or bad karma.

I'm also waiting for the developer to respond but it appears he has somewhat of a backlog.

I'll write up what happens next in this thread.



I see there was a new version released. Have you tried that, yet?

Hi Adam,

Completed the update. Running

  1. I have deleted the app from my system.
  2. Loaded the app in Hubitat and reloaded the Heroku server. Connected the Heroku to Amazon. Tested and found that the test feature in IN THE APP WILL NOT SEND TTS to the Echo Show. I can send TTS through the device configuration page as well as trigger jokes, interesting facts, and calendar summary.
  3. Again, deleted the app from my system. (I'm getting pretty good at this....)
  4. Rebooted Hubitat.
  5. Loaded the app in Hubitat and reloaded the Heroku server. Connected the Heroku to Amazon. Tested and found that the test feature in IN THE APP WILL NOT SEND TTS to the Echo Show. Essentially, same behavior as above.

Here are the error logs:

Waiting for the developer to respond on: Nothing happens (HELP) · Issue #76 · tonesto7/echo-speaks · GitHub



Working perfectly! Love it

1 Like

I'm glad it's working! This project is a brainchild of @tonesto7, though :slight_smile: I just like to help people set it up.

1 Like

Did you ever figure this out? I'm having the exact same issue.

It might be worst also checking with Tonesto7 in the primary Echo Speaks thread. There are quite a few tips and tricks in that one :slight_smile:

Hello - I saw your old post about "you like to help people regarding Echo Speaks". I am rather new at this and recently installed echo speaks. I am having problems with the search actions. I can search for WBMW under Tunein using the HE defined device itself without issue. However using Echo Speaks it seems that the search info is not getting passed to the command: 2020-05-25 11:48:03.005 am errorgroovy.lang.MissingMethodException: No signature of method: user_app_tonesto7_Echo_Speaks___Actions_258.executeTuneInSearch() is applicable for argument types: () values: [] on line 4271 (searchTuneInResultsPage)

Seems I am missing something simple? Any assistance would be appreciated.

1 Like

I know @adamkempenich has been really busy with his real job for a little while now, so it might be a while before you hear from him.

I would recommend posting your issue in the Echo Speaks thread (linked below). The Echo Speaks developer is guaranteed to see it in that thread (as will other Echo Speaks users).


Thanks for the advice. I will do that.

1 Like

Hey all - I'm hoping to use Echo Speaks to allow voice warnings in our bedroom (through an Amazon Echo Show) when our alarm is triggered at night.

I admit to being a relative newb, and I've been having some issues getting Echo Speaks to work.

I installed all of the package components, and tried to set it up, but it keeps telling me that I'm not logged into Amazon ("Complete the Authentication Process"...)

But when I follow the links to sign in it just brings me to a Heroku page where it says "There's nothing here, yet..." ...I have no idea what I've done wrong...any hints? :stuck_out_tongue:

I'd recommend posting in the main Echo Speaks thread, because @tonesto7 follows that thread as do other Echo Speaks users. The link to the latest release is below.

You need to setup the Heroku server.

I'd point you to the documentation, but it is currently being updated and the developer @tonesto7 asked not to use the documentation site for now.

Funny enough - like 20 minutes after I posted this I got it working! thanks!