Echo speaks help plz

I’m trying to find the instructions for the install process of echo speaks for HE I found the instructions but they seem to be for smartthings or are they the instructions for both platforms?

For both. :slight_smile:

Install the driver code, and app code. Go to your Hub Apps page >> Add User App >> Echo Speaks.

The rest of the instructions should be the same.

So just so I have this straight the smart app code would be considered the driver code in HE and the device handler would be the app code in HE am I correct?

Other way around:

Device Handler (ST) = Device Driver (HE)
SmartApps (ST) = Apps (HE)

Install this code into Drivers:
https://raw.githubusercontent.com/tonesto7/echo-speaks/master/devicetypes/tonesto7/echo-speaks-device.src/echo-speaks-device.groovy

Install this code into Apps:
https://raw.githubusercontent.com/tonesto7/echo-speaks/master/smartapps/tonesto7/echo-speaks.src/echo-speaks.groovy

Thanx much for the assistance Adam greatly appreciated this transition of apps was confusing the heck out of me

1 Like

Adam,

re: No signature of method:

My bad... so... you need to "authorize" an imported app before it will load. :thinking:

I deleted my first post because it so clearly demonstrated my "newbee-ness". Thanks for pointing us all to "Echo Speaks"

Regards,

Bruce

1 Like

Thanks for clarifying this as I too was confused on the app since it was talking about SmartThings.
I did get the Echo Speaks Driver Code & Apps Code pasted in and added, but then when I go in to load the user app of Echo Speaks I get "Unexprected Error":

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: No signature of method: com.hubitat.hub.executor.AppExecutor.error() is applicable for argument types: (java.lang.String, java.lang.RuntimeException) values: [getAccessToken Exception, java.lang.RuntimeException: OAuth is not enabled for this App] Possible solutions: render(), getLog(), now(), iterator(), grep(), every()

What am I doing wrong?

Did you enable oauth in your app code?

It's the button next to Save on that page.

Thanks for the reply..I went back and did that then I seemed to open a whole new can of worms! :slight_smile:
I got something setup on Heroku and in HE under apps I get this error & don't know how to proceed:

You are not currently logged in to Amazon. Please complete the Authentication Process on the Server Login Page...

Not really understanding where the Authentication process on Server Login page" is at this point...I click on Begin Server Setup & go all thru that...I see an "Alexa Login" screen at some point and I click on it and I get "nothing there yet"...

maybe Echo Speaks is not for me. :slight_smile: Too tired to fool with it anymore tonight. Thank you again for the reply.

Ok...got it working. What was throwing me off was the "deleting the space" in the app name on the deploy part. I was not seeing the SPACE at the START of the string & thought the docs meant a SPACE at the END of the string...that's what I get for working on this stuff late at night.

Anyway, the Echo Speaks now works as I got the "Echo Speaks broadcast system" message on all of my Echo devices, except my Sonos Speaker with built in Alexa doesn't show up in the list which is no big deal...I'll fool with that device at a later date. Thanks again for the help!

Hi Mojoman and Adam

Plowed the same ground as Mojoman did, independently, and am almost in the same place. At first I was leery about accessing Amazon through the Heroku site. Based on a suggestion I saw in the SmartThings Echo Speak Wiki, I enabled two factor authentication for better security. Feel better now.

Problems still exist. Here is my issue. The App is loaded, Settings are all visible. My Echo Show is detected and available. All looks good. Then, when I attempt the "broadcast test" and slide the blue switch to the right, it slides itself back. Not a peep out of the Echo Show. The error log reads;

" 2019-04-25 23:42:38.467
[error (http://192.168.1.225/installedapp/configure/114)groovy.lang.MissingMethodException: No signature of method: user_app_tonesto7_Echo_Speaks_67.setAuthState() is applicable for argument types: (java.lang.Boolean) values: [false] on line 1096 (amazonCommandResp)"

While the looks somewhat similar to what Mojoman experienced before the app was loaded, it is different and occurs after the app is loaded in Hubitat. I see the "no signature of method", but I thought I enabled oauth when I imported the apps code. I've tried to Google "MissingMethodException: No signature of method" but I get pretty lost pretty quick.

**UPDATE:

Error Log: dev:1972019-04-26 18:53:53.098 warndoSequenceCmd Error | You are missing one of the following... SerialNumber: null**

Currently at a standstill.

Thanks.

Bruce

Hi Adam,

I was wondering if you could look at my post below and offer some advice.

Thanks in advance

Bruce

Hi Bruce :slight_smile:

Just to confirm, you've got both the Driver and App installed? I presume so, just want to triple check.

Hi Adam,

Thanks for the reply. Yes on the installed driver. Please see attachment 1.

App seems to be loaded and sees all of my amazon universe. This is attachment 2.

Attachment 3 is today's error log. I keep trying random things on the Herku server and even re-out the app.

I'm willing to restart from scratch if you so advise.

Regards,

Bruce

Hmm, that's a real peculiar situation—it seems to be communicating fine with heroku... I'm not sure why it wouldn't work.

My only suggestions would be to try and clear your Heroku amazon account settings, and try that part of the process over:
https://tonesto7.github.io/echo-speaks-docs/#/docs/support/commonErrors

Otherwise, it might be worth to reach out to the developer at his Report Issues page.

https://tonesto7.github.io/echo-speaks-docs/#/docs/support/reportIssues

Hi Adam,

Thanks for the reply.

Followed suggestion 1. Went to the Heroko login, accessed the login page, cleared the cookie and logged in again. Received confirmation that the cookie had been accepted by Heroku. No change in operation of the app. Please see latest posted logs.

Second... posted the issue to :https://waffle.io/tonesto7/echo-speaks/cards/5c8ab6d3b2608e00330db8e9 ... The developers home page. Looks like I've got lots of company...!

Overall, this looks like a protection issue to me somewhere, somehow. Hope the developer can help. Made a donation even. Would be worth it if the app worked for me... still someone went through a lot of effort to make an innovative bridge app.

Even though we seem to be at an impasse, I do appreciate your help!

Cheers,

Bruce

pdf_page_1|386x500

If you want TTS only, you can manually refresh your cookies every 14 days (at a maximum, 14) and use the other driver in the meantime:

It’ll even let you run a local node server to automatically refresh the cookie, if you’re into that.

Maybe you could get that local part working on Heroku, even!

Hi Adam,

Well... we had a Hubitat update or two over the last few days and the Echo show is starting to respond a little. I cannot determine if this is cause -> effect.

After the update, I went to the device itself and accessed the configuration settings. There I found I can trigger the Echo Show to tell me a joke, tell me an interesting fact, and search for music. I can also remotely control volume. So Hubitat is talking to Alexa and Alexa is speaking through Echo. I'd guess that the app is not talking to Hubitat.

Still no TTL.

My plan for the next iteration is to review what it takes to delete and reinstall the app and retest. Then if it works, it was an install issue or demons or bad karma.

I'm also waiting for the developer to respond but it appears he has somewhat of a backlog.

I'll write up what happens next in this thread.

Regards.

Bruce

I see there was a new version released. Have you tried that, yet?

Hi Adam,

Completed the update. Running 2.0.9.133.

  1. I have deleted the app from my system.
  2. Loaded the app in Hubitat and reloaded the Heroku server. Connected the Heroku to Amazon. Tested and found that the test feature in IN THE APP WILL NOT SEND TTS to the Echo Show. I can send TTS through the device configuration page as well as trigger jokes, interesting facts, and calendar summary.
  3. Again, deleted the app from my system. (I'm getting pretty good at this....)
  4. Rebooted Hubitat.
  5. Loaded the app in Hubitat and reloaded the Heroku server. Connected the Heroku to Amazon. Tested and found that the test feature in IN THE APP WILL NOT SEND TTS to the Echo Show. Essentially, same behavior as above.

Here are the error logs:

Waiting for the developer to respond on: Nothing happens (HELP) · Issue #76 · tonesto7/echo-speaks · GitHub

Thanks.

Bruce

Download the Hubitat app