Eaton RF9640 - No local control

I have an Eaton RF9640-NDW I recently picked up from Lowes. Getting it installed and connected was no issue. It worked great for a couple weeks. Then, for reasons I'm not sure of, it stopped responding to any local controls. It still worked fine when getting it's commands from the Hubitat, but would not work when pushing any of the buttons on the switch itself.

A couple weeks ago I had to turn off the breaker for unrelated reasons. When I turned it back on, everything worked again as expected. Unfortunately, it's now doing the same thing. I can't keep turning the breaker off to make the switch work again.

I've read about a feature that some of Eaton's switches have for doing a child lockout to disable local controls, but I can't seem to find any information about how it works. It's possible that this switch doesn't have that feature and/or that it's not what's causing my issue... but it also seems plausible that it is my issue.

I do realize that this isn't an Eaton support forum and this does seem to be an issue with the switch itself, but I'm hoping one of the smart people on this board can help me out :slight_smile:.

Thanks in advance for any and all help.

Technical documents are links here:

I didn't see anything that would explain what you are experiencing.

Eaton specifications page:

states: "Child lockout feature which disables local control at dimmer" but I see no mention of how this is to be configured.

I had the z-wave RF9540 model and they worked fine for me.
Need anymore?

@Eric.C.Miller - That's what I seem to be finding. I can find a bunch of references (even across different Eaton products) to the existence of a "Child lockout feature" but I haven't been able to find anything about how it works.

@Rxich - That's actually a very tempting offer... the biggest problem I have is that almost my entire house is wired so that the power comes into the light fixture with a single 14/2 wire down to the switch, so there's no neutral available at the switch. This switch went into my daughter's bedroom which I just built, so I made sure to run the power to the switch.

I did much the same, copper romex is expensive as hell. I regret it now, but there was no such thing as a "smart home". The other day my wife said "why are you under the porch with a laptop" and I said I'm fixing the lights. Was excluding a z-wave Aeon relay with a z-stick & pc controller, due to weak hub signal. Insane world we live in

1 Like

I have had this issue (device responds to commands from the hub but does not respond to local commands) a few times myself with the RF9640 and RF9642 devices. I have a lot of these, and it has happened on five or six of my devices so far. I called Eaton technical support to see if they had any sage words of wisdom, and yes, they did! This is a known issue with early firmware versions. All of my devices are V1.00.

They had found this and fixed it earlier this year. [Eaton does not publish firmware updates, so stop looking for them. :slight_smile: ] They said they would send me a new device and when I had replaced it, send them the old device. I explaned I have 40ish devices in my home, and that would be a real pain in the *** to exclude, replace, and include them without totally rebuilding all of my automations. I explained I was very familiar with the OTA firmware update process. A couple of email exchanges later and now I have new V1.11 firmware files for both the dimmer and accessory dimmer devices. They also sent a very detailed document on how to perform the OTA update using the Z-Wave PC Controller 5 tool from Silicon Labs.

I am still in the process of applying the updates, so I haven't road tested it, but I am very hopeful this resolves the issue. Contact Eaton Technical Support. You should be able to get them to send you the firmware files too.

Thanks for this post… that might explain why I am having some issues as well… will try to call them (again!)

Any chance you could send me the v1.11 firmware files?

I have had ~20 RF9640 dimmers for 2.5 years and they have been a PITA. I tried going through support ~2 years ago regarding the nonresponsiveness and got nowhere. I was just about to tear out all of the Eaton dimmers and replace them with Zooz dimmers (which I have had a great experience with), when I saw your post.

I'll try reaching out to support again, but not holding my breath.

What firmware do you have @epicvs on your problem devices?

The problem devices were all on v1.0

I emailed asking for the v1.11 firmware images. They surprisingly responded in < 1 day with the files.

I flashed the new firmware with Z-Wave JS on Home Assistant. The new firmware seems to have resolved most of the issues with the dimmers.

1 Like

@epicvs I’m glad to hear that the updated firmware solved your problems too. :partying_face:

Good Afternoon,

I have installed about 40 + of these RF96 series switches, dimmers, add on switches and dimmers including wall receptacles. I started noticing the issues initially on 3 devices and then now 9 devices, not able to operate manually. There is no hard reset button to reset them. Can you please shed some light here. Worried about the whole investment on these devices.

Thank you,

Any chance to share the fw files? I have 8 devices/accessory switches and the support team keeps asking me to use the airgap switches to recover function and keeps saying that they dont send out fw files :frowning: Maybe I just got a bad CS rep....

Same here seems like we got a bad rep. They are refusing to share the firmware. Can any one of you please share the firmware files? I have about 34 devices (RF9640, RF9601, RF9642, RF9617 and RFTR9605). It is such a pain to keep using the AirGap on the Dimmer and there is no AirGap on the RF9601, RF9642, RF9617. They are asking to hold 20 secs to reset them and then exclude and then reinclude them. I really appreciate if any one of you can share the firmware.

1 Like

This is probably not something you should discuss on the open forums. The manufacturers are very touchy about sharing firmware files.

Tried to email the customer support. I told them I have sync issues and asked if they could share firmware updates. They are refusing to share the firmware files even after multiple requests. They just concluded that I have a faulty hub and closed the case. Anyway to get the firmware files?

Because of the repeated requests and Eaton no longer providing these files to fix their own product, I uploaded the firmware files here:

Obviously, this is at your own risk, I take no responsibility, etc.
And feel free to delete this post if Eaton complains.



• only use these files on Dimmers and Accessory Dimmers that currently have a 1.xx firmware version. This can be seen in Z-Wave PC Controller 5. Using PC Controller and a Z-Wave stick is the method recommended by Eaton. I have no doubt the Hubitat Z-Wave Firmware Updater will be able to apply this too.

• be sure to apply the correct file to the correct type of device. Dimmer firmware applied to a Dimmer. Accessory Dimmer firmware applied to an Accessory Dimmer. Any other firmware/device combination will brick the device. (The voice of experience.)

It isn’t difficult to do, but it can be a bit tedious to do when you have a lot of devices that need updated firmware.

@epicvs, I don’t think anyone from Eaton pays any attention to any of the DIY hubs since they have their own hub and seem to be targeting electricians.

1 Like

I cannot express how grateful I am for you uploading the files. I have multiple of these already installed and this has enabled me to update them through zwave2mqtt control panel in Home Assistant. Thank you!

1 Like