Eaton RF9640-N Z-Wave Plus Univeral Smart Dimmer

I'm migrating from smartthings and have an Eaton RF9640-N smart dimmer that was working perfectly on ST. On Hubitat, I am using the Generic Z-Wave Smart Dimmer driver, but have tried the Generic Z-Wave Dimmer driver as well. In either case, Hubitat will not turn the lights completely off, only dim it to near 0. The paddle works fine, and it worked in ST. Any ideas on this?

Any luck? According to the docs, only the RF9540 is supported, not the RF9640... Am hoping to use this exact combination...

I don't know how this could be a driver issue, but one never knows.
Please try using one of the generic zwave switch drivers just to see if on/off work properly...

Just hooked this up and it works perfectly! I'm using the RF9640-ND with the HALO HLB6099FS1EMWR Ultra Thin Downlight and it turns on/off brilliantly. The only thing I've been unable to get to work is the "Duration" portion of "setLevel" (it's instantaneous, doesn't seem to obey any duration I put in fro 0-2000).

Have you gotten anywhere with this 'not turning off' issue? I have this problem as well.

As a note, I was able to resolve this on another platform. In Home Assistant I was seeing this problem when the duration was 0 / instantaneous. If I set a ramp time of 2-3 seconds to match the physical switch, it turns all the way off.

I noticed the same thing. If you go into "Devices" and perform a Set Level with a Ramp delay of 3 seconds, the light turns fully off. Otherwise, just the normal off functionality seems to leave about 10% of the light still on.

Does anyone know how to change the ramp down rate to use with a Tile?

I found a solution to make the EATON RF9640 Switch work properly (Turning the lights off completely...) by making a very small modification of a custom device driver...

I am using a modified version of the "Any Z-Wave Dimmer Driver v1.1.8" written by @jvm33 found here : Link to Driver

The modification I made to the code is just on one line... I replaced line 1102 from the code :

else sendSupervised(zwave.switchMultilevelV1.switchMultilevelSet(value: newValue), params.ep)

with the following :

else sendSupervised(zwave.switchMultilevelV4.switchMultilevelSet(value: newValue, dimmingDuration:1), params.ep)

Forcing the "dimmingDuration" to 1sec in that command is making this driver works properly for the EATON RF9640 on my C-7 hub (correctly removing the residual current and fully / properly turning OFF the switch).

Check-out this driver... Pretty complete... Impressive work by @jvm33 (Thanks!) !!!

1 Like

Maybe contact the support department of Eaton, report the problem, and ask if a firmware update is available.

Yes, I did this... Eaton's feedback is that there has been no firmware update since the switch has been release and that since the switch is working fine when turned OFF physically, the problem is with Hubitat... Thus their resolution is for me to contact Hubitat to resolve this issue...

FYI - I put that Eaton response through my "customer service translator" app and it gave me this:


1 Like

That worked great. Thank you!