[DRIVER] Zooz ZEN Switches Advanced (and Dimmers)

Looks like the first byte of the devicetype is missing, in hex it should be 0xA004 but it is just 0x04. I would reply back to Zooz on the email they sent you the update with this info.

If you just newly paired this device (I think you did), I would say step one might be to exclude and pair it again. Maybe the deviceType got cut off when it paired somehow. If it happens again I would say it is a firmware issue and you might have to revert back to 10.0 to fix it.

1 Like

At this point i have paired it about 5 times. I will reach out to Zooz for help and see what they say. Hopefully it won't take to long to get a response.

Thanks for looking at it. It is a shame if this is a firmware problem. It does fix the ability to set level and have it do it over a period of time.

@agnes.zooz Is the parameter “ Disable programming from paddle” available for the zen22 dimmer yet? My kid keeps changing the settings. Driving the wife mad. Gotta get it fixed, preferably without having to swap the zen22 for the zen27.

Yes it is, please reach out to us here with your order number and we'll send the firmware file your way.

So I went through the process to upgrade the firmware. I got the status saying that the device was flashing, which i believe is the last message. I gave it a while just to be sure, then changed the device type back to the advanced driver. Now all I get though is a syncStatus of 8 pending changes (hitting Configure doesn't resolve this), and the firmware still seems to show 3.3. Not sure what to do now....

The firmware updates sometimes will force a factory reset so the device has to be paired again. See this post if you want to get it back into the same node: [Guide] Updating Zooz Firmware and ZWave Replace

2 Likes

Ok, I updated the firmware of zen22 to 4.04. I don't see any “ Disable programming from paddle” setting in the parameters, though. Where/how I am supposed to configure this?

@JustinL looks like I just happened to guess they would add that in 4.04, but you will need to update to my beta driver posted above: [RELEASE] Zooz ZEN Switches Advanced Drivers - #221 by jtp10181

You will need to do a refresh after updating and confirm the firmware at version in the data section at the bottom shows 4.04 or higher.

2 Likes

That did it. Thanks!

I just got a Zen74. Using the regular Zooz driver, it works fine. However, whenever I change to yours, it gets stuck in "pending changes" and doesn't work. Changing back to the default driver works.

I then figured maybe it's because of an old firmware so I just updated the firmware to the latest version (version 10.0). No difference. It's still stuck with "6 pending changes" using your driver.

Finally, I tried using your beta driver but still doesn't work. Please any guidance on how to get your driver working for the Zen74?

BTW, I've been hitting "Configure" after each update (changing driver or firmware update).

Here's the log after hitting Configure (appears it doesn't actually getting the parameters from the dimmer):

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.901 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing associationReports (#7) from null to 15

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.896 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing paddleProgramming (#26) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.892 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing smartBulbDimming (#20) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.888 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing smartBulbBehavior (#21) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.884 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing loadControl (#15) from null to 1

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.880 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing sceneControl (#13) from null to 1

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.876 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing nightLight (#22) from null to 5

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.872 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing customBrightness (#18) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.868 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing singleTapUp (#25) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.864 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing doubleTapBrightness (#12) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.860 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing maximumBrightness (#11) from null to 70

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.856 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing minimumBrightness (#10) from null to 1

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.852 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing holdRampRate (#16) from null to 5

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.848 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing rampRate (#9) from null to 1

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.844 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing powerFailure (#8) from null to 2

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.840 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing autoOnInterval (#5) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.836 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing autoOffInterval (#3) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.832 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing ledBrightness (#24) from null to 1

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.827 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing ledColor (#23) from null to 1

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.823 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing ledMode (#2) from null to 2

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.819 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: Changing paddleControl (#1) from null to 0

[dev:2891](http://192.168.1.222/logs#dev2891)2021-11-04 12:25:54.807 pm [debug](http://192.168.1.222/device/edit/2891)Bathroom Dimmer: executeConfigureCmds...

Thanks!

Looks like the issue was with the LED parameters (parameter 2, 23 and 24). Zen74 doesn't seem to support those (https://www.support.getzooz.com/kb/article/648-zen74-toggle-dimmer-700-advanced-settings/). I commented those lines out and a few others and then, the driver worked.

Although not documented there is actually an LED indicator inside the ZEN74. You would not be able to see it with a cover plate on the switch though, and the default is for it to be always off. When I tested it those parameters did work but I will have to confirm if they still work on the current firmware.

For the beta driver (which I need to just finish and make official), I have an easy way I can shut those parameters off for specific models.

Also, even if it says there are "Pending Changes" the driver itself would still function 100% otherwise, the pending changes does not prevent any other features from working.

3 Likes

That is not exactly right for the Zen74. If you turn on the LED it will shine out around the toggle switch. It isn't very bright though. I actually have it turned on for a few of my a zooz toggle switches. It can be a nice addition when it is pitch black.

FYI. I just reverted back my Zen74 to v10.0 of the firmware and all is good again. v10.1 just had problems. Hopefully get the kinks worked out of the V10.1 so we can get proper fade over time

Good to know, I have only had mine in a test rig without a cover-plate so I was assuming it would not be very visible.

If you have not already report the issues to Zooz. I have a ZEN74 and the updated firmware but I have not had a chance to install or test it out yet. I don't actually have that switch installed in the wall yet.

I have several emails with them about it after you responded to me. I believe they are fully aware at this point. They had to send me the old v10.0 firmware for me to roll back since i was on 1.2 previous as that is what my switch came with. Hopefully fixing that identification information isn't to hard. Either way at this point i wouldn't suggest upgrading to 10.01 or at least not until some more time has passed.

It took them less then 24 hours to respond to me the last time after i confirmed the rollback fixed what I was experiencing. I provided in that response v10.02. This does appear to have fixed the problem and have the udpate to allow proper setlevel over time. So that is good. I would point out most of the delay has been on my part as well to get this resolved. Zooz has been very responsive.

RELEASE:

Updated on HPM, for ZEN Switches/Dimmers only, ZEN30 no update.
If you were running the beta version, there are only minor updates to this final release.

Version [1.5.0] - 2021-11-24

Added

  • ChangeLevel capability support so level can be adjusted from button holds (Dimmers Only)
  • Warning if driver is loaded on unsupported device (including wrong type)
  • Added support for new parameters where applicable, Disable Programming from Paddle is the big one.

Changed

  • Total overhaul of parameters code to make it easier to maintain
  • Changed switchMultiLevel class down to V2 as no V3 features are needed (Dimmers Only)

Fixed

7 Likes

Thank you for this driver! I'm having as issue with it. I have many Zooz 77 dimmers. I like to have them set up so that a single tap turns to full brightness, and a double tap turns to a pre-set brightness. I've done this by adjusting parameters 12, 18, 25 with the Advanced Driver (v1.5):

The issue I'm having is that when I double tap, the light first goes to full brightness, then dims to the set level, instead of turning on directly to the set dimmed level. This is really annoying at night, since I use the double tap to go into rooms where I don't want to turn the light to full brightness.

When I change over to the built in Zen77 driver, it behaves as it should (single tap to full brightness, double tap to pre-set dimming level). Contrasted with the Advanced driver behaviour on double tap that first turns it to full brightness, then dims to the pre-set dimming level.

The same driver, same settings, with a Zen72 dimmer works as it should (goes straight to preset dimming level with double tap, instead of first to full brightness, then to dimming level).

Firmware on the dimmers is 10.0

Is there something I should change, or is this a driver issue?

I am not at home this week to test, but you enable debug logging and get a screenshot of both cases on the ZEN77 and post it.

The parameters are set directly to the device, and I assume you are setting them with my driver and they are not being changed when going to the stock driver. So that should not be a variable. The actual native single and double tap up features those parameters set are totally firmware level, the driver has no part in telling the switch what to do once the parameters are set, so that should not matter between drivers. When you tap the switch physically it does its thing and tells the hub what it did, the driver itself does not send any commands back in this case.

The ONLY thing I can think of is that you setup a button controller or rule, to act on button 3 pushed and have the scene control enabled (param 7). This would possibly only trigger with my driver because I think the stock driver sends a "doubletapped" event and not the button 3 pushed.

Also, it looks like you have modified the driver, as your param 12 and 25 marked "DEFAULTS" are not the actual defaults in my code.

Thanks Jeff.

I forgot, I had modified the defaults, to save time since I wanted the same behaviour in all my switches. I've restored to your original code for the purpose of debugging.

As I was compiling this response, I could not get the desired behaviour out of either driver this time. I could swear before I wrote my original email, I had confirmed this behaviour. So I'm guessing it's a firmware issue then with the Zen77. Looks like with a double tap, it registers a single tap then double tap. When I switch the single tap and double tap behaviour, the bug persists (single tap brings it to full brightness, double tap brings it it custom level, then to full).

Desired behaviour:

  • Single tap: Full brightness
  • Double tap: Custom brightness (set by param18)

Case 1:

  • ZEN77 dimmer with driver: Zen Dimmer Advanced v1.5:
  • Behaviour:
    -- Single tap: turns on to full brightness
    -- Double tap: turns on to full brightness, then immediately dims to custom brightness level.

Case 2:

  • ZEN77 dimmer with driver: Zooz Zen77 Dimmer
  • Behaviour:
    -- Single tap: turns on to full brightness
    -- Double tap: turns on to full brightness, then immediately dims to custom brightness level.

Case 3:

  • ZEN72 dimmer with driver: Zen Dimmer Advanced v1.5:
  • Behaviour:
    -- Single tap: turns on to full brightness
    -- Double tap: turns on to custom brightness level.

Case 4:

  • ZEN72 dimmer with driver: Zooz Zen77 Dimmer
  • Behaviour:
    -- Single tap: turns on to full brightness
    -- Double tap: turns on to custom brightness level.

After all that, now to me it looks like your driver is not the issue here. Sorry for dragging you into it. Thanks again for the awesome driver!

Download the Hubitat app