[DRIVER] Zooz ZAC38 Range Extender (and Power Outage Monitor)

When I refresh the device, the only information returned is the battery charge. It seems to only report power source info when the power source transitions from one state to another. Is there a way to have it return power source info upon receiving a refresh?

Turn on debug logging and you will see it. My drivers hide duplicated events from info logging, unless it is a forced event (which battery gets forced).

Thanks. So even though the info log will not show it, the power source status is being updated, correct?

Yes, the refresh asks for an update and the driver sends the event to the hub every time it gets the report from the device. The event is not "forced", so if the state is not changing you do not see it in the event log. I mirror that behavior with the logging, it hides the info log if the state does not change, which keeps your logs clean.

1 Like

I just picked up a ZAC38 and did exactly this. Thanks for posting!

PS why do these things look like little piezo speakers? What's up with all those holes?

1 Like

I have been curious too. Maybe I'll take one of mine to bits and see what's inside. It sure looks like there's more to it than just a battery.

1 Like

I added the package, aside from the above rule mentioned above to push notifications to my phone, can I get the device in HomeKit to push HomeKit alerts or anything?

I have a generator and just want to be alerted when the power switches from battery to mains so I know I can go unhook my generator.

Probably, with the Homekit integration. Not sure what Apple will let you do with it for automations, I dont use the HK automations. If its not doing what you want you could always create a virtual switch or contact sensor in HE, and then have that go on/off with a rule based on the powerSource. Share that to HK and then make an alert when the switch changes status.

Doesn’t look like the sensor gets exposed to HK with the integration - I’ll have to look into options thank you

@jtp10181 - quick question. Does the power attribute work with a C-5? I had tried the Ring Extender that it did not report power state on a C-5, so I wanted to confirm. Thanks!

I don't see why it wouldn't, the only difference is you cannot use S2 on the C5 otherwise the device would not know the difference between hubs. The device should work fine with no security. I am surprised the Ring did not work, it should have, unless it requires S2 for some odd reason.

That was it.

Strangely, it worked for some, but not others, but S2 was always stated as the reason why. Obviously, the mostly-closed support was why it was never totally figured out, and also why I ditched all my Ring REs for the Zooz.

1 Like

Not sure why either... I got a reply from @bobbyD that Ring Extender (v2) was not compatible with the C-5. I had paired it but the power attribute was not updated until I went to the device page and hit "Save Preferences" (or something like that). It would then not "unpair" and I had to use a Z-wave stick to remove it.

@JB_TX - do you have them paired with a C-5 by any chance?

No, I don’t, sorry! I’ve moved to the C-7.

1 Like

I think the more important question is, if anyone is using it without security. I have mine paired with S2. I am sure others are using without security and without issues or we would have heard about it.

1 Like

Mine is paired without security on my C-8, no issues

2 Likes

Thanks - just ordered it. Hopefully it plays well with the C-5 :crossed_fingers:t3:

Hey Jeff, @jtp10181

Great driver! Thank you for all the stuff you do...

I have 4 of these now and all appear to be working properly, but they don't show proper attributes in @tony.fleisher's Z-Wave Mesh Details App. Not sure if its something in these devices, the driver or the app.

I have quite a few Zooz devices and use your drivers for all of them. They all show correct attributes in the app, just not these extenders.

Its really more of an OCD annoyance so not a super big deal... I'm referring to the listening, beaming, FLiRs and Z-Wave Plus sections to be exact. They show "NO DATA" for these devices.

I believe that's all in the inClusters area and all of that is populated on the device page. It looks like it is all there so not sure what the deal is...

This is what I have for all four of the ZAC38's

inClusters: 0x5E,0x85,0x8E,0x59,0x55,0x86,0x72,0x5A,0x87,0x73,0x9F,0x6C,0x7A,0x71,0x80,0x70,0x22**

Did you go into the app and authorize those devices after adding them? I just turn the setting off, and then back on, then click all Zwave devices again to just pick up anything new.

Seems to be working for me (this is debug info for the device)
image

1 Like