Driver Save Takes an Hour

Attempting to update the driver below, the spinning wheel never ends. Nothing in the logs. Not sure what I should do.


There are 6 drivers it all of them or only some?

Could be that the hub is having issues connecting since he uses his own site for hosting instead of github. Maybe post in that thread?

1 Like

I didn't post on that thread because I'm looking for generic guidance on driver imports taking forever, as this is not the first time I have experienced this issue.

Doesn't appear to be a network connectivity issue.

I was able to import all six drivers without an issue. I've actually never had an issue importing drivers nor app code.

@bobbyD is there anything available through the engineering logs around imports that could be looked at?

My website seems to be up and I can access all the drivers... Import would be one at a time. Is there one specific one or are they all causing trouble?

My recommendations are:

  1. Try again.
  2. Try with one of the other drivers, then come back to whichever one(s) are not importing.
  3. Close the browser window, reopen it, and try again.
  4. Close the browser entirely, reopen it, and try again.

EDIT: Due to @FriedCheese2006's feedback:
I have not had an issue where import spins... but I HAVE had issue where an import does not bring in the "latest greatest" driver but instead uses a cached one from the last time you went to the driver page. But never a problem like @Busthead is hitting.

Started with the UnifiProtectAPI.groovy parent driver. Finally finished importing, after about an hour?

Trying Child driver now and spinning, spinning, spinning...only took 10 minutes this time.

Something with my hub, not the drivers?

@Busthead Is your hub network set for Auto or Fixed 100? If It's set for fixed, change it to Auto

1 Like

Sorry, I don't know what this is.

He's referring to this setting on the Networking page from the Settings menu.

1 Like


Ethernet speed is set to Auto.

1 Like

Is your hub on DHCP or static?

1 Like


To clarify, the code Import is instantaneous. After clicking Save I get the extended spinning wheel.

Based on this screenshot, it looks like your hub is reporting that it is under high load. If it is experiencing a high load I could see it taking a while to do anything.

Have you tried rebooting? Is anything else slow? Might try a soft reset and DB restore, in case there is some sort of corruption.

Please try DHCP, and do the address reservation in your router instead. It is very easy to misconfigure Static, and lots of people have been bitten by this lately.

Time for a soft reset :laughing:

How many States are you saving on that Unify driver? I would set them to 1 or 2 and see if that helps. I am not familiar with that driver, is it maybe polling too often, or not finding the device? I have had cloud devices go offline, and start consuming huge amounts of memory.

1 Like