Driver/Pairing -> MHCOZY 4 Channel 12V ZigBee Relay Switch

hum says relay 1 only?
Relay 1

Change the driver to "Generic Zigbee Multi-Endpoint Switch". Then hit the button "Configure" on the device page. "Device" is the wrong driver. Apparently when you paired the device, it didn't pair with the right driver.


Where do I find the driver "Generic Zigbee Multi-Endpoint Switch"

Device by type?
Device by brand?
Manual zigbee ?
sorry for so many ?
thanks for the help

The Device Settings page, "TYPE".


Change to the multi-endpoint driver here.

1 Like

Think I found it:
Add device>Type>Switch>Generic/Other (7)> "Generic Zigbee Multi-Endpoint Switch"
the open device and "Configure" save.
Hum still having trouble. Going to try a Hubitat reboot

1 Like

Thanks that helped. Kinda works. Relay 1 flashed then turns on Relay 4 ?
Your guys are really helpful thanks.

Did you do the Configure after switching the driver (device type)?

1 Like

Yes, but will remove and try it again.
Should I add it by Brand or Type ?

Here is what showed up in Device page

Think I found why! Had to go back to Dashboard and add device 1 and 2 and 3 and 4
seems to work.
You guys are really helpful Thanks!

1 Like

In the future if this happens to another device, you don't have to remove and reinstall it. That likely won't do any good. The Device driver is just a placeholder if it cannot properly match a device to a driver fingerprint. If it didn't recognize it the first time, the second or third is not likely to go any better. All you have to do is go in and change the driver to the correct one, hit Configure, and you should be all set.

1 Like

Thanks, that will save a lot of time.

1 Like

Is there a fix for this Bug using Basic Rules machine.
More than Likely I'm using it wrong?
I tried turning on multiple Relays with Basic rules machine at the same time say 1PM
relay 1 and relay 2.
Relay 1 ON only for an instant the relay 2 Turns ON and stays ON.
Next test programed two separate ON times one minute apart.
Does the same thing: Relay 1 is on for one minute, when Relay 2 turns ON relay one turns OFF.

It sounds like this is in garage door mode.

These instructions don't make any sense to me, maybe someone else has changed modes?

  1. Default inching Function: Press the open relay by mobile phone, then cut off the pull-on immediately(default one second)
  2. Self-locking mode: trigger to Turn on/off connected devices
    3.Interlock mode,wifi remote motor forward and reverse
1 Like

Thank you, doesn't to me either.
1 ) Didn't plan on having a mobile app?
2) What the heck is garage door mode hi hi
3) Need better instructions if possible.

It didn't come with instructions?

1 Like

Other than powering and pair none.
Found the mode switch on the board.
Seems to have three modes.
Just found one that lets me (with the buttons on the board) turn all the relays on, and they stay on, until I turn them off. So back to Rules machine to see what happens.
that may have fixed it, I will post here if it did.

@neonturbo is correct. This is an issue with the hardware configuration of the relay, and cannot be addressed in Hubitat.

These MHCOZY relays have two modes (maybe 3). Basically, they can work as:

  1. An inching relay, i.e you turn it on, and it turns off after a preset time determined by the hardware.
  2. A latched relay, i.e you turn it on, and it stays on until you turn it off.

These two modes are controlled by a button on the relay. Apparently you want it to be in latched mode.

Inching mode is most often used when someone needs a momentary switch, like if they are controlling a garage door opener.


Here is how I did it! Rules machine now works with the board.
By the way this article clears it up.