Dimmers Randomly Freeze

I have had a very strange situation now for many years, and nobody seems to have been able to resolve it. I'm reposting because I found out that it's not just me - in fact there are several others experiencing exactly the same thing. See an old thread from 2020, posted by the CEO of Inovelli, where he states a number of customers are experiencing this same issue as me:

The mystery appears to have never been solved, so I am hoping to reopen the investigation here and see how many others have the same issue. Let me state first that this is clearly NOT a manufacturer-specific issue (see below).

My original system, built 10 years ago, had around 20 old Linear single-pole dimmers on my Hubitat C5 (now C7), together with another 40 or so three- and four-way dimmers and a bunch of other regular Z-Wave switches (not dimmers). After a couple of years, all the Linear single-pole dimmers started randomly causing the lights to continuously fade slowly up from zero to 100 and then back down to zero. This would happen about once a month.

I thought the problem was the crappy Linear dimmers, so I replaced them all with a combination of Inovelli, GE (Jasco) and Leviton dimmers. Lo and behold, every one of these dimmers now randomly freezes in the exact manner described in the Inovelli thread, on average about once a month or less, and under no specifically identifiable condition. When I reset the switch (via air gap or breaker) everything returns to normal.

It is very important that I mention that, over 10 years, I have not once had a three- or four-way configuration freeze, nor have any non-dimmers ever frozen. It is only the multiple brands of dimmers on a single pole that freeze, and it appears to continue to remain an unsolved mysery. Further, I installed a very basic Hubitat system in my sister’s apartment 18 months ago, and it happened exactly once so far, on a single-pole dimmer as well. It’s very frustrating that nobody has been able to resolve this issue.

Any insight would be most welcome!

This sounds to me, and I'm no expert, that the "Flash" command has been activated somehow.

The Flash command can be seen on the default Hubitat driver.

I just replaced @JasonJoel 's driver, which doesn't offer that command, with the Hubitat driver, and "Flash" had that behavior.

However, the device page still allowed me to turn it off.

Let me say also that this same single pole switch has been a little problematic after power outages: It'll turn itself on. I believe it's still responsive to commands though.

Thanks for the insight. I can't see how the "Flash" would be activating randomly though, or why "Flash" would cause the physical switch to lock-up. Also, I am using the brand-specific drivers for each of the GE, Leviton and Inovelli switches. No harm in trying switching drivers again, I suppose, but I'm not hopeful.

I just made a rule in rule machine where an action would call the Flash command.

When I tried it the dimmer switch with @JasonJoel 's driver, it had no effect.

When I installed the Hubitat system driver noted above, (with the flash command button), it would flash.

Additionally, it would not turn off from the physical switch.
It does turn off from the device page.

Question: Do each of these brand-specific drivers have Flash command buttons on their device pages?

edit: This could be a question that @bcopeland may have some insight.

I just went to those drivers, and they do indeed have "Flash" command buttons.

When I installed the Hubitat supplied Generic Z-Wave Plus Dimmer driver: no command button and no effect by my test action.

So, I think there's a problem with the driver.
If the Generic can do it for you, excellent!

This really is in @bcopeland 's bailiwyck.

The drivers have a Flash command, but what you described is not the issue. I should actually correct my original post - it's not just the physical switch that locks up. The switch is completely unresponsive both physically and through Hubitat.

I should also note that it only locks up/freezes in the off position, never when the switch is actually open.

"Off position"??? What is that on these dimmer switches? There is no visible on or off position.

So, when it happens, you've tried using the Device page to turn it off?

I appreciate your work on this. As I said, though, the switch becomes unresponsive both physically and through the app, and it always and only freezes up from the "off" position. As I also indicated, Inovelli acknowledged this issue, but never seemed to find the problem. Seems unfathomable that it's a driver problem with all of Inovelli, Leviton and GE devices and drivers.

"off position" as in "when the switch is turned off (and the switch light is on, indicating the switch is off).

To you perhaps.
They're all the same driver, tweaked, in all likelihood. Perhaps carrying a bad gene, lol.

The physical switch is frozen. Neither the device page nor a physical tap of the switch does anything. The device stays locked in off, with the indicator light on the switch indicating the circuit is off.

This used to happen to my Zooz ZEN27 dimmers all the time, not sure if it was Zooz firmware or HE updates but at some point it totally stopped happening.

What model hub and platform version do you have? (I have a long shot hunch but its only for a specific hub).

Rather than guessing (though I do agree it seems unlikely): the "Events" button on the device detail page will take you to the device events page:

Somewhat contrary to its name, you'll see both events (which you don't really care about for this purpose) and command history on this page. You'd be particularly interested in anything with "command" in the "Type" column and "command-flash" in the "Name" column.

Thanks. As expected, there are no unusual events in any of the switches before they locked up, or that may have triggered a lock-up, nor are there any unexpected "flash" commands. It remains a mystery.

@cjlist :point_up_2:

It's a C7,

Is Z-Wave firmware up to date?


The instructions in the link you provided are very confusing.

It says:

If you have a C-7 hub and already updated to 2.3.8, prior to version, and you have a button on the Z-Wave Details page to "Update firmware," you will not be able to update the radio firmware to version

I did update to 2.3.8 before, but I do not have an "Update firmware" button in the Z-Wave Details page, so I'm not sure where that leaves me. According to your comment, it means my Z-Wave firmware is up do date, but it looks like my firmware is 7.14 but should be 7.18:

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:14, firmware0Version:7, firmware0SubVersion:14, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])

I'm confused.

@bobbyD is 7.14 zwave firmware one of the non-upgradable hubs? I forget which version that was.

It seems like the other one that came up the version report was all screwy looking and this one looks normal.

There is another endpoint you can check for the update flag I will dig it out tomorrow.

So I suspect if you can get the z-wave firmware updated it will solve a lot of the issues. I feel like thats when mine stopped locking up as well.


Check the 'pretty-print' box if your browser has it and look for 'isRadioUpdateNeeded'


I think thats what determines if the button shows up or not, so I think it will be false. It is odd that yours is not showing.

Here is my fully updated C7

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:18, firmware0Version:7, firmware0SubVersion:18, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])

OK, so what to try next. I would try downgrading the ZIP Gateway which is needed to do the update anyway. Maybe it will get the button to show.


Run that and let it spin, when it is done run it again until you get the message that it is already installed. Sometimes it takes a couple of tries for some reason.

Then do a hub shut down and unplug for 30 seconds. Boot back up and see if the Firmware Update button has shown up yet.

1 Like