Devices ignoring digital button push?

Ok.. I must be missing something here..

I made a tiny app to push a button on a schedule
FYI this is to force a button to report to HE so I know it hasn't dropped off the network

So.. according to this post by @mike.maxwell:

The command should just be:

device.push(button_number)

So look at this...
INPUTS

section() {input (name: "startTime", title: "Action time", type: "time", required: true)}
section(){input "buttonA", "capability.pushableButton", title: "Button", multiple: true, required: true}
section(){input "buttonNumber", "number", title: "Select Button Number", required: true }

Method called by a cron job (set by the 'startTime' input:

def pushNow1() {
LOGDEBUG("Scheduled operation running now...")
LOGDEBUG("Pushing button $buttonNumber on $buttonA now...")
buttonA.push(buttonNumber)
// buttonA.push(1)

}

Everything appears to work in the logs..


but the button doesn't get pushed..
I even tried hard coding: 'buttonA.push(1)' but that didn't work either.

I have tried this with a physical button (hue dimmer) and a virtual button.
Neither one worked.. (both work with the push command on the device page)

Am I being stupid here or has something changed?
@mike.maxwell ??

Andy

buttonA is a list, so you will need to iterate through it, or set multiple to false...

Thanks Mike
Schoolboy error :slight_smile:

Download the Hubitat app