Device firmware updater : zooz zen51

Hi,

I'm trying to update my zen51, but i receive the following error when trying any of the firmware files from zooz (tried 1.30 and 1.40)

Device Firmware Updater: ERROR: The transferred image does not match the Firmware Target

Anyone have any ideas?

What’s the firmware version currently on your ZEN51?

According to the device info, v 1.24

How is it paired? No security or with S2?

I paired via smartstart and S2 is enabled

Tagging @bcopeland.

I remember someone else having issues updating the firmware of a device paired securely, and they ended up using PC Controller as a secondary controller to update the firmware.

Hm ok, so the tool cannot update S2 devices?

Anyway to re-pair without S2 enabled?

Yes, exclude, then during inclusion pick Skip security when prompted. As a rule of thumb it's best to leave all devices except for garage door stuff and locks without security. Your mesh will be much happier

1 Like

I'm not saying that with complete certainty. I think I remember someone else encountering the same issue with an S2 paired device. I tagged Hubitat's lead z-wave engineer for clarification.

I re-paired without any authentication, but same error :confused:

Device Firmware Updater: ERROR: The transferred image does not match the Firmware Target

First, just triple-check you have the correct firmware file (i.e. not mixed up with another device etc) from Zooz -- you likely do, but crazier things have happened.

Remove that update file from the device updater app to get it back to a clean slate.

Remove the device updater app, and then re-add it. I know that sounds dumb, but that often helps shake gremlins loose.

Reload the update f/w file to the updater.

Try the update again - hopefully it goes well this time!

2 Likes

Just tried that, unfortunately, same error

Is the file the correct type for Hubitat to process it? I know some companies do some weird things to apparently make it more difficult to update. Ask Zooz if they sent the correct file for a Hubitat hub.

Zooz typically sends a ZIP file, did you unzip this before loading it into the firmware updater?

1 Like

I'll ask them

If it's any consolation, the update is possible -- I updated mine a while back using the built-in updater.

The file that gets uploaded should be this name and file extension:
ZWave_Dry-Contact-Relay_ZEN51_ZGM130_SDK7.15.4_ZOOZ_V1.40.gbl

(I just realized I can't find the file itself, but I did have a copy of the file name)

When you start the update and select the device, it should then populate the current firmware next (but before you select the updated firmware)-- does that revision number match the firmware information on the Z51's device page itself?

1 Like

The 1.3 driver has a different name, but yeah it was unzipped and the firmware version on device page and firmware updater match.

The odd thing is zoos doesnt have a 1.24 in the change log

1.40 is the latest for the Z51

1 Like

Have you tried rebooting the hub before trying again? Also, some devices don't update well through repeaters. Can you try getting the device and hub very close to each other?

I learned long ago that when trying to solve a problem, after all the possible causes are depleted one starts on the impossible causes :slight_smile:

1 Like

Download the Hubitat app