Device firmware updater stuck

I tried to update a zooz zen22 dimmer switch. It uploaded the new firmware to the switch but now it’s been sitting at “complete device is flashing” for a few hours. Anyone else see this before and know what to do?

Its probably done. You might need to run a configure on the switch to set the lifeline association again, or possibly use the zwave replace to pair it again.

The device doesn't tell the hub when it's done. All the hub can do is report that it's successfully sent the update file to the device.

But it’s still showing the old firmware version when I refresh. When does that change?

How do you do a Z-wave replace?

You will have to exclude and reinclude the device.

Check this out.

Thanks. I will try this when I get home.

I tried that. Didn’t work.

I sometimes have to cut power to the device and then try doing the replace. I think the Zen22 has the little air gap switch you can pull. I updated a Zen77 recently and had a hard time getting it to replace and it finally did.

Then in didn't update the firmware

Ok lets start over...

Does the device respond to commands or does it seem to be disconnected from the hub?
Or is the only issue that the firmware version is not showing the updated version?
Are you using this driver: [DRIVER] Zooz ZEN Switches Advanced (and Dimmers) ? Or the system driver?

I had this happen after firmware update on a Leviton Z-Wave dimmer. I tried powering down the module then rebooting C7 but nothing changed its state. When I did an exclude/include everything was cleared and it showed the proper version number.

Yeah thats the last resort, although I would be careful about excluding, as it may remove the existing device entry. If you just factory reset the device then include it new you can use Swap Apps to move the automations, then force remove the old device entry and zwave node.

Good advice I'll try this next time. What I do is remove all the automations from the device, then exclude it and immediately include it. Then add the automations back in. Frankly, a real pain to do.

I don't know why just about every device's manual has a warning that you should not do a factory reset but do an exclusion instead.

It went through the uploading process. Now it’s sitting saying device is flashing

Ok, so switch back to the normal driver, can you control the device?

Probably to avoid ghosted nodes in the zwave table, sometimes they are hard to remove. You could instead make a fake virtual device, swap apps to that, then exclude to get rid of the node properly, then include, then swap apps a second time from the virtual to the new device.

1 Like

So. I ended up rebooting the hub. And then using the built in firmware updater. It took a couple hours to upload and flash each device but it eventually worked. Once updated, I created a virtual dimmer as a place holder, swapped out the device in all my apps and then excluded and the included them again and all is back up and running and no ghost devices. Thanks for the help all.