Device Delays Since 2.2.4

Apologies if this is already being tracked / discussed somewhere else, I was unable to find a similar threat.

Since 2.2.4, I've noticed odd delayed behavior for z-wave specific devices. Example: I have an automation to turn on two lights (one zwave, one zigbee) in a room when a door opens (the contact is also zwave). The automation is all in one rule. When the contact opens, the zigbee light responds as expected, but the zwave light does not turn on (sometimes extremely delayed, sometimes never). This automation worked correctly prior to 2.2.4.

From a dashboard or device page, I can see the contact open and close in real time, and the lights are controllable in real time (so I do not believe there is an issue with routing in the zwave network).

Attempting to delete and rebuild the automation in Simple Automation Rules did not correct the issue.

Recreating the automation in Rule Machine did correct the issue (everything works as expected, without unexpected delays).

I have had to move several automations over to Rule Machine to correct similar issues, but the above example was the only situation I have where both a zwave and zigbee device are issued the same on / off command at once, which is how I began to realize something else was up. The vast majority of my devices are zwave.

I have a sneaking suspicion it had something to do with Mode restrictions, based on the automations having trouble.

I have been having similar problems , and have been blaming automation as well. It works well from the dashboard.

I most only use simple automation rules with all mostly all z-wave devices, do not use modes, but do use other restriction conditions, like sunset/sunrise and disabling switches.

I hadn't thought of Simple Automation Rules being a possible culprit. If it wakes up slowwww again tomorrow morning, I'll try converting a couple of the major offenders, but I have to say, when it really slows down, the entire mesh is affected.

So things were good yesterday. Woke up this morning, and those same automations I had moved over to Rule Machine seemed slower again (but not as slow as they were running from Simple Automation Rules). The only connection seems to be automations triggered from contact sensors (all of my contact sensors are zwave, and all the problematic automations involve switches that are zwave). I have no zigbee contact sensors to test that example set.

I'm going to run a full zwave repair today to see if that changes anything.

I'm in full reset mode, alas; it was a downward spiral. The soft reset and restore didn't work out too great.

Excluding/Including all the devices is pretty bad and I'm dreading the Utilitech water sensors.

But what's going to be tough is recreating all the rules I created. I wish there was a way to get at least a paper copy of the rules for backup purposes.

The good part is that the mesh that will hopefully be stronger.

Platform 2.2.4 permits individual rules to be backed up and restored.

1 Like

I had the same problem with with several Simple Automations turning on/off zwave light switches from door contact sensors. I could see in the logs where the door sensors were opening and closing but the lights were very delayed, if at all. I power cycled the hub, tried device repairs, and let it sit overnight but the lights were still very slow. I also tried a Rule Machine but this did not work either. I finally gave up and reverted back to and everything is working fine.

Sounds like this isn't isolated then... I can't figure out a pattern either. I see the delays in the log as well (watch the contact event open... wait 8 - 10 seconds, then the on or off command get sent). But only for the zwave switches... zigbee is on time as expected.

Not isolated to Simple Automation Rules or Rule Machine... which is odd because when I moved the automations over to Rule Machine yesterday, the issue went away, but then issues returned today.

1 Like

Do you have logging turned on in the Simple Automation rule? If so, please show the logs.

I did save a screenshot of the device logs but not the SA rule....sorry. The bottom 7 items are with the Simple Automation. The top items are turning on and off the light from the device page, which worked. It seems to me that SA was trying to turn the lights on and off but was not receiving an acknowledgment.

Screenshot 2020-11-22 052227

We need to see both the device and the rule logs.

Understood....I will remember to do that next time. As for now I have reverted back to and everything works. I understand this does not help you troubleshoot the issue, but I do appreciate the reply.

Show me the rule that is misbehaving. That might allow me to look into it.

I suspect you have some Z-Wave mesh issues.

OK....but the z-wave details page does not show any ghost nodes....all the devices have the proper clusters and how would I troubleshoot the mesh issues? I do have a UZB-7 that I used once to delete a ghost node some time ago....can I use this to troubleshoot the mesh issues? Thanks

It's just a suspicion. Need to see the logs to see what's going on.

1 Like

Best example I can provide at the moment, I'll enable more logging and provide more examples.

Basement room has 3 doors, all zwave contact sensors. 1 zigbee light (bench light), 1 zwave light (back room light). Desired behavior: If any door opens, turn on both lights. When all 3 doors report closed, turn both lights off. I have the automation broken into two rules, one for open, one for close.



Here's a log from a test I just performed:

I first opened the "Bench" door. Both lights turned on immediately, as expected.

I then opened the "Back" door. The Zigbee (bench) light turned on as expected. The Zwave (back room) light did not. I then closed the door. The zigbee turns off, but the zwave then seems to "catch up" and cycles. I open that same door again a second time but hold it open. Zigbee turns on immediately, zwave comes on eventually.

Same rule, different source contact, different results from the switches.

In your logs what I see is time on the order of 100-200 milliseconds from device event to Action running in RM, which is normal. If the light turning on is then delayed, this is not due to anything with the rule.

SA 1.1 doesn’t work with sunset +offset. The rule ran fine under 1.0 and I recreated in 1.1 and it’s not working now. Hasn’t worked in any 2.2.4 version.

Please show such a rule, and I will look into it.

I am not able to reproduce a problem with this, so I'd really like to see your example.