[Deprecated] Xiaomi / Aqara ZigBee device drivers (possibly may no longer be maintained)

The xiaomi Aqara ones do. (Make sure its specifically the Aqara branded ones despite both looking identical except for the little light sensor slot at the top)

Is it anyone that uses the Aqara "Single Switch Module T1 (With Neutral)", SSM-U01, and that can recommend a driver that works with that device?

Hi,
I bought a bunch of the D1 switches with and without neutral wire, 1, 2 and 3 switches and used the latest version .1123 of Markus ("Ohlalabs") wall switch drivers.
Most of the models were not working initially (no neutral and more than 1 button) and I had to fiddle around a bit in the driver code. Now it works fine. I don't really know anything about java and/or git hub, but I was wondering if someone would be interested in the updated driver code and maybe somehow make it available for the others...

@andre-berlin
I'm current playing around with my Aqara switches as well, trying to move them from SmartThings and they're not working as expected. Tried the drivers from here and Markus' drivers.

If you post the code here or perhaps in a PM I can temporarily host them on GitHub in case someone else needs them and hopefully your changes would work for me too. And eventually hopefully Markus will update his own code.

@veeceeoh

Do you happen if there is any issues with running a second MiJia Honeywell Smoke Detector . The first one I have paired up nicely. The second seems to not want to connect. Wondering if this is common or just my luck :slight_smile:

@jeff12 veeceeoh hasn't logged on in a long time, hence why the drivers are no longer supported.

Someone else might be able to answer your specific question.

For more up to date divers use the ones provided by Markus

I’m not certain @veeceeoh is even living any longer. He hasn’t logged into any forums he was a member of or updated his GitHub repo.

RIP Keith.

In regard to your question, try resetting the device that does pair so it isn’t connected to the hub. Now try to pair the device that you’re having trouble with. If it does pair, then you have your answer. If it doesn’t pair, then you’ll know there’s something wrong with that device.

The first device that was working can simply be paired with the hub again. As long as you didn’t remove the driver, it will join up as before with the same device name and all your rules it was associated with will be fine.

1 Like

He is. He was on Twitter just a couple months ago.

1 Like

Oh this is good to hear. Nice guy. Don’t know why he logged off here and the ST forum, but great to learn he’s alright.

3 Likes

Hi, I have noticed that there is a temperature feature and have managed to make it work for all models. Now I have also noticed that there is a power consumption feature, which I have not fixed yet.
Do you still want the code or wait until it is fixed? I could send an update later.

BTW do you happen to know if the "non" neutral switches are supposed to have the power consumption feature? None of them seem to, but I am not sure if this is a bug or just physics.

Some of the other features did not work for the non-neutral and some not for the 3 switch model. So I am not sure about this specific feature...

I know with inovelli reds if you do a non-neutral install you loose the power sense capability. So it doesn’t surprise me with these devices. Current sense could still be done but their cct design might not accommodate it that way.

1 Like

Hi, does anyone have the latest driver for Aware door/window sensor. I'm using v0.7.2. When pairing, the device(s) won't initialize. Can anyone advise on this please. I'm migrating from ST and have 5 of these contact sensors. Thanks in advance guys

This one is working OK for me.

@bobbles thanks for this, I now have success. However my dashboard tile doesn't seem to acknowledgee that they are contact sensors. The tiles are showing the unknown questionmark as though it's the wrong device. Can you offer any help please.

Check the device and make sure it has the correct driver and the sensor is showing as a contact sensor.
Do not delete the device.
If it has the correct driver and is showing as a contact sensor, go into discover zigbee devices again, hold in the reset button to reset the device and let it discover the device again.
Sometimes this does the trick.
I don't know why but sometimes these devices need to be discovered again to get them to work ok.
Good luck.

That's done the trick @bobbles. Brilliant help, appreciated

1 Like

@andre-berlin yes please I'd still like the drivers please.

Perhaps not the best topic to be chatting on as the drivers that you modified are Markus' drivers, so I'll tag you on the thread there

Xiaomi Smart Home Mijia Honeywell Smoke Detector:

After connecting the device and installing the driver I can access my new device. :+1:

The first “Test” command works, after a while the battery status (100%) is shown, and even my push on the little button of my device raised a smoke=“testing…” event in Hubitat.

Great! But…

I’ve noticed that the log is now flooded with “Parse START” messages; The lastClear state is set 10 to 20 times a minute! I fear that the battery will be fast drained...

Any suggestions?

Thanks very much for this - needed a driver for an Aqara motion sensor and vibration sensor, worked perfectly!

HI there, Thanks for all your help with these drivers! I was looking at this thread but theres a lot here... and I couldn't nail a solution down..

I am trying to figure out how to set the sensitivity of my Aqara vibration sensors.... I can practically knock them over and they don't pick up....

Thank you for any help!