[Deprecated] Xiaomi / Aqara / Opple Drivers with Presence!

Which HomeKit integration are you using?

I'm running a docker image of onzu-homebridge on a Synology device.

Hi Guys!

My first post here after the migration from ST (ongoing) so bear with me :slight_smile:

I have a couple of Aqara Wall Switches , QBKG24LM to be precise.
I have installed the following driver for them:

My issue is that I cannot see the "hold" button option. As far as I have read on this thread, there is a way to reproduce this by using push&release but not sure how.

What I am trying to do is to create a webcore piston that when the button1 is held, something happens.

Can you please guide me on how to do this "hold" action?

Thanks ,

thanks for your driver.
can i ask driver Aqara Cube MFKZQ11LM?, not MFKZQ01LM
Aqara Cube (works with model MFKZQ01LM) is not worked with MFKZQ11LM.


pairing info is

Manufacturer: LUMI
Endpoint 01 application: 1C
Endpoint 01 endpointId: 01
Endpoint 01 idAsInt: 1
Endpoint 01 inClusters: 0000,0003,0001,0012,0006
Endpoint 01 initialized: true
Endpoint 01 manufacturer: LUMI
Endpoint 01 model: lumi.remote.cagl01
Endpoint 01 outClusters: 0000,0003,0019
Endpoint 01 profileId: 0104
Endpoint 01 stage: 4
Endpoint 02 application: unknown
Endpoint 02 endpointId: 02
Endpoint 02 idAsInt: 2
Endpoint 02 inClusters: 0004,0003,0005,0012
Endpoint 02 initialized: true
Endpoint 02 manufacturer: unknown
Endpoint 02 model: unknown
Endpoint 02 outClusters: 0004,0003,0005,0012
Endpoint 02 profileId: 0104
Endpoint 02 stage: 4
Endpoint 03 application: unknown
Endpoint 03 endpointId: 03
Endpoint 03 idAsInt: 3
Endpoint 03 inClusters: 0004,0003,0005,000C
Endpoint 03 initialized: true
Endpoint 03 manufacturer: unknown
Endpoint 03 model: unknown
Endpoint 03 outClusters: 0004,0003,0005,000C
Endpoint 03 profileId: 0104
Endpoint 03 stage: 4
1 Like

problem log is
[warn] Unhandled Event PLEASE REPORT TO DEV - description:read attr - raw: CDFB01000012040042044C554D49, dni: CDFB, endpoint: 01, cluster: 0000, size: 12, attrId: 0004, encoding: 42, command: 01, value: 044C554D49 | msgMap:[raw:CDFB01000012040042044C554D49, dni:CDFB, endpoint:01, cluster:0000, size:12, attrId:0004, encoding:42, command:01, value:LUMI, clusterInt:0, attrInt:4]

Good day sir,
I was wondering if you ever got around to coding a driver for the Aqara T1 family of products? I have the T1 Pro cube and would love to get it going on this platform. It was given to me, so I do not have any other Aqara product like their hub to pair with. This is not a product line I care to follow, so if you have one great. If not, no biggie, I will pass this one to someone else.

I just come across your post as I was reading about the M2 and I had a very similar situation in particular with Hive. May I just ask... are all the HomeKit and Zigbee devices connected to M2 also 'visible' on HE as well??

The short answer is no, the devices available on HomeKit are not exposed to Hubitat.

thanks for the info.
May be I have confused myself. But how does the M2 reports its connected device to HE? is it through its HomeKit connection to a Home Hub.
@andydvsn 's Hive device I guess is connected to HomeHub instead of M2??
link to all these. I am thinking of getting the FP2 sensor. and my real question is , do I need a M2 hub

The devices connected to Aqara M2 hub are exposed to HomKit, as this is there is a direct integration from Aqara to Apple home automation systems.

Hubitat also has a one-way integration to HomeKit - HE devices can be exposed to HomeKit.
Apple does not allow HomeKit devices to be exposed to any other HA system, however.

The workaround is to use Hubitat virtual devices. If a HE virtual device status is changed from the HomeKit automation, its changed status is available in Hubitat.

For example - this is one of the possible ways to bring Aqara FP2 Presence Sensor to Hubitat:

This automation turns on a virtual presence device in Hubitat. There is a second automation made in HomeKit, which turns the virtual presence sensor off when the FP2 presence status is off.

For Aqara FP2 presence sensor you do not need a M2 hub, as FP2 is a WiFi device (not Zigbee or Thread).

1 Like

thanks for explaining. very useful

Hi there,

I have a Aqara wall switch with double rocker using this driver (thanks so much!) It nicely sets up 2 x child virtual devices as generic switches for each of the rockers. All works fine turning them on/off individually on the device page, they do not interact and work great. However, when I add one of the child devices to a dashboard, pushing the tile turns both of the child devices on/off. I can see in the dashboard debug log that it sends a command only to one of them, in the device log I can see that only one end point is turned on or off, but both child switches change state.

Any ideas? Let me know if more info is needed to debug?



There are many postings of drives for Aqara, and I can no longer tell which would be the latest and actually work properly.

For example the Aqara switch drive, so far I have not found a solution for when we command manual, that the status in HE is updated.

If anyone can help by trying to consolidate that would be a latest version.


There are no known active developments for Hubitat platform for the new series of Aqara wall switches and remotes. The existing old drivers will work with the old models.



Which of the older drives do you then recommend using for switch (1 gang 2 switch), humidity/temperature, motion and FP1 presence?


It is time to find a new home for Markus’s drivers, so that more Hubitat community developers can contribute on adding these new Aqara devices that are currently not supported.

Such a process (moving all of the Marcus’s drivers into HubitatCommunity repository on GitHub) will take time however.

Meanwhile, you can try to find a driver for your Aqara device in this list.

Probably the most difficult to handle are the new E1 series of Aqara wall switches. Currently Marcus’s driver supports 12 different switches models , but there are at least 3-4 newer models that needs to be added.

If anyone has successfully modified and tested these drivers for the new Aqara switches, please let me know. I will try to merge the modified code into the original driver.


Hi I bought a "Aqara Smart Wall Switch H1 EU (With Neutral, Single Rocker) (WS-EUK03)" as it fitted a specific need. I tried a few drivers and the Aqara specific ones didn't work - was throwing exceptions off (below) when I tried to use the "Zigbee - Aqara Wall Switch v1.0.1.1208b" driver.

But the good news is that it seems to work OK with the generic driver "Zigbee - Generic Switch (with Presence) v1.0.1.1123b". I get two child devices (I have the single switch model) but that's OK I just ignore the second child. All I really want is the switch state on/off and that works fine.

Awesome work Markus thanks!

Exception with Aqara specific driver: "Unknown model (lumi.switch.n1aeu1) - PLEASE REPORT THIS LOG TO THE DEV - description:read attr - raw: 323D0100002E050042126C756D692E7377697463682E6E3161657531, dni: 323D, endpoint: 01, cluster: 0000, size: 2E, attrId: 0005, encoding: 42, command: 01, value: 126C756D692E7377697463682E6E3161657531 | parseMap:[raw:323D0100002E050042126C756D692E7377697463682E6E3161657531, dni:323D, endpoint:01, cluster:0000, size:2E, attrId:0005, encoding:42, command:01, value:lumi.switch.n1aeu1, clusterInt:0, attrInt:5]"


I have come back to looking at these drivers again, as I have switched to the new C8 Hub and I noticed some regular log warning, from one of my 2 gang no neutral aqara wall switches.

In fact I had this warning before, but only now I am getting around dealing with it.

So I am using this driver:
Zigbee - Aqara Wall Switch

I have replied to your message, because I did indeed make some modifications to Markus' original drivers, in order to make it work with some wall switch models, that were not supported. I don't know much about driver programming, but this kind of modification is quite straight forward. Only a few lines have to be copied, with the new model number like "lumi.switch.l2aeu1", like in this case. In some cases the button numbering is a bit weird and it takes some trial and error to figure this out. But nothing major has to be modified in the code to make it work.

I could send my current driver code, so you could update your GitHub collection. I can see you have created new versions 2.0x. I wonder if you figure out the changes I made easily or if I need to guide you. It seems you added some US models, so you probably know where to look.

Could be great if you could include my modifications in your code, so I can use the "official" driver again and get updates in the future.....:slight_smile:

...anyhow, concerning that warning, it says this:
Unhandled Event PLEASE REPORT TO DEV - description:catchall: 0000 0005 00 00 0040 00 845D 00 00 0000 00 00 EB0000 | msgMap:[raw:catchall: 0000 0005 00 00 0040 00 845D 00 00 0000 00 00 EB0000, profileId:0000, clusterId:0005, clusterInt:5, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:845D, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[EB, 00, 00]]

I seems most of the data just says "00"
The first 2 digits in the [] only count upwards by +1 every 10 seconds. The message is generated every 10 seconds.
If I press a button or reinitalize, the message stops for about a minute before it starts sending again.
The switches that are currently on have a red LED blinking. It also stops, when the message stops.

This is the only device doing this. However, the other ones I have are not no neutral models, display either a "not present" status (even if they work) or are using the aqara plug/outlet driver (which should not work but is...). So comparison is difficult... This might in fact be the only exact same model with the same driver I have...

Firmware: 115F-0C18-00000E0B

I tried to understand the driver code to figure out what could be going on but it is not obvious for me how the message is created. I can tell I get into some default case at some point, but I am not sure why none of the other cases in the code are applicable..

Hi, I could probably make it work. I have, amongst others, added the lumi.switch.n2aeu1 model to the driver. If kkossev is willing to add my modifications to his version of the driver, I can make sure I add your model before I send him my code. However, I don't have that specific model, so you might want to help us out by testing it.

1 question though: you say you use driver version Zigbee - Aqara Wall Switch v1.0.1.1208b, where did you find this? It's not in the collection linked by kkossev in the message above...

Hi @andre-berlin ,

Yes, please send me in a DM your mods, I can compare and merge the additions to the forked driver in GitHub.