[DEPRECATED] Kasa Plug, Switch, and Bulb integration

Open the Kasa App and see if it can control the device. The continual flashing means something is wrong with the switch's installation or the switch itself.

This is normal. Somewhere your devices were uninstalled from the hub and when you rediscovered, they became new devices - so no link to a dashboard. Easy fix:
a. Open the dashboard app for your dashboard.
b. Add in the two "new devices" in the app list.
c. Open the dashboard for edit.
d. Select the buttons without a device (Has ? in tile) and select the new device.

1 Like

Thank you @djgutheinz , for some reason, this one HS200 switch fell off the wifi network either right as I was migrating my Kasa devices to the built-in app, or it had fallen off the wifi network previously and I did not notice until I was checking everything after going through the migration procedure. After a while, it reconnected and now all is good.

As far as the dashboards go, I must have misunderstood how the migration procedure worked as I assumed that the Kasa devices were to “automatically” transfer from the community app to the built-in app when the “Migrate button” was pressed and would thus just repopulate the dashboards automatically as well. This may serve as a heads-up to those that have many Kasa devices they may wish to “transfer” over to the built-in app that are also involved in several rules as well.

Thanks for your help and feedback, and for keeping this integration alive. Really appreciate it!

Mine stayed connected to all the apps they were named in, including a dashboard. Or at least those apps are still listed in the In Use By list

That unfortunately was not my experience (but I probably did not perform the migration properly?). Good to hear it worked for you. That’s how I had expected the migration to work! Again, I probably did something wrong (that’s my wife’s explanation every time something does not work for HER . . . that it was because I did something wrong, lol).


I take that as I should hold off on upgrading to, or just hold off on migrating the kasa integration for now. (I have several devices that use the multiplug driver).

1 Like

I just upgraded my hub and migrated devices. All went well and seems to work.

I tried to do a test device lan status just to see if it lists them, but nothing happens with the new built in app. Still works with the user app however.

Uninstalled user app and everything still seems to be working correctly.

PRESS configure on any one device and see if that fixes your issue.

Sure did!

Hi there, hope I'm posting in the right place. Crossing my fingers.

I'm currently running Hubitat and Kasa Integration 5.1.1 (I think; that's what def appVersion() says).

When I upgraded Hubitat to some time ago, I noticed some of the features in the Kasa integration stopped working (changing bulb color, for instance). I could still control the bulbs with my smart speaker so for the time being, I let it go.

Today I decided to clean all this stuff up so I can have a healthy system prior to upgrading to the latest Hubitat code, so I went about deleting all kasa devices and all dashboard elements/routines that referenced them. I then deleted both the bulb and plug driver code with no issue.

However, when I go to delete the "Kasa Integration" in the Apps code, it fails, returning an error that states it is still in use by "Kasa Integration" (i.e. itself). On a whim, I attempted to edit the code, deleting all of it minus the comments but it would not save. So, I took another backup (I took one prior to starting this endeavour) and rebooted. It came back up but I'm still stuck with this integration that I'd like to remove for a number of reasons, chief being getting to newer versions.

Can anyone offer any guidance on next steps, short of factory defaulting the device and starting over, which I really don't want to have to do?

Thank you in advance.

Since your intent is to remove the devices/app (for now), I suggest:

  • Update the Kasa app to the latest version (link at top of this thread).
  • Open a Logging Window
  • Attempt now to remove the app
    • If it works, great. Delete all Kasa Drivers and the Kasa App.
    • If it does not work, private message the logs (as TEXT) to me.

If you then want to reinstall, go to the Hubitat built-in version (available in latest HUBITAT version).

Thanks for the info!

Did something happen to the Kasa cloud service today? I just noticed that my logs have been full of these failed token refesh messages repeating every 10 minutes since about 12 hours ago:

info[KasaInt: 6.7.1]: cloudAddDevicesPage
info[KasaInt: 6.7.1]: getTokenFromStart: Result = [[updateFailed: [error_code:-23003, msg:App version is too old]]]
warn[KasaInt: 6.7.1]: getToken: [[updateFailed: [error_code:-23003, msg:App version is too old]]]]

It didn't seem to impact my devices since I don't actually use any cloud features. I just ended up removing my cloud credentials and that stopped the errors.

Can not duplicate on my system. Gets the token first-time.

Problem may be you have not used your Kasa phone App recently. Update that app on your phone, log in on the phone, and verify functionality. Then try getting credentials again.

I recommend doing this for EVERYONE. But that is up to the individual.

I actually did just use the Kasa app earlier this week, but the app did update since then. Regardless, didn't fix the issue when I readded my credentials.

Give it a day or two and try again. If it is a change in the API, it will eventually reach my integration and I should be able to work then.

I found the problem. Apparently 2FA got enabled in my account somehow. Anyway, mystery solved I guess.

1 Like

Can you please replace the code that is generating these Logs:

with the Hubitat standard 'Enable descriptionText logging' Preference:

input "txtEnable", "bool", title: "Enable descriptionText logging", required: false, defaultValue: false

Doing so enables users to completely disable logging and adds your drivers to the txtEnable group in Preference Manager.


I will think about it in a future release.

So as a result of the prime day sale I purchased an HS300 power strip. The TPLink forums are not clear on whether the random reboot issue is resolved. What have other HS300 owners seen? Will the integration allow me to see if the strip reboots itself?
I just updated to 1.0.12 build 220121

Thanks Folks