Denon Receiver Stopped Communicating (Maybe after recent update)

Not sure how to trouble shoot this. It was working fine up to the 16th which was the last time I tried using it. I (think) I ran the latest update between then and now. Now it doesn't report on or off or anything. The device is locked to an IP so that hasn't changed. I could try removing it, but I'll have to fix a bunch of rules. Any ideas?

I just fixed it by pressing Initialize on the device screen. What exactly does that do and why did that fix it?

It probably reinitialized the Telnet session that Hubitat uses to connect to the receiver.

Happens to me every now and then. Demon/Marantz only allows a single telnet connection unlike other AVRs like Onkyo or even the Lutron hub. If power is pulled from the Denon this situation will happen

Ok. I don't believe it ever Lost power. Can I set a rule to periodically initialize again? I see that option in custom action under RM, but it wants me to add a parameter to it. No idea what that would be.

Leave it blank?

2 Likes

Didn't realize I could. I set it to initialize daily. We'll see what happens going forward. Thanks!

1 Like

Unfortunately that won’t always work. If you click it multiple times it attempts to establish another telnet connection and it may fail and cause issues.

So what's been your solution? Just log in when it happens and do it manually?

I have a UPS on my AV equipment which has stopped it from happening too much.

2 Likes

Ok. I have a ups in there but don't normally run the receiver or amps thru it. I'll rethink that if it continues. Thanks!

1 Like

While I am able to still control my Denon AVR 3600 (set volume, set input), the built in driver is having probems - the "send message" function is returning the following for me:

org.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: denonAVR.sendMsg() is applicable for argument types: (java.lang.String) values: [MSDOLBY DIGITAL] (sendMsg)

This may not be a new problem as I've never tried using the "Send message' feature before, but it's certainly not working now.

I'm trying to replicate remote control functions via the documented Denon command set. (MSDOLBY DIGITAL) is the command/message to set sound mode to DD.

I’ve never used that command. Based on the error there is no code in the driver to handle that command. Tagging @mike.maxwell who wrote these drivers.

The sendMessage command was added to the telnet capability after these drivers were written, but the drivers weren't updated to include that command.
I'll get this fixed, though it probably won't be until 2.2.9.

1 Like

Download the Hubitat app