Dashboard not updating

Being reasonably new to Hubitat, I'm trying to use the Dashboard to verify the status of lights in the house. On some occasions, some lights that are on indicate they are off in Dashboard and some that off indicate they are on. The lights affected are always different and vary among plugs, switches, and dimmers. Is there a way to force the Dashboard to update the status of lights?

I've got a combination of about 80 dimmers, plugs, and switches. All are GE/Jasco products.

This could certainly be the reason if they are older z-wave devices, which don’t do a good job of sending status updates to the hub.

Listing the model #s for the devices can give others a sense of whether that’s likely to be the issue.

You can also compare each device’s status in the device settings page to what it’s showing on the dashboard. If the device settings page is out of sync, it’s a device issue. If the device settings page is showing the correct status but the dashboard isn’t, then it’s a dashboard problem.

You can either setup a rule to refresh all your GE/Jasco devices periodically or use the built-in poller app to do the same.

I have the same problem, and attempted to use the poller app. Unfortunately I'm unable to select any of the devices in the poller app, so it's essentially not doing anything.

The polling app only works with the older Zwave, and not with the newer Zwave+.

As @neonturbo said, there’s no reason to use the z-wave poller app with newer z-wave plus devices because they don’t need to be polled, only older devices do.

As I said above:

Without that basic information we are all just guessing as to what the underlying problem might be for you and OP.

The model numbers I'm not getting a proper device status on are:
GE Enbrighten Smart Dimmer 14294
GE Enbrighten Smart Switch 14291
Spring Window Fashions Somfy Blinds

The motion sensors that I'm using are:
GE Enbrighten Portable Smart Motion Sensor: 34193
Aeotec Trisensor
Dome Motion Sensor

Same issue. Quite frustrating.

What did you try to do to troubleshoot?

For example, does it work from the Device tab, in the individual device? Did you look at logs? Anything else that you can tell us other than it doesn't work?

:man_shrugging:

The turn off of dimmers switches and plugs has become more consistent since I initially started this thread in January of 2020. What is still inconsistent are my four Schlage locks. The logs show an attempt to lock these locks. Three of the locks are within 6’-7’ of each other. There’s a GE dimmer no more than three feet from one of the locks. All are z-wave devices.

The logs show a number of repeated commands

ital]

dev:2132020-09-15 09:05:06.402 pm infoLiving Room-Southlight is off [digital]

dev:2102020-09-15 09:05:06.029 pm infoLiving Room-North light is off [digital]

dev:2102020-09-15 09:05:05.980 pm infoLiving Room-North light is off [digital]

dev:2102020-09-15 09:05:05.465 pm infoLiving Room-North light is off [digital]

dev:2102020-09-15 09:05:05.441 pm infoLiving Room-North light is off [digital]

dev:2132020-09-15 09:05:05.158 pm infoLiving Room-Southlight is off [digital]

dev:2132020-09-15 09:05:04.867 pm infoLiving Room-Southlight was turned off [digital]

dev:2102020-09-15 09:05:04.789 pm infoLiving Room-North light is off [digital]

dev:2102020-09-15 09:05:04.738 pm infoLiving Room-North light is off [digital]

dev:2102020-09-15 09:05:04.675 pm infoLiving Room-North light was turned off [digital]

dev:2092020-09-15 09:05:03.728 pm infoLiving Room-East lights was turned off [digital]

dev:2592020-09-15 09:05:03.543 pm infoDoor-Garage is locked [digital]

dev:2592020-09-15 09:04:54.076 pm infoDoor-Garage is locked [digital]

dev:1982020-09-15 09:04:41.780 pm infoOutside-South is off [digital]

dev:1982020-09-15 09:04:40.157 pm infoOutside-South is off [digital]

Seems kind of noisy. I’m not sure if that’s a potential source of the problem.

The device "works" from the device tab but the state does not refresh. Using the dash board it just says sending but it does actually change the state on and off. The displayed state does not update though unless "refresh" is clicked under the device tab.

Nothing appears in the logs unless "refresh" is pressed and then it shows "was turned" on or off " digital" at the time of refresh even though it actually turned on early when the digital command was originally sent.

Physically operating the switch updates the dashboard with out issue.

Have the same issue with some of my bulbs. I'm using Linkind Tunable A60's They hooked up fine. I have them all controlled by philips hue dimmers using rule machine. It all works great apart from all the upstairs bulbs. these will be controlled happily with the dimmers located in the same room but for some reason the dash downstairs wont update with the status. If I use the dashboard to turn one on, it will turn on but the dashbord will go to the egg timer and wont update. If I then go to the device and refresh the dashboard updates ok. Likewise turning off.

I have several Leviton VRMX1 dimmers. I am fairly certain these dimmers previously worked as expected physically and via the dashboard using the Generic Z-wave CentralScene Dimmer driver. However, I can no longer get them to work properly both physically and via the dashboard. The following table shows the behavior with the "Generic Z-Wave Dimmer" driver, the Generic Z-Wave Smart Dimmer" driver and the "Generic Z-Wave CentralScene Dimmer" driver.

I am looking for ideas on how to get my Leviton VRMX1 dimmers to be properly reflected on the dashboard if I control the dimmer physically or via the dashboard. Any advice will be appreciated.

I have the exact same behavior with my GE Z-Wave Plus embrighten dimmer. Responds perfectly to all automation actions, responds perfectly to controls in the device properties page, but status never updates until it's manually refreshed. Anyone find a solution? It's using the "GE Enbrighten Z-Wave Smart Dimmer" device handler.

I have a few Zwave Plus devices that are not good at reporting their status changes. And if you try to set up a periodic event to refresh or poll these devices you will find out that these options are not available in rule machine because Hubitat feels it is unnecessary with ZW+ devices. My solution is to do a refresh with a custom action on an actuator (the switch in question).

Have you tried clicking “CONFIGURE” on the device details page? This sends some configuration commands to the device, some of which include telling the device how to report status updates back to the hub.

Also, are you certain it is a Z-wave plus device? On the device details page, on the bottom half, you should see a section that mentions supported command clusters. The first one of these will be “5E” if it is a Z-wave Plus device.

1 Like

5E - very interesting. I have way more ZW+ devices than I thought - 26 by count. Sadly some of my older ZW devices do a better job of reporting status changes, and in particular digital or physical, than my Z+ devices. My old Aspire RF9534 dimmer in the far end of the house is 100% reliable on status and usually reports physical when I manually change the device. Even some of my earliest devices from Intermatic have been very good at reporting status changes. And Iris 3210 modules are 100% at reporting status changes.

Well, they are Zigbee, not Z-wave, so they always work. :wink:

The 3210-L outlets have a z-wave plus repeater built-in, but it is not used for control of the outlet. The Zigbee radio does all of the heavy lifting for those outlets. And Zigbee devices have always reported their status updates without issues. Z-wave, not so much...:stuck_out_tongue_winking_eye:

2 Likes

You're right of course - senior moment on my end....lol Saw it on my ZW+ list and forgot it was there because of the repeater function.

1 Like

I dumped my z-wave switches and dimmers a while back do to these issues. I installed Lutron Caseta throughout the house, and couldn’t be happier. Lutron + Zigbee makes a great combination, IMHO. :wink:

1 Like