Danalock V3 zwave lock


I am trying to migrate from ST to HE environment.

Since I know that most of the zwave & zigbee devices are supported , I have no doubt that standard devices will be easy to migrate.

So before all of them, I want to start with my zwave lock.

I have a Zwave lock from Danalock (v3) and it works fine with my ST hub.

But when I exclude it from my ST hub and put it into pairing mode, and then try to add it from HE devices menu. It is not found.

HE Hub keeps looking for new devices without any results.

I have the US Zwave model as my HE Hub. So frequency is not the problem.

What can be the issue ?

I have the driver for my lock from ST hub.


Move the lock closer to the hub. You can also try a hub reboot, but don't go crazy with them. The HE hub backs up the database when it reboots, so it'll be busy for a bit. Make sure you reboot from the UI. Don't yank the plug like ST.

Hello have the V3 from Danalock, it connects and is in the device, only as a Device.
After set it to Generic Z Wave Door Lock, no action at all when press lock or unlock.

what to do ?

@nest Did you press CONFIGURE after changing the driver and saving the device? In general, anytime you change a driver in Huibitat, you must SAVE the device and then click CONFIGURE to send all of the reporting/configuration data to the device from the new driver. If a device pairs and correctly is assigned the right driver, this is automatically done for you.

This may or may not help with your specific lock device. If not, you may want to submit an email to support@hubitat.com to see if they can assist you.

since the OP is mine, I take it that this answer is directed to me.
However, I did not use a custom driver. I HAVE a custom driver but Hubitat does not accept it. The code is not optimized for HE.

I tried moving the lock close to the hub. But that did not help.
I am still at " looking for new devices " phase.

Sorry for any confusion... My reply above was to @nest.

ok. what about me ?
what should I do ?

Contact support@hubitat.com. That really is your best option, especially with locks.

I had already done that 2 days ago. I didn't receive any response.

Did you get an automated response acknowledging your email?

Edit: also, after unpairing from ST, did you factory reset the lock before trying to pair with HE?

yes I received an automated response.
Actually I had a spare lock waiting for install. I am trying with that one. It was not unpaired from ST and I remember I had factory reset it. At least , its app shows it's not installed anywhere.
But if you say that the reset step is important, I can try reset again.

@mike.maxwell has mentioned factory resetting z-wave devices in several threads.

I can’t say for sure whether that’s the crucial step for your device, initially you said you excluded your device from ST and are trying to pair with HE but now that is not the case? Or have you tried with two locks?

I am sure support will reply as soon as they’re able to, since the auto-response indicates you generated a ticket in their system.

ok I will try resetting and then pairing.
initially I said I had excluded device from ST and that's correct.
This is a spare lock excluded from my ST hub. And it was factory reset before (that's what I remember)

Hello, I did a a few times . the 4th time it worked and switching under the Device menu.
Battery Status, locked/unlocked condition everything is fine as long it is next to the Hubatit box. Move it away to the door ....DEAD again no connection. How handle that issue . (only 6 metes away clear veiw.).

Once you move it to it's final location, do a z-wave repair. Do you have a z-wave repeater in range of the lock?

I made a factory reset and now the lock is added to the HE hub.
But I am in the same situation with user @nest ; HE hub can only control the lock when it is in a very close range. If I take it to my door, it can not be controlled.

I did a z-wave repair at its final location. But that didn't solve the issue.
There is only 1 wall between the hub and the lock and the total distance is only 5-6 meters.

My ST hub can control it with same distance and same wall in between.

Of course there is a difference that on my ST environment I have adapter powered z-wave devices (repeaters) and they are not migrated to my HE environment yet. (1 siren, 1 motion sensor and 1 thermostat)
But ST hub can control the lock even when other zwave devices are turned off.

The distance is really close and I am surprised to see that HE hub can't control the lock from that distance. Most probably, when I migrate all my zwave devices, HE will be able to control all of them but what if I did not have any zwave repeaters ?

Also, additional question :
now I use the Danalock Lock as "generic zwave lock"
on my ST hub I had a specific driver (device handler).
Is it "ok" to go on with the generic driver ? am I missing anything ?

The generic zwave lock supports lock codes, I don't know if this lock supports user codes or not, if it does, then stick with that driver. If it doesn't, no harm though apps like LCM and anything else expecting code usage won't work. You can try the August driver (which doesn't have the lock code capability), however it was written specifically for the August and may not report physical actions correctly.

Hello, thanks for the answer, I do not have a repeater between this is to close to use a repeater 6 meter...
After the Repair no change . = no connection same issue like [ilkeraktuna]

_Hello, I am the new one here and several asked for the help with user login because I made a mistake and sign-in via social network. _

My experiences with Danalock V3 (DA) are about 6 months and with Z-Wave protocol two weeks. Also writing of device drivers via Hubitat are very weak. So correct me, if I am writing any non-sense.
At first I made a big mistake when I include DA in Z-wave hubitat and I remove it without exclusion etc. Reseting of DA is on separate post not belonging here. But at the and I was successful.

After many try & error I found article Z-Wave devices that should be changed from secure to non-secure. DA is pairing like non-secure. I have checked inside device code that parameter zwaveSecurePairingCode has value "false". Every communication must be in secure mode. I have asked @bobbyD to add to secure via e-mail and waiting for answer.
Meanwhile I have bought Fibaro Smoke Detector with Z-wave and I am lost in documentation and examples in and for Hubitat but it belongs to another thread.
I really understand that Hubitat is child and I like its concept.

As you say, the Fibaro Smoke detector may not be related, but I have one and I am using it with this information here: