Crons/Scheduled Jobs No Longer Run

I noticed none of my automations worked yesterday. I didn't really know why. I tried rebooting the hub, no luck. I noticed today that cron jobs do not appear to be running:

Notice that for this 1 app there are 3 jobs PENDING but in the past. According to the Scheduled Jobs tab of Logs I have over 100 jobs that are scheduled in the past and have not run. What can I do here? It seems like quartz isn't running? IO don't know of a way to tell if it is or not. I'm also not sure if this is the same root cause of Simple Automation Rule Stopped Working or if I have two issues but right now, unfortunately, none of my automations work.

I've rebooted the hub multiple times, no luck

cc: @gopher.ny

Can you PM me your hub's id? I'll take a look at the engineering logs.

I'm having the same issue. I have several jobs that I've scheduled that show pending and not updating to show the next run time. Also nothing in the logs.

Was there any resolution to this?


If you open the apps those jobs are for and click Done on them, does that push things along?

Many (most?) of my jobs are in Rule Machine. Those just stopped working abruptly about a month ago. I had sunset/sunrise lighting controls that don't fire any more at all.

I also had some notifications driven by Better Laundry Monitor that seem to have stopped entirely as well.

I opened many of my rules and laundry monitors and clicked done and that did, in fact, move the scheduled time forward into the future, however, those again did not trigger this evening. We slipped by with nothing in the logs and no actions.

If I go into the rule and "Run Actions", it works fine. It's just not being triggered.

Is there any way to get details about how/if cron is functioning or any other metrics about the system? I've also noticed that the UI is quite sluggish.

Follow up...

I had no luck getting this resolved, trying many different tactics, until I got a software update to 2.3.2 (I think). When I applied that it seems to have sorted things out.

Upgraded to 2.3.3 and all still seems to be good.