Could never do a soft reboot: ERROR 401 is returned when using port 8081


Could never do a soft reboot: ERROR 401 is returned when using port 8081. Soft reboot simply isn't an option for me... What can cause this?

error mesage: "Error: Request failed with status code 401"

So, how are you trying to perform a soft reboot?

That just means your login session expired. Logging out of the Diagnostic Tool, and back in should solve the problem. If that doesn't work, please PM and will further research.


Same. Never. Ever. Been able to get anything on the service menu to work. What is the trick?

I press logout/login...nothing happens.

Use the incognito/private function of your browser (or clear the history).

thanks...same result.

same here as well. login/logout does nothing from any browser/device nor in private mode...

Yeah I'm convinced it doesn't work. Also my habitat recently started reporting every node as failed, over and over and over, nothing has changed in the house sigh I'm moving shortly and will not be repeating this Z Wave Fantasy :frowning:

@8ph I was able to get it to work by changing to new VLAN/IP on the hub, It allowed me to login and soft reset finally.

I'm on the same VLAN/Subnet at my hub. This have never ever once worked for me. I'm just not finding that this device it as all stable or production ready. Since so many people seem to think it is, it is just probably me, HAHAHA!

Lol. Are you able to create a new VLAN and move the device to it? I have a Ubiquiti UniFi system and I just set switch port 7 to a separate VLAN with different IPs and manually unplugged the Hubitat and moved out from port 5 to port 7. (moved the HE from to and then was able access and reset.

Anyone ever get this resolved?

401 error with a locked up system. cleared cache, changed browsers, tried privacy mode, even tried two other computers who never connected to hubitat and same issue. It’s become a paperweight!

Who has gotten past this issue to bring their device back from the dead?

Does it let you enter the MAC address and complains that it's invalid even though you entered it correctly? Or is it just 401 straight up, even afte clicking Log out?

If there's anything running on port 8080, please PM me your hub id, I may be able to take a look in the support tool. This depends on what's running/not running, but worth a shot.

it never let’s me enter the mac address. I’m using port 8081 to access the admin / diagnotics page. I’ll PM my hub ID

ok, @gopher.ny did you do something, because now I could enter my mac address and was able to do a soft reset. I’ve been trying for days and right after I post to the forum it works.

@bobbyD @gopher.ny, I found out a while ago that the "Login" on the port 8081 ONLY works if you access it through the IP directly and NOT through hubitat.local, this is the real solution.

I figured this would be fixed by now since it was in a forum thread with devs but just tested it again and if I use hubitat.local pushing login doesnt do anything.

No, although I'm glad it worked now. Our hub access through support tool is limited at best, and we don't do anything without user's explicit permission.

I did miss this one, actually. Diagnostics tool is ripe for a facelift, I'll address it then.

1 Like

Could just use the mobile app to access this right?