CoControl Wall Switch control

I purchased a couple of GoControl WAOOZ-1 Wall Switches that I would like to use to control some dimmable Z-wave bulbs. I have the bulbs in a group. I can create a simple automation rule to turn on/off, but I would like to be able use the switch (as designed) to so the top button turns the lights on and a long press increases brightness, and the bottom switch turns the lights off and a long press decreases the brightness (the buttons are suppose to support long press commands).

Other than creating 4 separate rules, does someone have one simple rule for doing this?

Use the button controller app.

1 Like

That is one option. You certainly could do 4 rules. You also could if needed use Rule Machine which has a built in button controller. Using RM can get you some advanced settings absent in button controller. But RM is quite heavy and hard to use for something as simple as this.

My other suggestion which I like better due to the clean interface and ease of use is Advanced Button Controller. It is a community app though, and not a stock one if that makes a difference to you. But most everyone that tries it likes it more than Button Controller (stock) app.


Not sure how I missed this!? I tend to just do things the hard way when the easy way is staring me in the face :rofl:

1 Like

I went this route and it is working great! I wish these app developers would spend 5 minutes to write directions for newbs. I installed the app and child app under App Code, but it took me 10 minutes to figure out I then had to also enable it with the "Add User App" under apps. But after that it was easy.

Thank you @neonturbo and @marktheknife !


That’s covered in the hub documentation pages too :wink:.

1 Like

Did you experience any issues getting the GoControl WAOOZ-1 to include in your hubitat z-wave network? I have the same switch but could never actually get it to pair with hubitat (it paired with smartthings just fine)

Also so for the multiple posts. I fat fingered the reply button on my phone before I was done :confused:

Nope, all of them paired immediately on the first try.

Oh, I know; I've got 5 other custom apps running. This is part of my curse of doing things the hard way. Still, it was only 10 minutes, I probably would have spent that long finding the instructions. I'm not complaining, I just think it wouldn't hurt to mention these things in the install instructions.

1 Like

What all did you try? Usually one of a few things helps.

  • Move the device closer to the hub (or the hub closer to the device).
  • EXCLUDE first before trying to include.
  • Reboot the hub before trying to include.
  • Do the RESET procedure outlined in the manual (linked below). It even mentions that you may need to do this factory reset before doing anything else.

Thanks for the reply. I tried all of these things many times. I tried pairing with the device right next to the hub, still no success. I found it a little odd that the device would EXCLUDE just fine (Hubitat would say "unknown device excluded" - or something of the like to my memory), but would never INCLUDE. I've tried rebooting the hub, no success. I also tried the RESET procedure several times with no success. My solution as of the moment was to install an extra Inovelli switch I had laying around :upside_down_face:

I'm sure you've tried this as well. But what I did for each of these was to remove the batteries, start the Z-Wave discovery on HE, then reinstalled the batteries.

Now I feel really stupid because I did not try pulling the batteries. That worked like a charm! Thanks so much!

Now that I have it successfully paired with the hub, I'm curious which driver you're using?

For others, I forgot to mention that after putting the batteries back in again (and with HE in discovery) you need to push one of the buttons.

This is the driver I used, works great.