Cloud Connection Unavailable

Hi why would the hub say cloud connection unavailable, have rebooted and can see it making calls to and Internet working fine for everything else, have checked the hub time and it is correct.

What firmware is your hub at? There was an issue that was fixed with the current release. If you have any dashboards that are cloud accessible do they work from your phone when you turn off WiFi to force it through cellular?

Latest firmware, tried that with the phone and it gives the error {error:true, type : AppException , message: not found}

Your not blocking any outgoing ports on your router are you?

no it was working about 3 or 4 hours ago, then I noticed the message in the top right? Would Hubitat possibly block a hub from connecting?

Okay would this make any sense, I turned the hub off for about 20min. Then booted up again, it had lost all the devices, apps etc almost like a factory reset, but it did not show the internet problem. I have a 2 backups I did this morning, so I just restored the backup. All good boots up with everything back, then almost instantly no cloud connection again. I am busy trying an older backup file.

Restored 3 different backups as soon as the backup is loaded, then no cloud connection. If I do a full reset and login after that seems to be okay? now I don't know what to do. Don't want to lose all the configurations I have made over the months.

Still having an issue getting my hub to connect to the hubitat cloud? Does anybody know what the ip address or addreses and port numbers the hub uses to make the cloud connection? I would just like to check that I am able to get connectivity to the ip and something is not blocking it from my side.

Can you connect to your hub via

Yes, if I open it shows there. I can then click on the blue writing and it opens my hub config pages?

Is the ip address correct when you click on find my hubs?
If you click on your hub it should take you to your hubs main menu.
If so I would think this would prove remote access.

Yes bobbles, all the ip's are correct and it does take me to my main menu. I sent an email to last night and got a reply from Bobby and he said that none of my hubs are showing connected to the cloud server??? he asked me to check a few things (reboot, turn off wait 30 seconds) He then said to send him my hub ID and my public ip address but I have not heard back from him yet?

1 Like

Hi @bobbles
Just to let you know, it had something to do with me doing a full reset, then restoring a previous backup. Apparently a "full reset" changes the cloud certificate, so when you restore after the "full reset" it wont let you connect to the cloud. Bobby sent me some instruction on how to delete the cloud certificate and renew it.

Thanks for trying to help.


Glad you got it sorted.
That's the main thing.

1 Like

I have the same problem now. Can you you share the information Bobby sent to you. Did some searches and was not able to find how to reset certificate.

Hi @kwwinken

Did you do a full reset and then restore from a previous backup? If so this is what Bobby told me to do.
P.S. You will do this at your own risks. I did it and it sorted out my problem but yours could be different.

If so, you cannot restore a backup after performing a "Full Reset" as the cloud certificate is renewed.

You could try to renew the cloud certificate by following these steps:

  1. go to: yourHubIP/hub/cloud/deleteCloudRegistration

Replace "yourHubIP" with your current hub's IP address. Once you've accessed the above path, then go to the following url:



I have the same issue after a power outage and internet went down can't reconnect to the cloud

If you are able to access the web interface fine, but the hub just doesn't connect to the cloud, I would check your firewall settings. Also you may want to check the hub's internal time. (Go to Settings, then Hub Details and click update time from browser). If the time is off, it will take a while for the hub to reconnect to the cloud.

I got it working. I shut down the hub for about 20 hours. when it reconnected it worked.

1 Like