Cloud connection is unavailable -

New to Hubitat and like what I can do so far. I seem to have hit a roadblock with cloud connection -

I've read as many, many posts and I just can't find the answer. I don't feel like my network is complicated so I'm a bit perplexed. Hubitat is connected directly to my router. I'm using Cloudflair's family DNS service and on my router. I have tried letting my ISP decide, and Still no connection.

Things I've tried -
Nothing - I used all default settings except I reserved the IP in my router. No connection.
Overrode the DNS servers using -,,,,, no connection.
Updated the time. No connection.
Waited a few days. No connection.
Changed the ethernet speed to 100. No connection.
Network test results -

The trace route does finish with
17 * * *
18 ( 34.015 ms * 27.827 ms"

In addition - When I try to log in to the app, it just hangs. When I can get in (by backing out and opening the app again) I can't access my hub.
I can see my hub in my Hubitat account.

I'm lost and could use some guidance.


If you've set a static ip, press the network reset button on the bottom of the hub with a paperclip or toothpick for 7 seconds. (This will be the only round hole out of all the square ones).

If this still doesn't work it is likely network related. Do you have any firewalls? If so have you given permission for the hub? Obviously it's connecting to the local network but something has to be actively blocking it if the above reset doesn't work.

1 Like

I forgot to mention I had already reset the network using the reset button on the bottom. I did it again for kicks. Still no connection.

As for firewall settings in my router - I'm not sure what needs to be open. is there a list of source ips and ports that need to be opened?

Also did a soft reset. Still no connection.

C8 Hub? Make sure the Wifi is disabled / not connected.

Is there a specific error you are getting about the cloud connection? Screenshot please.

1 Like

C7 hub
"Cloud Link to Dashboard" returns an error saying "No Response From Hub"

I also can't log in to my account in the Android app.

You should just open all outbound for the ip of the hub. Otherwise you will continue to have this issue. What router/firewall do you have?

I have an Asus RT-AX3000.
I know how and where to port forward but I don't know what ports or type Hubitat uses. Am I on the right track?

You don't need to port forward. I am using an RT-AX68U. Its not the router unless you have specifically configured something extra restricting in parental controls, or very restrictive DNS servers (you already said you tried different DNS).

Check your clock / timezone settings on the hub. Cant think of anything else as the moment.


When you did did you just press it or did you hold it for 7 seconds?

Held for 10 seconds. LED went from green to blue when I released it.

You might try turning off (temporarily) that AI protection and any parental controls you might have.

I know with my TP Link that the built-in router antivirus blocks all sorts of things, and there is no way to edit or whitelist what it blocks! It is either on or off, so I turned the dam thing off. These stupid built in apps are having the opposite effect to what they are intended to cure, at least in my setup.

I just turned off all AI protection, set Cloudflare as my DNS using, and in my router, and reset the network setting again in Hubitat using the button. I'll give this some time to work itself out if needed.

When updating the date and time, I don't have a timezone option. Only GMT. I assume this doesn't matter. I did notice the time is one second off no matter how many times I refresh/set it.

Currently on - hub- and updates fail.

I really do appreciate all the advice and assistance in trying to work this out.

You should have options here...

Ahh, yes. I have the correct time zone there.


Seems there are two places to check and set the time. I've been using Settings, Hubitat Diagnostic Tool, Set Hub Date and Time. This screen shows GMT.


FWIW - Soft reset fails as well. I get an "Unknown Error Occurred"

Are you getting that when you go to yourhubip:8081 ? Are you doing this on a PC? And what browser?

1 Like

I'm using Chrome. 8081 takes me to the Hubitat Diagnostic Tool.

You have an outdated diagnostic tool, but not sure if you will be able to update it since the hub is having connection issues it seems. If you can get it updated then it should fix the Soft Reset problem.

Just tried updating - http://[Your Hub IP ]*/hub/cloud/updateDiagnosticTool
*NOTE : Replace [Your Hub IP] with the IP address of your hub.

"{"success":true,"message":"No update for diagnostics tool available."}" is the response.

Don't know if it's related but I also can't log in to my Hubitat account with the Android app. The app hangs at "Fetching users data..."

Go back to 8081 and check the version number of the diagnostics tool now... If it is up to date, reboot the hub and try updating the platform again.

Can you get to from a PC browser?

Went back to 8081, still shows version 1.0.92 instead of 1.0.97. When I try to update the diagnostics tool I get the same message -
{"success":true,"message":"No update for diagnostics tool available."}

Yes, I can get to from my PC browser. I can see my hub, it's registered.

I tried "Download Latest Version" from the diagnostics tool last night. I let it sit all night and it stayed on the update screen saying I'd be sent back to my hub. I had to power cycle the hub this morning to get back into it.