Cloud-base migration to C-8 doesn’t work

According to instructions I try to create cloud backup of my C-7, but get message “ Last cloud backup upload failed, please try again.”. I rebooted my C-7 and deleted and reinstall app on my iPad, but nothing change.
Would be nice if I don’t have to reconnect all my devices and recreate all rules.
How can I migrate from C-7 to C-8?

Try doing it from a PC browser.... Also are you running DHCP or a Static IP?

Does it take a while and then fail or does it fail right away?
Thinking maybe it is a DNS or web access issue but I think that would fail right away as opposed to after it processes everything.

Found this: C7 stop working and never get restored

Knowing that, you should do a local backup of the C7 and then immediately restore it. If there is database corruption this usually cleans it out. Then after the reboot try the cloud backup again.

I am running DHCP. Also, I tried to make backup from iPad’s Safari, Chrome, and Firefox, from MacBook’s Safari and Chrome, and from Windows’ Edge and Chrome and all of them with the same results: fail to create cloud backup.

It takes a minute or 2 of circling green dots. I don’t think there is a problem with DNS because everything else on the network works fine.

I’ll try to backup and restore and will report…

Tried to backup, restore, and create a cloud backup. Still sitting for a while on cloud backup and finishes with the same message about failed cloud backup.

Any other ideas what to do?

Do you see your hub at or is it greyed out? Also is your hub on the latest platform?

I don’t know what is “platform”. My hub is up to date on software version and I can fine it on with no problem.

At that point then I would tag @support_team to look into the issue.

Your screenshot shows, not (Not saying the outcome will be different, but you'll see a difference on the latter if the cloud hasn't seen it recently.)

1 Like

That’s referring to the hub’s firmware. The current version is v.


As @bertabcd1234 mentioned, please try using, as it shows the current status of your Registered Hubs from the Hubitat cloud server's perspective.

For example, the red circled hub is an old, original C3 hub that I currently have powered off. Thus, it is showing up as not being connected to the Hubitat cloud due to its grey text.


Make sure that you don't have a radio disabled. That could cause the backup to fail.

Thank you for pointing. The link presenting the page with a few links. I choose “find hub”, which links to “findmyhub” page I included.
The link “regestererd hubs” brings attached page, you were looking for (I guess). It shows C7, I am using now and C5, I disconnected years ago.
Seems C7 showed not have problems… Anything else I can do?

That’s what I see. Firmware is up to date

I don’t think I disabled it. Is it what needed for Z-wave and Zigbee to work?

Both zigbee and z-wave radios need to be on for cloud backup to work yes.

Yes, they both are on and working.
Anything else to enable migration to C8?..

What is your current home networking setup design? If you have an ISP-provided router, and have added another router on top of that, you may have a double NAT scenario which might be causing some issues. Just a hypothesis... :thinking:

Almost every issue with Hubitat cloud connectivity has been an issue with the home network configuration. For example, having Jumbo Frames enabled on any of the devices or network switches/router can cause issues. Having a bad network patch cable. Double NAT. Improperly assigned DNS settings. Multiple V-LANS. Etc...

I am not saying that this is the cause of what you're seeing... It is just all that I could come up with at the moment...

Since it is a USA National Holiday, one should expect the @support_team response to be delayed somewhat.

1 Like

If you have both Zigbee and Z-Wave devices working, then both are enabled. Easy to check, connect to hub, go to Settings and select Zigbee Details and Z-Wave Details respectively. At the top of each page will show if the radio is enabled or not.

Download the Hubitat app