[Closed Beta] Echo Speaks 3 + Actions

community_app
community_driver

#21

Ok, realised I didn't need to set the rule in echo speaks anyway as it has now exposed the echo devices to HSM and I can set the rules up in there directly and it will happily use the echo devices to speak through. All works great now :slight_smile:

Now to see what else I can use it for.


#22

I made the action in Echo speaks for testing purposes since it's beta and it seemed to work. Just letting you know


#23

I set this up last night. I cant stay logged in to amazon account.


#24

Send me a Private message with the link to your diagnostics info. It’s under the Echo Speaks app > Manage Logging & Metrics > Scroll to bottom and expand the Diagnostic Data section > Diagnostic Data (JSON) > This will open a webpage which I will need the link to


#25

Noticing a few errors.


#26

Anyone else having an issue where HSM on the apps page says it's in arming away when it should be in armed away? It never changes it's status after arming. That seems to cause a problem with Echo speaks not knowing that HSM is in armed away mode so no actions happen.

I figured out what's going on. I use sharptools for dashboards and if I use it to set armed away that's when my problem happens if I use the Hubitat HSM app to arm away it all works fine. I'm going to have to stop being lazy and just do away with Sharptools.

Edit: I didn't figure it out it just seems to be random


#27

Is there any way to shuffle a playlist?


#28

I think you can use the word shuffle in the search string for the music command


#29

my echo speaks cuts off about half of the sentence...cant figure out why....v2 didnt do this for some reason. thoughts?


#30

Ive been trying to set this up, but doesnt seem to work for me.
At Step 8, i sign into Amazon, and get the following screen
Untitled
instead of


Then when i go back to the apps screen and wait a minute, there is no save only next.
Clicking on next gives me this

Any ideas where im going wrong?
Cheers

EDIT - Link to json data
link removed


#31

I’m not able to duplicate this. I had my test setup to speak every single event type in my home. it probably sent 10000 commands to the device Over a weekend and never cut off a single message


#32

Thats the same issue I am having.


#33

@tonesto7
Any ideas on where to start ?
Cheers


#34

wow interesting, thats alot. i just tried the test message a few times and i made a short personal one that did the same thing. I think I installed the beta wrong. i think will uninstall and reinstall. if so, do i install V2 then overwrite V2 with the beta? i didnt do it that way the first install...i uninstalled all the code then installed the beta.


#35

A couple errors popped up today, seems to be working OK for me...

Rick


#36

I think what I need to do is add an adjustment variable to the app to allow you to fine tune the wait between messages. I did slightly adjust it in v3.

I will have a fix out this evening


#37

Installed the new version last night. Excited to test it out. This is some powerful software with a ton of use cases. I'll let you know if issues arise that I can't fix. Thanks for your work tonesto!


#38

This version Of echo speaks is actually amazing. You sure this is Beta? Yeah I see some errors in the Log but it all still works really well so far. The more time a spend figuring out everything it can do the more impressed I am. Thanks so much for this. I Definitely need to throw you some Dollar bills, so worth it this app is money.


#39

Sorry @tonesto7, i was referring to my issue about amazon not staying logged in?
Screen shots and diagnostic data above

But big props for providing a fix so soon for the other issues!

I will try the install again later


#40

My ES stopped working today, won't play any of the tests... checked all application logins, code versions are all current...

Anyone else have this issue?

I had the same thing on the previous version and it was never solved

PM sent to @tonesto7, waiting to hear back

Rick