[Closed Beta] Echo Speaks 3 + Actions

community_app
community_driver

#1

This BETA is closed… Please see the release info here: [RELEASE] Echo Speaks v3 + Actions


[RELEASE] Echo Speaks
TTS Fabriq Speakers
#2

Do i need just update Old app and driver or better create a new one?


#3

Update the old app, install the new action app, update the device. Open the main app and press done


#4

How do we update the server code on Heroku Server, I couldn't figure out how to update it without a redeploy of the server.


#5

For some reason Heroku doesn't allow linking dynos to public github repos you don't own (Eventhough it deploys from them)

So either add me as a collaborator on the server or perform a redeploy.


#6

Awesome Thanks for this. Install went like butter couldn't have been easier. I will be testing it out thoroughly. I had to uninstall echo speaks a month ago it just kept getting errors and things not sure if was my side or the app but it had to go.


#7

Oh Damn The integration with HSM is really nice. I noticed There's no armed Night to select in modes to monitor?
Nm it's not there to select but i get speech in any armed mode


#8

looks amazing, keen to try it. Just a small edit to your step 9 for hubitat:

Step 9:

At this point, close the browser window and go back into the SmartThings mobile app.

  • Open the Echo Speaks SmartApp and press Save then wait a couple of minutes.

#9

I had something go on there that I didn't do that step but the browser refreshed and it saved it anyways and all worked.

This is really nice feels & looks like a built in App


#10

I have so many echos in my house, would be happy for them to start being more friendly with HE


#11

Thanks for catching that... I will get it corrected.


#12

What would your name be for heroku to add you as a collaborator? Looks like it has to be an email address.


#13

Is local heroku no longer supported?


#14

Nothing was changed to prevent local


#15

sorry @tonesto7 - as a complete newb thing, I didnt have a heroku account before doing this, so step 4 of the server deployment I had to create an account, but as soon as I did it went straight to the screen for the next step. But just a note :slight_smile:

Step 9:

At this point, close the browser window and go back into the Hubitat web interface.

  • Open the Echo Speaks App and press Save then wait a couple of minutes.

Sorry, at the bottom of my screen it said "next" not save. so i clicked next.

Step 11:

Select the devices to test and activate the Perform the Speech Test toggle.

I am at this step, I can see all my devices and everything so far has been as your screenshots have advised. But none of my echos will say this test.

  • test to speech gives me no response
  • announce test gives me no response, but, the volume ring comes up after what would be an announcement I guess.

speech gives me no logging, announce gives me this


#16

If i go into the device "study dot" set volume the device sets the volume,
then I did Speak, and she spoke the phase I typed in.
So not sure why in the app she wont reply.

she performed the "send test announcement" on the device as well, I heard the test.

went back into the app and the Speech test works now :man_shrugging:

test announcement Doesn't work through the app, but worked through the device page, so dunno there


#17

seriously @tonesto7 - big hand to you. This app is amazing.
will throw you some bucks on payday!


#18

Hey @tonesto7

When creating my first action here is what I found

  • During creation, the test wouldn't speak anything, once I saved out and went back in, the test speak worked
  • Volume doesn't work for me, using an Echo Gen 1. No errors in the logs
  • At the end of the create process, the message says select Done/Save yet the next step is "Next"

Thanks again, I'll keep playing with it
Rick


#19

Might be me but it seems to be having some issues with HSM. So as an example if I set it to speak if door or window is opened (contact sensor) but as a condition only if HSM is Armed Home it says nothing, take out the armed home condition and works fine. Try any other HSM status and nothing when used as a condition and the logs say all the conditions weren't met.

If I do something simpler and tell it to speak if HSM is Disarmed, it does, but it also speaks on any other status with HSM. I think it is having issues confirming the status hence the issue in the conditional option in the scenario above.

Regardless, loving it so far, great to get those echos speaking :slight_smile:

Cheers
Steve


#20

I made a action exact same as you described and it works fine for me.

Wow this is rare I haven't had to reboot or refresh devices to keep things working since installed that's a first for me when trying to use Alexa or Chrome cast fingers crossed. Hopefully I'll be able to rip that sonos connect out that I just installed.