Centralite 3400 Keypad


#22

I have that model, what is your problem? I had it before HE introduced the night mode in HSM, but the night mode on the keypad never worked.


#23

When arming night it will beep and just flash across the top a couple times then go back to disarmed. I get the above error in the logs.


#24

Yes, but the night button never was activated in the driver. The driver is based on the centralite iris version and that keypad doesn't have night button.

@mike.maxwell Are you going to add the missing keys of both keypads? I have both, the iris the panic button doesn't work and the xfinity the night button doesn't work, just asking. Thanks


#25

Lmao, it's a freaking typo... armNite vs armNight...


#26

Gotcha. Currently I have a work around that works for me. I arm home and use that to trigger night mode.


#27

Ah I have done that before. I know your pain.

And now I see that in the error.


#28

Panic won't work on the iris v2 unless you enable it in the driver, in the iris v3 it cant be disabled.
I dont know about the 3400 yet.

What's the xfinity not doing?


#29

The night button, i think it was your typo! Lol


#30

Any news on this problem for the Centralite 3400 keypad? I've got two of them and both with the same night button not working with Hubitat.


#31

@mike.maxwell , please let us now if the fix for the night button is coming on next release, I will use it too. Thanks


#32

Where you unable to incorporate a fix this release? I tried last night and no go.


#33

multiple things are wrong with the current driver and this keypad, these are being worked on now so these updates should be in 2.0.7, sorry they didn't make 2.0.6, i tried...


#34

No problem. Appreciate the effort.


#35

This is a good thread, I'll be keeping an eye on it, I have the 3400 model. One behavior I'm having that seems to be unique is my keypad ignores the arm with pin toggles. No matter what position those switches are in, the only way to arm my system for either Home or Away (I don't use Night) is by first tapping the Home or Away button on the keypad, then keying in four random digits (they don't even have to correlate to a registered user code). Repairing didn't help. I prefer to arm without a pin as that's how my Iris keypad on the other door works, and to me makes the most sense.
The keypad's siren is also very quiet but I'm assuming that's a hardware limitation, not software?
Oh, and sometimes when I disarm the system, the Home button will turn bright red and stay on indefinitely, but waking the keypad back up after it expires clears it, and I can live with that.


#36

The 3400 series keypads do require hitting one of the arm buttons, then the code, disarm is just the code.
I did notice and have fixed the arm toggles, and the new driver doesn't leave the panel indicators on.
It's not possible to arm these without a code, unlike the iris versions.


#37

Ok that's good to know. Using a code works too, especially since it can seem to be any random 4-digits (that way someone like an overnight guest without an entry code can arm the system).


#38

Looking forward to seeing if 2.0.7 resolves a disarming issue I have with my Iris keypad.
So glad I wired the power directly into it. I'd have burnt through dozens of batteries by now as I often come home to find "someone" has disarmed it but has not bothered to ensure the LED's have turned off. :slight_smile:


#39

I've been trying to find a place to actually buy one of these keypads and it seems as if they've vanished into thin air. Certainly not easy to order one for delivery to Aus either.

Anyone know where they're selling them? Or is there a new version coming out or something?


#40

I was in the US last November and grabbed one , along with some sensors, from Lowes


#41

Boo! You going back soon? :wink:

Now that Iris is gone boom, I think Comcast maybe the only source, but can't see anywhere to get them.

Not on Centralite's store either.