Can't Update Driver Code - Error

Since 2.0 I am unable to update driver code, receiving the following error when I click save, having changed a single line of code.

A problem occurred while trying to acquire a cached PreparedStatement in a background thread. on line null

Could it be related to the 1st bullet in this post? Or are you using that method to change your driver code?

I did not use the import feature. I just changed the code manually.

@doug I went to a driver code and added a return. Did a save, it worked.

Can't trivially duplicate your error. :frowning:

Is it just that driver or all drivers?

What happens if you copy the code and try saving it as a new driver?

Have you rebooted and tried after a reboot?

  • It's intermittent. I had it occur previously and it worked when I tried again later, so I dismissed it.
  • It is currently occurring with all drivers and it's been this way all day, this the first occurrence since the 2.0 upgrade.
  • Copy to a new driver seemed to work fine, but the update problem remained there after.
  • Reboot has not resolved it.
  • Does not happen with apps.

Since I copied the code and created a 'new' driver. I now have a duplicate that gives an error 500 on delete.

The problem persists. At this point I cannot update my custom drivers.

@bobbyD Still dead in the water.
Plus I now have duplicate drivers I can not delete. I can therefore not use them because I can't tell which is which when installing.

Attempting to delete anything results in