Can't pair GE light switch

Supremely frustrated.
Have two GE switches in same gang box and one just will not pair with hub.
Have tried every combination of hub resets, zwave repair, exclude etc.
For a while, the first switch didn't pair either but after giving up for a day I came back and it worked .. I think by shear luck.
Adding to my frustration is that my Google Home only sees one of my two Zooz switches.
Yes, I even moved the hub into the room where it is only 10 feet from all these switches and I have even done factory reset on the GE switch.
I'm seriously about to give up on Hubitat ... things should not be this difficult.
Would appreciate any help that doesn't involve the solutions I have already tried.

Reach to to support. I find the GE switch needs to be a little closer to the hub while pairing especially when it's in a gangbox with other switch.

These were joined to another hub before correct? The advice from many has been to exclude them from the old hub first. Apparently the factory reset on some older devices either doesn’t exist or doesnt remove the accociation with old hub as it should. Some even recommend exclusion a few times and then another factory reset before joining the new hub.

Honestly I’ve seen enough problem posts with the letters GE in them to know where the issue is.

Thanks for quick reply.
Actually no. These are brand new switches. Never been paired before .. I read that in some cases people had luck excluding them even though they were new.

If I have any issues pairing a brand new device, I do a factory reset on it, it's less work than trying to exclude it, and then you are sure that all the settings have been reset as well.

Thanks Mike.
Been there/done that.

Have moved the hub; reset the hub; reset devices; removed all and even did a full hub do-over; have spent the last two days trying, searching for solutions and trying some more.

I appreciate the efforts by Hubitat and I wish you luck in your endeavors but I'm done.

I'm sure this system works for others who have the time to deal with it but I just want a system that works out of the box. Maybe in a couple of years it will have the bugs worked out and I will give it another shot.

You gotta do what what you gotta do, but your expierence here is not the norm, there's something seriously wrong, your expierence isnt bug related...

1 Like

What model number of GE switches are you trying to use?
I have seen some people post that some models do not work well
I had to determine what zigbee channel worked best
one of my GE 45856 zigbee switches would not see it on channel 21 but changed the zigbee channel to 20 and it paired fine.
I really like my GE 26931 motion sensor zwave switches though.

The ops switches appear to be zwave, not zigbee.

These are: GE Z-Wave Plus Smart Control Light Switch, Wall, Repeater Range Extender, White and Lt. Almond Paddles, Zwave Hub Required, Works with SmartThings Wink and Alexa, 14291 ... from Amazon.

My questions were specific to one issue because I didn't want to rag on every little thing going wrong and I was trying to solve one problem at a time. It really was not my intent to beat up on Hubitat. I really do applaud them for their work.

But ... One of my other switches which didn't work originally was a Zooz (for 3 & 4 way switches.) Only got one of those to work when the Hub was in the other room. The 2nd didn't show up until I move the Hut to about 6 feet away from it ... even though it was only 8 feet away from the other zooz switch which DID work ... so much for a mesh system. Then, even after it showed up in the Hub I could never get Google Home to see it so I could never use voice to control it.

Other issues that I never mentioned was that I was never was able to recognize either my Tan Tan WiFi plug ins or my 2 Legelite WiFi bulbs. I was't that worried about those because they have their own Smart Life app. but I was disappointed because I want everything in one place.

For all these reasons it just seams to me that Hubitat has some growing to do and the fact that I just don't have the time to fuss with this kind of thing anymore is why I have returned my Hubitat to Amazon ... going to give SmartThings a try.

Good luck with SmartThings. I spent years "over there". The grass isn't greener. I understand the frustration, I hope it works better for you.

That's unfortunate and I feel your frustration. It's a little more pain to pair these switches on HE than ST and Wink but once they are paired. They just don't drop-off the network. I was having random GE switches both Z-Wave and Zigbee dropping off on ST. One advantage ST does have is Z-Wave switch replace.
Whichever route you are taking. Best of luck on your venture and hope you will find your solution.

How do you exclude something that isn't there? I'm having the same problem with my one (and will be only) GE switch. I deleted it from ST (from the IDE), did a factory reset, even shut off the circuit it's on for a minute, but my hub still doesn't see it. I tried to add it back to ST, but ST doesn't see it either now.

1 Like

It's a procedure that clears the association and in a way resets the device (sort of). Put the previous hub in exclusion mode and run the exclusion procedure on the device. Most hubs timeout after 30 seconds I think and will automatically exit exclusion mode. Don't look for fireworks. There's no party. It's just a procedure.

If the old hub in unavailable or no longer working, do the procedure with Hubitat instead. Again, it's just a procedure. If it wasn't joined in the first place, you're not going to see anything happen, but this is what I'm told to do by people that have a heck of a lot more experience with Z-Wave than I do.

I have paired >60 GE/Jasco switches, a mix of their older ZWave and newer ZWave Plus, with no more issues than any other brand.... I've never had to remove power to the circuit or factory reset any device - and I moved 30-40 of those devices between different hub brands 2-3 times so have done a lot of exclusion/inclusions.

For new / out of box:

  1. Put hub in include mode
  2. Include device by pressing ON. If not immediately discovered sometimes I'll toggle between OFF/ON a few times.

For existing/used devices:

  1. Put the hub in exclude mode (doesn't matter if it is a different hub than it used to be associated with)
  2. Exclude the device by pressing ON. If not immediately discovered sometimes I'll toggle between OFF/ON a few times.
  3. Put hub in inclusion mode
  4. Include device by pressing ON. If not immediately discovered sometimes I'll toggle between OFF/ON a few times.

I was hopeful but thsat didn't work. did manage to get it back into ST, then excluded it from there again, but the hub still won't see it, either in exclusion or inclusion mode.

Just my 2 cents to an old thread . . .

I was also having similar issues with GE/Jasco dimmer switches (as well as a few other devices that were previously paired with a ST hub). Apparently, some GE/Jasco switches can't be factory reset. It took me DAYS to figure out the proper process to exclude. Specifically, you must have the Hubitat hub within a foot or 2 of the device you want to exclude. I am not sure why, but this worked EVERY TIME. Every device I wanted/needed to exclude . . . as long as it was within a foot, it worked flawlessly. Then, immediately included without issue. I just made an extremely long cat 6 cable and stored it away for future use.


Depends on the GE switch model. All of mine are 14xxx and 26xxx z-wave plus models.

I excluded all of my GE switches from ST before pairing with HE, with no issues at all. And I did it in-place, with the HE and ST hub 50 feet away in many cases.

Now I have had issues in the past successfully excluding the older 12xxx standard zwave devices. But even then, I always got it to work after a few attempts.

So, dunno? I totally believe you had issues - I just don't know why it would be so different between people/installations.

Maybe it is a zwave mesh strength issue? I have so many hard wired zwave devices, all that support beaming too, that pairing anything anywhere has never been an issue for me.

Yeah, I thought about that too. I have a ton of repeaters and/or devices that act as repeaters on that floor. I also moved a few of my z-wave outlet devices nearby to increase repeater strength. Honestly, it was super frustrating, but once I figured out that trick, it worked great. In any event, system is all up and running and stronger then ever. So far, I'm a happy camper. I was just adding to the thread to give another possible way for people with similar issues to trouble shoot!

1 Like

And thanks for that! Some of us need all the help we can get. :smile: