Can't get new app to work properly

Installed new app. Logged out of old one first. Logged into new one. Tried using presence and got no notifications BUT ... then tested having the notifications app PING me when a switch is thrown.


Signed out of new app - resigned into old app. Did same test. Yup.

Also signed into new app on ipad - it let me PICK the mobile device (i picked my ipad from before) - and THAT works fine.

TRIED again with new app (I do not have remember me turned on) - it won't let me pick the mobile app nor create a new one. AND - if I have something send a notification - it doesn't work. But it does on the old app


You have likely created a new device for the new app when you first logged in. Go to your hub then select Devices on the left menu, then search for "mobile". Remove the newest device (make sure "in use" section is empty, then reinstall the Mobile app and be sure to select the device that you are using for notification purposes. Check this post for more details: How to transition to the new Hubitat Mobile App

1 Like

So - I also had the same problem on my wifes iphone. No matter what I did, I could NOT get the new app to "connect" with the existing mobile presence device. The new app was NOT creating any new mobile presences either - I thoroughly checked.

I FINALLY just created a dummy virtual presence sensor - used SWAP DEVICES in settings - set all my automations to this new dummy - then deleted the iphone presence sensor.

THEN I re-logged in fresh to the NEW app - the old app was long gone off my phone. THIS time it did not attempt to bind to one of the existing mobile App Devices it presented them all to me but let me create NEW .... which I did. Once I had the new - I RESWAPPED that for the temp dummy one and I am back operational.


BobbyD, I can't get past the initial screen after login. I'm a C-7 device running the latest update, 159 I think. There is a green icon at the top of the page with four arrows pointing inward. Underneath it says, "Multiple Hubs found, please select the one you want to connect to." Beneath that is a shaded out selection the says "Lee Hub (Unavailable)". I've tried everything with the exception of deleting my old version. It just won't work for me. Any suggestions.

Updated device info: v.154 not 159 sorry.

Any help here????

Well, I am no expert just another user ..

is your hub on the same network as your mobile device? Do you have another mobile device (family member phone, spare tablet) you could connect to? Can you connect to the hub via web browser?

Also - go into old app and sign out and remove remember me. Then do the same with the new app. Then completely delete the new app and try reinstalling it and relogin in.

Post some screen shots of what you are seeing and answer the above questions lets see if we can get you going.


The only thing I think that changed was logging out. Is is now working, kind of. Not all devices show up on iOS app, but do appear if I connect directly to the hub. At this point, good enough. I have access and all my devices are there except my iPhone. The geo fence shows me miles away from the location of my phone and my hub.