Can't discover hub

Hi, I appreciate that I'm probably making a rookie error.

Hub arrived today. Followed instructions, but the very next step is failing me as I can't get the portal to find my hub.

I'm using a Frontier router, but my knowledge of routers is dim. I'm currently trying to figure out which of many connections is the Hubitat hub so I can give it a MAC address. I don't know what the hub is named and there's a lot of ethernet connections. I've whittled it down, but it's still not finding the hub with any address I try.

I have tried using another ethernet cable instead of the supplied one. I'm hooking it up ethernet first then power.

I'm using a Macbook on Safari, but have tried using my iMac via Chrome to no avail. It just doesn't want to find the hub. I would have plugged one of them into ethernet just to make sure, but that will be a mission as the iMac is across the way and I don't think I have a long enough cable right now.

Tried to give as much info as possible... If anyone can help and spot the (no doubt) rookie error I'm making, then please do.

What color does the light on your hub turn? Your hubs mac address is on the sticker on the bottom of your hub, which will let you trace it down easier.

If you have been unplugging the hub from the power STOP that right now. You may have already corrupted your hubs database. These things dont take losing power gracefully.

Now that you can find the mac let us know if your able to get into your hub, and if not stop unplugging the power to it until we are able to get you in and you can shut down properly to unplug (granted once up and running it wont be an issue)

1 Like

If your Hubitat hub is connected to the network and has booted and received an IP address, it should respond to the name "hubitat"... In the address bar of a browser on a computer on the same network as the hub, enter "http://hubitat/". This should bring up the web interface of the hub. You can then click on "settings", then "hub details" to get the IP address and MAC address of the hub.

If the hub doesn't respond to this, then it has probably been corrupted and is not booting properly. STOP... Email for help.

Thanks for replying. Light is blue and... I didn't read the bit about the mac address. Found it... put it in... nothing.

Cybermage - thanks, tried that and not seeing anything. Emailing support.

BTW - can't get over how quickly you guys responded with useful advice. Really appreciate it. This has been driving me nuts.

1 Like

Sorry... I missed this on first read (hey... it's late...)... You may need to try this on a windows PC...

However... the "" site does work in safari on catalina... So, if the "find hubs" function does not find your hub... you have an issue... and "Emailing support" is the correct path forward...

1 Like

I'm blaming it being late on why I didn't clock the mac address being printed on the hub...

I have tried it on a Chrome browser on the Mac as well. If I have to go out and buy a Windows computer to set it up then, well, that's going to be a deal breaker. I think both computers are on Sierra versions, the Macbook on the the latest and iMac on first iteration.

Blue is still booting... Green is what you need.

IT can take a while to boot if you've pulled power AND that managed to corrupt the 'empty' DB. It tries to clear it and pulling the plug in the middle of that corrupts it again, etc. So.. wait 20 mins. If it hasn't gone green in that time, it probably wont. OR, it's late, look at it in the morning. :slight_smile:

Between the Community and Support, we can get you running....

and.. no Windows needed. All Apple domicile here. :smiley:


I'm thankfull for that. I literally threw a Windows computer out a Window 20 years ago and went out and bought a Mac. I'm not cultish, I just have no use for one now and would have to learn a whole new muscle memory.

Anyway, it's been sitting for well over 20 minutes so I'm guessing it's not going to go.

While I was messing around I pulled the power on my second router that is plugged into the first, and now its dead after over 10 years of faithful service. If anyone has any recommendations for a replacement...

No. You don't need a Windows PC to set up or use the hub... The "http://hubitat/" trick seems to only work from a Windows PC. Normal operation of the hub, once you find it, can be done from a mac (usually) without issue.

You seem to have a misunderstanding about your router and the MAC address...

You do not assign a MAC address to the HE hub... Every network port on every device has a "unique" identifier - the hardware or MAC address... Your router does NOT assign this number. Your router assigns an IP address to the device (in this case the HE hub) using DHCP... BUT the connections are identified by the MAC address... If you reboot the device, the router remembers that it assigned a specific IP address, because the MAC address of the device never changes.

If you are seeing ethernet connections on your router, the connections will be identified by an IP address or hostname or MAC address. The MAC address of the HE hub, that you have now found, is the identifier that you are looking for in the list... or the hostname, which will be "hubitat"...

Actually... Most routers have a function to display the DHCP table (which lists the IP addresses assigned to devices) or ARP table (which lists the IP address and MAC address for all devices that have communicated with the router)... If you can not find the MAC address for your HE Hub in either of these tables, then the HUB is not communicating with the router and is not getting an IP address... If you can find the MAC address in one of the tables, but the IP address does not respond, then there is an issue with the hub...

Just so you know... Hubitat Support WILL help you figure out what is wrong... I'm just mentioning all this so you can get a better idea of what your router show/does...

1 Like

Second router?? Is it actually a router??? or is it a switch...

If it is a router, then you have a double NAT-ed and segmented network... Which could explain why you are having trouble detecting your HE hub...

1 Like

Very happy with these. Good coverage, no problems, lots of features, antivirus and other protection built in, easy to use app, and good paternal controls that are easy to manage and change.

1 Like

Thanks, and yeah, I'm clueless about routers to the point they're pretty much little magic boxes. I've just never had to learn. If this had gone smoothly I still wouldn't...

Still not seeing it or the hostname, so we'll see what support can come up with.

And good mounts for them.

It's running as a switch so I can get more ethernet inputs for non-essentials. I pulled the power to make sure it wasn't confusing things, or me, or showing me a bunch of connections i didn't need to see. I don't know routers but I'm a savage at blind trouble shooting...

Damn... that thing will cover the neighborhood! I'll check it out and probably pick one up. Thanks for the pointer!

1 Like

Yeah. They’re good. Here’s the right link. I accidentally posted the Canadian price before.

If you need a switch for extra ports...., get a switch... they are dirt cheap...

And you don't run into problems when you accidentally plug into the WAN port...

1 Like

Then again, why not plan ahead. :wink: I have this switch too. It has given me no trouble either. 17 ports filled so far.

1 Like

The one I linked to (actually all of the units in that listing) has a hidden bonus... They are managed switches...