Can't Delete Ghost Device

I spent much of today removing Z-Wave Plus devices from my HE so that I could re-add them without any S2 security. Because... nothing from Silicon Labs is compatible with any else from Silicon Labs; God, I hate Z-Wave!!!!

All was going well until I tried to remove the first Zooz device. Of course, being Zooz, it did not go well. As far as I can tell, it only partially removed the device. I now have a ghost device, and am unable to get rid of it. I have deleted devices before, and thought I knew the drill; reboot HE, do a "refresh" on the ghost device, and then "remove" and "remove" and "remove".... Have done this multiple times now, and can not get rid of this particular ghost device. I reset and re-added the Zooz device. No help. Force removed the newly added Zooz device, again. No help.

Please advise how to get rid of this device. I do not have a Z-Wave Stick. Nor do I want to go down that path.

Thank you.

Using a Z-wave stick is very, very easy...and I've been able to remove ghosts every time with it (It can take a few tries, but you just keep pressing the button until it goes thru.). Go ahead, get the stick, and we'll walk you thru it. :slight_smile:

1 Like

I’ve been down a similar road several months back and let’s just say I wasn’t plesant to be around while I tried to figure out how to get this all fixed.

I had one persistant ghost that just didn’t want to go away. I ended-up ordering a Z-Wave stick and that did it for me. I see you want to avoid this.

I did get a recommendation that I haven’t seen you mention, so here goes - hoping it will help.

Sometimes if the device is still “seen” by the hub, it will not be removable. You may need to remove power from the offending device before it is forceably removed. Give that a try to see if it works.


Thank you. Yeah, that occurred to me too so I already tried it. No joy.

That’s unfortunate… The only other thing I can think of is resetting the Z-Wave radio, but that will remove all Z-Wave devices which would not be plesant if you have lots of them…

I haven’t tried this, but if you decided to go that way, you probably could manually re-link the newly discovered “real” devices to the “old” devices by swapping their Device Network IDs. There is a post by Bruce on the topic of migrating from one hub to another that explains how to do this.

Between the silence about ghost devices (and device replacement breaking Rules) from Hubitat Support and the generally crappy products from Silicon Labs and their Partners, I am not a happy camper. It would seem that Hubitat should be including a UZB Stick with every Hubitat HE so that Users can repair damage to their networks.

When my HA network was on Vera, Vera Tech Support was able to take my configuration files and clean up damaged records.

After today's activities (removing and re-including devices to remove S2), every one of my Rules are broken and I now have a ghost device that can't be removed and will likely result in problems.

And they call this Home AUTOMATION.

Can you screen shot this failed node on the z-wave details page for me ?

can you use the Aeon Labs z-stick s2 dsa02203-zwus to remove ghosts?

Ok.. In the next hotfix build there is an update to failed node removal.. Slight change in the handling and added logging so we can get to the bottom of the issue..


I would assume so, but I used this one (several times), which is half the price.

Ok.. is rolling out any minute..

What I need to further troubleshoot is what will show up in the logs:

Failed node XX remove status: x

Updated to
After rebooting from the update, I performed a "refresh" on the device.
Tried to "remove".
The Log shows:
sys:12021-05-12 01:13:00.005 pm Failed node 86 remove status: 0


The SDK reported that the node was not in the failed node list and rejected the removal..

Can you click refresh on that node and then remove again when it finishes refreshing?

Even though "remove" was already displayed, as you requested, I hit "refresh", again. And then "remove".

Here is the log:

sys:12021-05-12 01:24:53.543 pm Failed node 86 remove status: no reply

sys:12021-05-12 01:24:43.545 pm Z-Wave Network responded with Busy message.

sys:12021-05-12 01:24:13.519 pm Z-Wave Network responded with Busy message.

:thinking: That time the SDK was busy and didn't respond.

Looking at the Log from yesterday when I was trying to delete the device, there are numerous entries for "Z-wave Network responded with Busy message". And I have seen other Users with Ghost Devices report the same log entries when trying to delete the Ghost Device.

Having the same problem as above. A ghost node refresh then remove the logs show status 0 then remove again and status no reply. If I refresh again then remove the status is 0 again. remove again and status is no reply. C-7 .126

Also multiple gen 5 z-sticks will not remove it either.

Any updates here? I am seeing this in as well.

sys:12021-06-08 02:03:09.993 pm Failed node 33 remove status: 0
sys:12021-06-08 02:01:44.361 pm Failed node 33 remove status: 0