Can't connect to Hubitat C7 (previously mis-labeled C5) (solved)

I cannot get the Hubitat to respond to web inquiry's.

I did a search by mac address using and it responded with "Found by Mac address,

I do see this address in my router's list of devices, so it is connecting to the router just fine.

Just FYI, it is a Dlink DIR-655.

Clicking the button, (or typing the address into my web browser) yealds a timeout looking for connection.

I tried going to ipaddr:8081 to no avail.

Is there a hardware "reset to factory defaults" technique if I remove the cover to the hub?.

Since the router creates an IP address that means the network portion of the Hubitat is working. I can only assume there is an issue with the microprocessor inside the box.


Thanks, Mark.

What is the color of the hub’s led?

Hi, aaiyar:

The LED is steady green.


Have you pulled power for 30 seconds then powered back up?
Could also try doing a network reset (hold the little button hidden on the bottom for 7+ seconds then let go.

1 Like

Hi jtp10181:

An update, it is a C7, not a C5, my bad, sorry.

There may be have been a block, I setup my router to prevent that MAC address from reaching the web. After I did that, it still worked locally. I have since removed that block, no change to the symptoms.

I removed the power for more then 2 minutes while I searched for my glasses to locate the button.

I powered it back up, Got a blue LED for a while, then got steady green. Still can't connect.

Then I pressed the button for 15 seconds or so, No change in the LED, and till can't connect.

The MAC address and an IP address do appear in my router's list of connected devices.

Tomorrow, I will disconnect it again, then revoke the IP address from the router list, and reboot the router.

Previously this evening in, it was able to locate the IP address via the MAC address, but no more.

I think my next step will be to open the box and look around. If it is dead, I have little to loose. Not that I will be able to do much.


Did you ever have a static IP set on the hub itself? Thats what the network reset will clear out. If its already set to DHCP the reset wont do much anyway.

Also may want to try swapping out the power block, usb and ethernet cable to rules those out. Any power block 1A or higher will work.

Network Setup | Hubitat Documentation.

1 Like

OK, I don't know what happened, maybe a router issue, but it is now working.

I really dislike intermittent problems.

I dug out an old router, connected it to a laptop, and connected the Hubitat.
The router assigned new IP addresses to both and I had access to the Hubitat web setup.

I power cycled my old router, reconnected the Hubitat, and it is now working.

Still using the AC adapter (it is a 1A device) and the USP wire.

Also using the same Ethernet cable.

I had power cycled the old router previously without success, twice, actually, but for whatever reason it is working now.

Thanks for your help,

1 Like

That's the ip not the MAC...:slight_smile: Glad you figured it out.

1 Like

Yes, it was the IP. I think the actual message was found by Mac Adddress.

My hub is doing the exact same thing as yours. Light is green but cannot access it. Have reboot allows it to work for short time then disconnects again.

Are you static or DHCP? Are you running jumbo frames?

1 Like

DHCP from what I remeber last time I could connect. Just checked my router/switch and it shows connected. The light is green but I cant connect to hub through app or ip unless I reboot, but that only lasts a short time. Was working fine until last updates.

Can you get to yourhubip:8081? Are you running jumbo frames on your router or switch?


jumbo frames are running on switch. Cant get to hub unless I physically reboot, power down and then back on. I have not done anything to my setup and problem only started after last update. Only had hub for a month

Turn off jumbo frames.


unable on my switch. TL-SG2008P v2.0.
Was working fine for a month until last update

HE has problems locking up with jumbo frames. It's a well known issue.

1 Like

Ok. But it worked fine for a month, then locked with last update, coincidence?

Unlikely, nothing has changed on the network stack for a long time. You've been lucky. @gopher.ny is the one that handles the network portion of HE and he'll attest this is because of JF's. Honestly they're not needed and the problem is there is not ieee specification for them so every companies' implementation can be different and it can wreak havoc. I work with very large networks and honestly, we just don't enable that crap because the little speed increase you can achieve is not worth the headaches they can cause.

1 Like

will have to see how to disable jumbo on switch I guess, presently can only configure between (1518-9216)