Can't access dashboard locally

I did some searching and I see some old threads with this issue, but nothing recent. I originally assumed this was an issue with the new app, but I just opened the original app and it now has the same problem. So I guess it's something with my network, but nothing has changed and it's a pretty simple setup. Netgear nighthawk router connected to cable modem. My router is about 5 years old, I haven't changed my network setup in probably 3 or 4 years. Last change was turning on the built in Netgear VPN and set that up. That was a few years ago and it's been working great, the first time I noticed this problem was when I installed the new app.

If I set the app to local and select a dashboard I see the connect bar at the top start to slide across but it almost immediately stops and remains at the main dashboard page.

Works fine if I use the cloud connection. Any ideas what to look at?

It is an issue that impacts some hubs, but there is no known solution (that I am aware of anyway…).

I have the same issue on my primary hub.

@gopher.ny, in case you need another data point…

1 Like

Have you tried clearing the web cache on your phone?

1 Like

I hadn’t, but just did. Unfortunately, it didn’t resolve the issue on the latest iOS beta mobile app (2.0.1 (280)).

1 Like

Is there another thread on this? Does HE say it is definitely a bug or do they think it is just an anomaly that a few of us are seeing? Just wondering if I should try reinstalling, rolling back to see if the error goes away, or just wait for a new release. I believe I saw a new release is eminent.

It seems to be something that affects only a small number of hubs. In my case, of all of my hubs, only 1 seems to be affected. Unfortunately, it is the one where I have all my rules and dashboards…

I am not aware that it is reproducible, so that makes it almost impossible to diagnose, and hence to determine if it’s a bug or something else… That said, the more we do to help diagnose it, the easier it will be to pinpoint the issue and fix it. I have had a lot on the go, so have not spent any time diagnosing it on the hub I have. Rolling back to help determine where it started to be an issue is likely not a bad idea! :blush:

It might also help if we can identify common elements. On this hub (C-8 Pro), I have 44 dashboards, one of which is an EZ Dashboard. The hub also has 742 devices (Virtual, Integrations and Mesh - No Z-Wave or Zigbee) and 936 apps. DB size is quite large at 186MB currently, but I have also seen it at over 200MB. Needless to say, the hub has a lot on it…

I fixed it. Not sure how though. tldr at bottom.

I had seen in your earlier post you mentioned only being an issue on one hub. It didn't sink in until this morning, however. I have 4 hubs. The hub that had the issue was the C7 that holds almost all my rules and dashboards. There are no actual Z-wave or Zigbee devices on it. Only some wifi and virtual devices.

My shop hub which is a C5 has several dashboards on it as I keep that hub separate. I use a CPE device to link my shop to the home network, the shop is about 200' behind the house. So it can lose connection from time to time. I usually only access those dashboards when on a PC.

My C8 hub has most of my home zigbee and all my Z-wave devices. The remaining devices are all zigbee and on a another C7. I keep that one going because i still have a few Iris V1 devices and I need a C7 for that. This hub has no dashboards on it. My C8 has a couple of dashboards that I really never look at.

So I tried connecting to the C8 and shop hub dashboards and they both worked fine in local mode. So I was going to post that we had one similarity, but after doing all that and then reconnecting to my C7 rules hub that wasn't working, it now works as well.

In fact it works better. I have a number of webcore graphs on my dashboards and when in cloud mode they will not appear. I have to be in local mode. The old app would always switch back to cloud mode after exiting a dashboard. So I would have to scroll to the top switch back to local then go back to the dashboard I wanted to open.

The new app seems to be staying in local mode, so I can jump from dashboard to dashboard without have to scroll to the top and switch it.

TLDR; after trying other hubs the hub that was not working is now working as expected.

1 Like

Well that’s awesome! No luck for me here… Switching from a working hub to the non-working hub, the non-working hub still doesn’t work locally.