Cannot discover Aeotec devices

Hi everyone. I'm brand new here and to Hubitat and home automation, so please be kind.

I have a new Hubitat C7 which I connected and everything seems good.

I bought 3 Aeotec sensors - Smart Switch 6 (ZW110), MultiSensor 6 (ZW100) and Door/Window Sensor 7 (ZWA008).

So far I have only tried the Switch and MS. Everything seem straight forward. Put the Hubitat in discovery mode and click the Action button on the sensors.

I have tried this many many times now with no luck. The discovery screen seems to find the sensor but just stays on "Initializing" forever and the sensors never show on the Devices list. Both sensors do flash green then solid red which apparently means the connection is not made, but the solution is "try again".

From these and other threads,

I have (multiple times):

  • reset the sensors (hold down the Action button)
  • rebooted the Hub
  • Z-Wave exclusions
  • Reset Z-Wave Radio
  • check firmware
  • tried different browsers and pop-up settings
  • tried one click, two clicks and even three clicks on the sensors
  • I am trying one at a time per the Hubitat warning for Z-Wave
  • had a drink or gone for a walk

Thanks in advance for your help.


1 Like

How far away from the C7 are you when you try to include the devices? I assume these are your only devices and first devices you're trying to pair so you may need to be pretty close to the C7. For the door and windows sensors even after I had all my mains powered devices included I still need to bring them to the hub to include, this wasn't the case for the C5 so I'm guessing it has something to do with S2. Make sure to look in Z-wave details under settings before you try to include again or you may create Ghost devices

Thanks @shawnx1. I was maybe 15' away but in a different room, then moved 8' away in the same room. To clarify, do you mean distance from the Hub or the router? I assumed since the Hub is wired to the router, where the Hub is does not really matter, so it's behind the TV stand, but the router is in the open and central to the house. Maybe I'm wrong on that? In the Hubitat app, Devices only shows my iPhone as "Mobile App Device" and Settings - Z-Wave Details has no entries in the table. Is that what you mean by "ghost devices"? Thanks again.

Hi Jdbrown and welcome, The hub is what matters here so try pairing a device right next to the hub. The Hub is your Z-Wave router basically. Devices that are powered by mains power plugged in or hard wired act as repeaters battery powered devices do not repeat Z-wave traffic so you want to make sure you build a solid Z-wave mesh Not sure if you read this yet or not so I'll link it. Yes ghost nodes have no numbers for in and out.
First device is a good node other two are ghost's see how they have no numbers for in and out.


Oh another thing make sure to uncheck all boxes when you are asked about security for now at least if you get this window you might not depending on device unless your trying to include a door lock then you want security

1 Like

Thanks again @shawnx1. I have become very proficient at creating ghost nodes. I'm not sure how close to the hub I need to be, but I tried it at 3 feet then later held it at 1 inch. The discovery still hangs on "Initializing". When I switch over to Settings - Z-Wave details, I see the entry but no numbers for in/out, as you described above. Also, after this happens I get this message:


So I unplug and restart. I have again tried Z-wave Reset, Exclusion, and resetting the switch. All results in the same outcome. I have also again tried both single and double clicking the Action button (is there a difference?) and tried different browsers. I have never seen the security keys window from the screenshot above.

System Events log seems to report this each time, which probably explains the message to unplug for 30 seconds:

There was also a firmware update tonight, which was successfully applied.

Any more suggestions? Thanks for your help.


You mention that you are creating Ghost notes - it is important that those be removed otherwise you will have more issues down the line...

Are you having the same issue with all your devices? The plug (Smart Switch 6) will be a repeater, so it might be a good idea to start with that one if you can get it to work... It could make pairing the others easier.

1 Like

Hi Darren, A successful Ghost node welcome to the club now your getting somewhere. Like Sebastien said we need to make sure you get rid of those ghost nodes. I would probably just reset the zwave radio if you still have any ghost. After that try and get the smart switch included first. Just pick an outlet closest to the hub for now. I Use chrome I haven't had any weird things happen when using chrome. I've also used safari but I've stopped using it because I would sometimes end up with ghost nodes when using safari so I just did away with using it. So here's what I would do after you reset the zwave radio. shutdown/ unplug the hub for 5 minutes. Plug it back in wait for green status light to come on then give it another 10 minutes. Then go to devices page then at the top of the page click on discover devices, click zwave then click Start Z-wave Inclusion now press the action button 1 time on the smart switch 6. It may take a while, the entire countdown & then some , so just be patient. after that even if nothing shows up like name your device open up another browser window and check in your devices tab to see if anything is in there also check zwave details. Let us know what you get if anything.

1 Like

Thanks @shawnx1 and @Sebastien. I will try again tonight, but I think I have already done pretty much everything you suggest, assuming I'm doing it correctly. I have been deleting the ghosts under Settings - Z-Wave Details - Reset (type the word and click the button). That seems to remove them. Originally I tried the Switch (plug) then the MultiSensor, one at a time. Last night I just tried the switch, figuring it will help with the other sensors, for the reason Sébastien suggested.

Maybe patience is my problem? I unplugged everything for a few hours today and then plugged in back in earlier. I will try the pairing again later and just let it soak for a while after the countdown, while it "Initializes" and see what happens, as well as checking in another browser. More to come...


I wouldn't give up yet. When you get your first device paired you'll get a better understanding of how things work and how simple it can be. I think your devices still think they are included sometimes when you go to include them and that just complicates the process. I keep a Aeotec Z stick handy when I'm including devices and I usually do an Exclusion with the Z stick before trying to include but no need to buy one just yet I think you can get things worked out. Definitely try the plug first and reset the plug before you try again.

Many of the Aeotec devices support SmartStart which may be an easier inclusion process


your right, but I don't think any of his mains powered devices do

@shawnx1, Ha! Maybe it responds to threats. I tried again as you described, which I have done many times already, planning to just leave it alone for a while to see what happens, and it found the switch and added it immediately. Boom!

Thanks also @thebearmay, I'll file that option away for another time.


It’s about time things start going right! :grin:

1 Like

That's Priceless, I usually receive the opposite results.

Hi Darren, That's great to hear!! Don't be shy if you have any other questions, the people in the Hubitat community can usually help out.


@Sebastien, yep, guess I'll keep it. :slight_smile:

Hehe... That’s good!

I haven’t had issues pairing like you have, but the first months weren’t easy. (Hubitat just updated to a brand new 700 series Z-Wave chip on the C7 and there are issues that are out of their control. There are Z-Wave chip firmware updates being developed by the provider and I suspect one will make it’s way to the Hubitat platform in the not too distant future. It will help resolve some of the issues users are seeing.)

That said, there is so much that this platform can do, it takes a while to learn it all.

After a little while though, once things are setup the way you and your family like, it is really awesome!

The community is really, really helpful. There’s always someone who can and is willing to give you a hand. A really awesome group!