Cannot connect to hub - connection refused

Hi all,
I am currently at work and ran into a problem with my hub. Normally I would try a reset however like I said I am not there.

I made a RDP connection to my windows machine and was playing with trying to get a smartapp ported over. I made a change that apparently made my entire hub choke. I do not seem to be able to talk to it anymore. I can login to the portal, I see my hub listed. When I click on it I get connection refused. Same if I try the IP direct. Since there is not anyway for me to interfere currently I figured I would post for staff to have a look at if it interests them. Of note I cannot seem to load my webcore dashboard associted with this hub and devices are not showing in housepanel that were there before. Wont be home for 6 hours or so at which time I will attempt a reboot. Any better advice out there?

Reach out to support before you reboot. I had a similar issue and my hub got stuck at 70% on the first reboot. I rebooted a second time and it automatically loaded the last backup causing me to loose a lot of changes I made that day.

I was advised by @bravenel to contact support before unplugging so they can try to determine the cause.

Hmm yeah I remembered seeing advice of this nature. Is there a better place to post for support than the support forum?

Thanks for the confirmation.


Thanks just sent email. Instant autoresponse outside of business hours.

So I am at a bit of a loss. Do I just leave my hub in the state until someones chooses to respond? I am kinda losing faith - No staff member has responded to me anywhere lol. Makes me wonder what I am doing.

Not much you can do remotely if you can’t get to the web interface. Anyone home that can reboot it?

The wife is at home. Was going to have her reboot. However most support threads state do not reboot until reaching out to support. So I was trying to get some clear guidance. If your saying first step is reboot I will do so in an hour when home.

Well, first I’d check if the red light is on or if its blue. Red means shutdown, so safe to reboot.

If you can’t ping it and its not responding via web interface, there really isn’t anything else you can do but hope you have a good backup and pull the plug and reboot.

Worst case its a factory reset and restore from backup. But I venture a simple reboot will get you back up and running.

It does respond to ping.

Does the web page load? If it responds to ping then its on. So that rules out red light being on.

If the web interface doesn’t load its probably time for a forced reboot. Its not going to come back on its own.

In the end it is all good. I usually do not resort to support requests. I think I will probably get it sorted. Just thought support would be interested in looking per other threads I’ve seen. Thanks for your help Patrick.

1 Like

This happens to my device too. It seems to go into a deadlock sometimes when I’m editing a large smartapp multiple times while other endpoints are trying to hit it. I’ve also seen it on my second hub which has no apps installed. It usually just sits in the other room but I noticed it was really hot picking it up and I was unable to access the web interface so I’m guessing that some process ran away and was preventing access to other parts of the system. In those cases I’ve had to physically unplug the hub before it could respond again.

This happens to me quite often where I cannot log into the hub. Automations work (albeit slower) and home bridge integration works well... but I cannot log into the hub!?!?

Do you also use Hue Integration? Or any device that publishes to HomeKit on its own? If so, go through your Homebridge setup in HE and deselect anything with native HomeKit support. I did this recently and it dramatically improved UI performance.

Although I'm not 100% sure it has anything to do with it, I also removed the Ecobee integration.

Lastly, and I would call this anecdotal evidence, since it might not happen for everyone, but whenever the hub reboots, I try to remember to first shut down any Node.js instances I have running. I find if I forget, everything runs sluggish and then I'll login to my Homebridge and see that it's just posting "invalid API call" over and over. So now if I remember before a reboot, I shut them all down. For me that's Google Assistant Relay (although that one doesn't seem to be a culprit, but I do it anyway), Homebridge, and Insteon-Server.

If I forget to shut down the node instances, then I do it, then reboot the hub. Once it's booted and a few minutes have passed, then I restart the Node instances. Since removing the Native HomeKit devices from Homebridge (which I realize now was a mistake to ever select in the Hubitat-Homebridge plugin the first place) and starting the Node instances only after the hub is fully booted, my UI is back to normal.


Just a suggestion but I put a WiFi controller outlet (WeMo, TP-Link, etc) so I can hard reboot the HE in case I goof it up remotely and have to hard reboot it.

The Hubitat staff have already warned this isn't a good idea. Risks database corruption. But, yeah I understand sometimes rock meets hard place :grin:

Not saying this is your standard way to reboot the HE but it gets you going. I look at it this way:

  1. Hub isn’t shutting down/rebooting correctly but like typical Linux just needs a power cycle
  2. Power outage happens all the time
  3. Z-wave repair in extreme cases do not work resulting in the database needing to be rebuilt with boot up procedures
  4. You just totally goofed up and need to remotely hard reset

All 4 above are not ideal BUT are sometimes necessary. Hence why I have a TP-Link outlet connected.

Yeah, I do get that sometimes there just isn't an option. Although power outage happens all the time says you need a UPS if you don't have it on one already. :wink:

No not all the time per-se' but it does happen from time-to-time. Maybe 3-4 times a year. No reason to buy a UPS for that scenario especially since HE can't support UPS and shutdown activities due to it being a closed system (though it is running raspi).