Cannot connect home app to the homekit integration

Hi,

I just got an Apple TV and wanted to connect it to Hubitat via the HomeKit Integration.

Every time I scan the QR code Home tries to connect, but at some point it times out stating that the accessory cannot be connected. All devices are in the same LAN. Both Apple TV and HE are wired to ethernet in the same subnet. I tried changing all three switches at the bottom of the HE configuration page, but there was no obvious change in the behavior. I also tried the "nuclear option", but that also made no difference.

What else can I try?

What is topology between the two devices, are they connected to the same switch?
What is your subnet mask?

Any possibility a managed switch between the devices is blocking mDNS traffic?

Is the mobile device you are scanning the code from also on the same LAN/vLAN and same subnet?

You can use this program from a windows PC on the same Lan to see if the hub is broadcasting the HAP info on mDNS. zeroconfServiceBrowser | Tobias Erichsen

I forget what it looks like exactly in there but its something _hap and will say hubitat I think.

If you haven’t seen it, there’s a post over here with some additional info, but not much:

Also, what kind of router/Wi-Fi setup do you have? Perhaps something there messing it up… but if other HomeKit pairing is working, probably not that.

What do you mean by connecting the Apple TV to Hubitat? You should be able to set up HomeKit without an Apple TV, but that or a HomePod is needed to connect to HomeKit from the internet. Note that if you’re trying to do automations, you can’t connect the Apple TV BACK to Hubitat and see it in Hubitat (because HomeKit integration is only one way, so you an only see Hubitat devices in HomeKit, you can’t see native HomeKit devices in Hubitat). Also, note that you can’t use an AppleTV as a trigger in HomeKit, so if you want to do something like “IF Apple TV turns on or starts playing, THEN do X,” you can’t in a HomeKit automation. You’ll need something like the Apple TV Advanced plugin in Homebridge to truly do any automation.

Thanks @brad.

The real reason I want to use HomeKit is that the frequency of Amazon's ads on my Echo Show devices is getting more than infuriating, so I want to do away with Alexa and have Apple devices, ergo I'd like to tell Siri to turn things on and off. I do not "plan" on getting any HomeKit only devices, with the possible exception of replacing my Ring doorbell with a HomeKit one.

All devices are in the same network segment (192.168.0.0/24). The Apple TV and HE C8 are connected to ethernet ports on the same Netgear ORBI satellite. The Orbi Router is the DHCP server and is set to be the clients' DNS server.

ZeroConfServiceBrowser remains empty on my PC, but although I said to install bonjour, I don't see anny similarly named services on the PC. Where should mDNS be running, HE?

I rebooted the hub and now get "Failed to add accessory" after clicking on "Add Anyway" in the "Uncertified Accessory" message.

Edit 1: I haven't used Home before, so I don't know if it works at all, except for the Apple TV that I literally just got.

The Apple TV is actually irrelevant at this point, it is not required.

You only need to link the App on your phone to the HE Hub.

Once that is done if you have a capable ATV or Hompod on the same account they will act as a relay (Home Hub) service for HK so that you can securly control your home while away from home. They also help when using locally vs going direct from your phone to the HE hub.

If the ZeroConf app is totally blank either your router is blocking all mDNS traffic or something did not go right with the installation. There should normally be all sorts of stuff in there.

All the Homekit stuff should be in HAP (this is all from Homebridge for me, I do not use the system HE integration since I had Homebridge setup before it came out)

image

1 Like

I was reading that Apple has downgraded the phones and tablets and “highly recommend” using an Apple TV or HomePods as the hub. I tried before getting the ATV with just an iPod and then with an iPhone, but the results were the same.

Edit 1. In your screenshot it says “using bonjour”. Mine does not say that.

1 Like

A phone could never be a "home hub" and the iPad used to be able to work as a hub but I think they killed that off. You don't actually NEED a home hub for it to work locally on your own LAN, but you need it for it to work outside of the LAN and also I found it works much better locally with one as well.

After testing the waters a while back using no hub and then an old iPad as the home hub I eventually got a Homepod Mini just to be a home hub. Sits in my office and occasionally plays music.

I don't really know what else to tell you. The built in integration has worked flawlessly for many and other people struggle with it. Either cannot get it to connect or cannot keep it connected. Might have something to do with the Orbi routers, those seem to come up on here a lot as causing issues.

@lcw731 Didnt you have this same problem getting the "Failed to add accessory" error over and over? What was the eventual solution?

@Daro66 how many devices have you added to the integration? I would suggest just adding one single very simple switch device to start with. There are issues with certain devices/drivers that will break the integration.

Also please confirm you are following these instructions? HomeKit Integration | Hubitat Documentation

If you really cannot get it working and have any sort of always on NAS/Server/SBC (RPi) then you could also just go the Homebridge route.

Just one.

This is what I selected for the installation:
image

But the app is using "Lightweight mDNS":
image

Since the HE and ATV are on the same switch, I'm going to try connecting the computer to it as well, then most of the other network devices are irrelevant. If the ZeroConf app shows something, then there is a wifi issue, if not, I have no idea...

I think this is the Bonjour service you would need to install for it, however it may work using the lightweight mDNS, not sure.

Guessing whatever download it is trying to use no longer works, the software is pretty old but it was the best thing I could find for Windows when I looked in the past.

I can't believe it, but I do have a home enabled device. I got some Meross outlets a while back but never used HomeKit, but rather HE for them. I just plugged one in that has never been on the network before, and I was able to add it to Home without any issue, so we can safely(?) ■■■ume that connectivity functions properly.


That did the trick.

I still can't connect HE though. The Meross outlet is functioning just fine.

Edit 1. I should mention that the C8 does not log anything about the attempts. Should it? Is it listening to Apple network requests? Which tcp port? I can try connecting to it to see if it's open...

The Homekit integration has absolutely zero logging, so its pretty much impossible to troubleshoot :frowning:

In the Home app, ... menu > Home Settings > Hubs & Bridges >
Is your apple TV listed there as the home hub?
Just curious if that got joined up correctly.

You can also test it by going on cellular connection and trying to control that outlet.

For HE, have you tried doing the reboot > advanced > rebuild database yet?

Also what hub model and what platform version?

Yes.

Great troubleshooting tip! I did, and it works fine.

I just did the reboot, not with rebuild.

C8 - 2.3.9.158

I did the reboot with rebuild. The accessory error came much quicker, but it errored out none the less.

You never answered any of these that I can find.

...

:+1: Looked and could not see that, I was skipping over that part my brain thought it was all a reply to the other person.

Seems pretty straightforward, like a normal home network, it should work.
I have no idea what could be wrong.

One more idea, I assume by this you mean they are on one of the APs and not the main router. Can you temporarily move the HE hub so it is connected directly to the main router?

Also what Orbi model do you have?

Unfortunately, that will be a bit of a project...

It's an "older" RBR40 with current firmware.

Could you switch the C8 to the Wifi temporarily (same as the mobile device uses)?

Have any sort of always on NAS/Server/SBC?
I bet homebridge would work fine.