Cannot connect home app to the homekit integration

I have a Synology, but I really want to keep it as simple as possible. That said, if that's what's going to be simplest, I'm willing.

I have been running Homebridge on a mini PC for a while now, it is rock solid once you get it setup and going. All I ever do is update stuff once and a while (would keep working without being updated too).

If you do it on Synology I'd suggest using Container Manager (Docker). Works great.

Thanks for the idea! I’d of course prefer that the official built-in app in Hubitat would work…

Is homebridge bidirectional?

Thank you. Why not use the native synology app?

It will update status on shared devices bi-directionally, but you can only share devices from HB -> HomeKit (same as the system integration).

The only way I know to bring HK devices back into another system is through an addon in Home Assistant. (Or using tricks with virtual switches)

I have home bridge on the synology, and the home bridge plugin on the C8, but after defining a device to be exposed to Home, I’m stuck. I tried creating the configuration, but the test always fails:


What am I missing?

Easier to maintain and segregate from the base NAS OS

1 Like

What test? What are you clicking?
Did you copy the config generated from the app on HE over to the plugin on Homebridge and then restart Homebridge?

I didn’t see any instructions, so I’m just blindly clicking things… :joy:


Edit 1. I assume that is the config in the screenshot, but I have no idea where that’s supposed to go.

I gave a link to the instructions above:

:man_facepalming:t2: I noticed that I didn’t read far enough.

I'm misunderstanding something... is the code from homebridge plugin:

meant to go here:
image

I tried that, but after restarting HomeBridge, the config.json was rewritten, removing my modification.

Okay. I missed a comma. Now the file stays intact, but I have no idea how to get the devices in the home App. If I try adding a device, it offers the bridge right up, but it wants a QR code or a setup code, of which I have neither(?).

Did you install the web UI for homebridge? It will show you the QR code on the main web UI page.

This is weird... I first pasted the code from the plugin, and json file was overwritten. That changed the pin. I then copied (by mistake) the code from the github page. That did not reset the file or the pin. This is where I mistakenly wrote the coma was the issue. I then tried again with the coma and the code from the plugin page, but that reset my configuration again.

This is what the UI shows after restarting HomeBridge:

I do have a newer version of node.js installed...

There can be multiple node JS versions installed at once, so there must be another copy somewhere it is pulling from. Sorry I remember this being pretty easy to setup when I did it, but it was on a linux box, not Synology.

I'm comparing syntax now...

the json file is now valid:


but I'm getting this message in the log:
No plugin was found for the platform "Hubitat-v2" in your config.json. Please make sure the corresponding plugin is installed correctly.

Any ideas which plugin or where it needs to be installed?

Did you install the Hubitat plugin into Homebridge? The error is saying the plugin is missing.

1 Like