Can’t figure out Homeseer WD200+ status LED

So I’ve successfully installed the driver from @codahq and clicked every reference link and created/deleted countless rules but still can’t sort out the status LED indicator.


My rule looks like this so far
I ran a custom action using the actuator for the dimmer. I feel like I’m close but not quite there.
Any help would be appreciated. Thanks In advance

Have you set the status LED's manually from the device page. Every time i pair one, i have to send 1,1,1 on the device page. Then my custom commands will start working.

I know you have to set a "Trigger" (TRUE) command, and a "Reset" (FALSE) command.

Not sure if this will help you out or not, but with this Rule in RM (RM 3.0).
If any of our water sensors get triggered, then all 8 of the LEDs on each of the WD200+ Dimmers will turn red and start flashing until the sensor no longer senses water on the floor any more. Then they will all reset and go back showing their individual light setting on their LEDs.

Is there anything in the logs? (turn on additional logging in the device preferences) When you are setting up setStatusLed what type of parameter are you using (int or string)?

This is what I get in the log

I’m using string as the parameter, I’m new to HE and have only made 4.0 rules and the 3.0 rules seem just different enough to not figure it out from the screen shots I’ve seen. I tried the 1,1,1 on set status led and didn’t get anything.
How do I make the reset (false) command?

You need to use the number or integer parameter type. You can kind of get a feel for which parameter type you should choose by using the command on the device's edit page. There is usually validation on the parameter fields of the button commands that will only let you use a certain type.

Strings contain characters and not just numbers.
Integers are whole numbers.
Boolean is either true or false.

Not sure what you mean here.

When I try to use anything besides the string parameter, I get bad value. I’ve tried putting the values in quotes like I’ve seen other users do but still nothing. @nkyspike suggested the “Reset” (false) command which I assume is to tell the status lights to be off when they are supposed to be?

What's the status on this? Did you figure it out?

I hadn’t and I put it on the back burner for a while, but just gave it a shot again and still can’t get it to work. I checked on the device edit page and LED and Color call for 0-8 and Blink is 1 or 2. When I enter a value for either number or integer, for example 4,6,0 it says bad value. Is there a proper format, parenthesis or bracket that I’m missing?

I have the same switch. You have @codahq HS-WD200+ Dimmer Driver installed and your device set to it?

In the device details page, do you see the following?

image

I just tried it and it changed LED 4 to Cyan - no blinkj

Does your device data details look similar to this?

2 Likes

Everything looks like that in the device details and I do have the driver from @codahq , however if I enter numbers in setStatusLed and hit configure nothing happens. I’ve been trying to do this in RM and have t had any luck there either. Hubitat is my first smart experience but I’ve been able to get everything I’ve tried up and running except this. That being said, I’m sure I’m missing something and I appreciate everyone’s help and patience.

Enter the numbers and click the setStatusLed button (right above the entered numbers) - not the configure button. See if that works.

Once that works, we will move on to RM.

1 Like

Ok great, I have the correct led number and color set thank you! Now as far as the rule for the indicator to be on when another light is on I’m apparently still lost.

What kind of indicator are you looking for? Which light, color and blinking?

1 Like

For example, I change my office light switch to green if my HSM status is Armed Home using this rule:

Hopefully, you will get the gist.

In RM, you will use Run Custom Action. I then pick the Actuator attribute on my WD200+ Switch. Add Integer Parameter for each of the 3 numbers (light(s), color, blink) for setStatusLed

1 Like

When I get to parameter type, my options are string, number and decimal. Whenever I enter (4,6,0), or any number parenthesis or not, it saves as “bad value”

You enter one digit at a time. For example for 4, 6, 0

Select Number as Parameter type and enter 4. Click on Add another parameter and select Number and type 6. Add another parameter and select Number and type 0.

That should do it.

Hint: After typing a number, click outside of the box somewhere to see the Add another parameter button.

1 Like

That was the problem I was trying to enter them all at the same time as I saw it on the rules from you and others. Thank you!
And now that I have that squared away, my rule looks like this


...and still doesn’t work lol looks like I’m close?

So, if your Living Room Lamp is on, you want the #4 LED to be a non-blinking green color? If lamp is off, then turn all lights off?

What are you trying to do and what is it actually doing?

1 Like

Download the Hubitat app