C8 is unable to be upgradable from to

Please provide your hub model (C7, C8, etc.) and its platform version from Settings>Hub Details.

Check out the following post for help troubleshooting problems and gathering details that will help others to identify and solve the problem you are experiencing: ‼ READ FIRST - Before Posting in Get Help

Cannot get the C8 hub to upgrade, fails upgrade many times. Turned off my most highest performing apps, rebooted hub, no luck. 2.3.9 is stuck at 2.3.9!

When you try to update the platform version, do you get a very slow download that times out/fails?

If so, go to the Network Setup section of Settings, and Ethernet Speed is set to Fixed, change it to Auto, and if it's set to Auto, change it to fixed.


Then try the platform update again.


Thanks, fixed it. I should have checked the missmatch duplex!

1 Like

I had the same success swapping this setting. What I don’t understand is why was my connection set to “fixed.” I don’t recall doing this.

Did you ever restore/migrate from another hub?

Yes. I went from
C5 to C7 to C8 Pro.

At some point you probably changed it for some reason on a previous hub and the settings migrated...

1 Like

Flipping that setting may be anecdotal at this point. Based on feedback in other posts I am starting to think that just resetting the ethernet connection by flipping that setting is what is fixing the issue for a lot of people. Other people have gotten the same result by rebooting or a shut down.

Not saying there is anything wrong with flipping it, either way the max speed of the hub port is 100Mbps, the setting is just there to deal with potential switch incompatibilities where they do not negotiate the speed correctly on Auto.

The original issue that flipping that setting was intended to help with was an extremely slow UI, which I had on my original C7 and it did in fact fix it.

1 Like