C8 Hubitat Keeps Crashing

It start a couple weeks ago were I could no longer gain access to the hub. About every 3 hours it would crash and I would have to unplug and plug back in. After a couple days it went away and everything was fine.

Starting last night, about every 2 hours I loose connection and the hub crashes and it is still going on.

When I look in the logs I do not see anything that shows errors or warnings that something is about to crash.

At 02:06:13.782 AM the hub stops until I reboot at 08:24:15.507.

dev:17532023-10-13 08:24:19.608 AMinfodimmer_inblue_pantry initialize()

dev:17522023-10-13 08:24:18.175 AMinfodimmer_inblue_kitchen_main initialize()

dev:17512023-10-13 08:24:16.590 AMinfodimmer_inblue_kitchen_table initialize()

dev:16092023-10-13 08:24:16.221 AMinfoTelnet connection to Lutron interface established

dev:16092023-10-13 08:24:15.507 AMinfoLutron Telnet is still online

dev:19742023-10-13 02:06:13.782 AMinfomotion_sensor_hue_garage_back temperature is 65.81Β°F

app:16432023-10-13 02:05:58.648 AMinfoDelaying off for 1 minute

app:16432023-10-13 02:05:58.595 AMinfoMotion inactive: motion_sensor_hue_downstairs_hallway

dev:18122023-10-13 02:05:58.558 AMinfomotion_sensor_hue_downstairs_hallway is inactive

app:16432023-10-13 02:05:43.722 AMinfoSetting dimmers [dimmer_inblue_Stairway] to 10

app:16432023-10-13 02:05:43.717 AMinfoMotion active: motion_sensor_hue_downstairs_hallway

dev:18122023-10-13 02:05:43.671 AMinfomotion_sensor_hue_downstairs_hallway is active

dev:19742023-10-13 02:05:29.841 AMinfomotion_sensor_hue_garage_back illuminance is 0 Lux

dev:532023-10-13 02:05:21.698 AMinfomotion_sensor_hue_laundry illuminance is 0 Lux

app:16432023-10-13 02:05:21.137 AMinfoDelaying off for 1 minute

app:16432023-10-13 02:05:21.077 AMinfoMotion inactive: motion_sensor_hue_downstairs_hallway

dev:18122023-10-13 02:05:21.021 AMinfomotion_sensor_hue_downstairs_hallway is inactive

app:16432023-10-13 02:05:13.095 AMinfoSetting dimmers [dimmer_inblue_Stairway] to 10

Can someone help me troubleshoot, not really sure what I am looking for.


I think it is Bricked (the second one), it is flashing green and orange on the hub.

That means it is offline. Can’t get an IP address.

1 Like

Thanks, now getting

Corrupt database found

Hub cannot continue. To fix a corrupt database, the hub needs a soft reset (read documentation, open diagnostics tool) followed by a database restore (read documentation, open restore page).

It went down again, this time I got the Hubitat Diagnostic Tool and trying another reboot.

How is the hub being powered? Included supply and cord or other means?

You need to take a backup and download it locally, then do a soft reset and restore.

1 Like

It is being power with the USB cable it came with.

Already tried backup and restore, still keeps dropping off network. Even tried changing to a different IP.

Do you have any Network settings on the hub - like static IP or anything?

How about on your router - have you set a DHCP reservation for the hub on your router (preferred way to set a fixed IP).

There is a button on the bottom of the hub that is under a hole that is different from the others on the bottom of the hub - it's square rather than round. Use a pin to push the button under that hole, and hold it for 7-10 seconds. That will reset your network settings and I think it restarts the hub as a part of that process.

1 Like

UDMPro Network, it is on a static reserved IP but nothing has changed in the last 3 months.

Now everytime I reboot it comes up to the Hubitat Diagnostic tool page.

I am going to wipe the hub and run it for a couple hours to see if it stay connected.

If so will do a restore

Only a cloud restore will bring back both your Zigbee and Z-Wave radios, a local backup restore will not. Don't wipe unless you have hub protect and a cloud backup.

Set the DHCP reservation on your router, and remove the static IP setting on the hub, that's the best way to go.


What sort of integrations are you running? Sounds like maybe Lan/IP integration is hammering connections until the hub crashes. You would think it would generate errors but really that's up to the app/driver developer unless its an actual code exception then the hub itself throws an error.

Checking the app/device stats will show you if something is going out of control.


Still crashing.

I have removed a lot of apps and it is still going. Ecobee, Ring, Govee.

I have test the cable, changed the ports, removed the statics to DHCP.

Where is the app/device stats ??

I have disabled most of my apps. See how long it lasts.

Going to disable Alexa TTS Manager, Amazon Echo Skill, Bond Intergration, CoCo Hue Bridge, Holiday Lighting App, and Hubitat Package Manager and see if it is one of them. Everything else is stock apps

Logs tab in HE, you'll see them there.

Well it disconnected again, this time came back into the Hubitat Diagnostic page. Tried to load into safe mode but it just hangs forever. Did another soft reset.

Everything is clean and new, let me see if it disconnects.

So what am I looking for ?

I think I got things working again. I removed a bunch of apps, then I used Hubitat Package manager to repair every app. This actually has held through the night.

Sort on % of Busy and % of Total to see what apps or devices may be "hogging" your hub's attention. Click at the header at the top of the columns to change the sort.

1 Like

So I think I solved this.

  1. Use HPM to repair all apps
  2. Remove any ghost Zwave device
  3. Remove any old apps
  4. Basically clean things up.

See, Mom was right, clean up your room! :slightly_smiling_face::rofl: