C8 Hub - Sengled Zigbee Smart Plugs Unresponsive After Reboot

Platform version =
Protocol in question = Zigbee

Devices in question = https://www.amazon.com/Sengled-Compatible-Required-Appliances-Certified/dp/B08FJ5LHSN

Device Count = 3
Brand = Sengled
Driver = Generic Zigbee Outlet


Every time I reboot the hub, all three of these plugs become unresponsive. I have 3 plugs setup + 2 hue sensors. Hue sensors work fine. I'm seeing activity in the 'Msgs' column (Zigbee Details) for hue, but 0 for Sengled.

Once I go to Settings -> Zigbee Details and hit 'Rebuild Network', the plugs work again (and the 'Msgs' count instantly increments to '1' for each device).

Is this a bug I need to report or am I missing something here? Thanks.

PM'd @bobbyD for assistance.

Can you go to the device details for one of these and post the model number from the data section?

Sure no problem, here you go. Also if it's relevant at all, these work just fine on my C7 hub:

I've ordered one for testing, I only have the older non repeater model.

Ok, thanks for the assistance - appreciated.

1 Like

in leu of clicking rebuild network after the next reboot can you try manually turning the outlet on and off from the actual device?, if that doesn't work can you try unplugging it, then plugging it back in?
Then let me know the results of that...

This hub is at a friendโ€™s house I installed this for, just made it over.

I can manually trigger the light by pushing the physical button on and off from the plug itself. Works just fine.

If I unplug the plug and plug it back in, and I trigger it manually from Hubitat devices page, it works.

1 Like

Turn on rebuild zigbee network on every reboot.


I'm not able to replicate this on a C8.
Rebooted, device worked first time.

What's the total zigbee device count on the hub having issues?

I have 5 devices total.

3 are Sengled Plugs
2 are Philips Hue Motion Sensors

Philips Hue sensors work as expected, sengled do not.

Let me know what else I can do to help get to the bottom of this. Thanks.

Hi @mike.maxwell,

Wanted to follow-up on this and keep on your radar. Let me know what I can do to help further diagnose this. Thanks.

There's really nothing I can do as I can't replicate the issue.

1 Like

Ok, I'll treat this as a one off for now. I'm configuring another new C8 hub for someone with these plugs and will see if the issue persists. For now, I've worked around the issue with @rlithgow1's suggestion. Thanks.

I'm getting some Sengled plugs soon as well and will link them with my existing C8. @rlithgow1 , and other, say they're good.

That's what got my Centralite 4200C's going again after they became unresponsive, as I recall.

Here's the thread. Hopefully this crap doesn't happen with the new plugs. I was hoping 3.0 would do it.

1 Like

Agreed - I do my research on this forum in advance (like you) on what to buy and saw the Sengled were recommended as well; which is why I was surprised I got the results I did. I do understand these things can be a beast to troubleshoot since everyone's environment is different.

Keep me posted on your progress @velvetfoot and how the install went for you. I will do the same.

I bought 12 of them. I'm a glutton for punishment I guess.

1 Like

I just tried setting these plugs up on a brand new C8 hub and the same behavior occurs - they go unresponsive after a reboot until I rebuild the Zigbee mesh network. For now, I've worked around the issue by setting this toggle:


@mike.maxwell - Anything I can do to help further diagnose this issue?

I don't know what's going on, but i don't think it's specifically these outlets.
I tested the newer version (E1C-NB7) of these a few weeks ago and wasn't able to replicate the issue.
Were there other devices on this C8?, what channel and power settings?
And the proximity to the hub?

I have 3 or 4 sengled plugs myself (oval) and have yet to be a problem.