C8 dropped all Zigbee devices after working fine for 24 hours after migration from C7

Not sure what’s up, but I migrated everything from my C7 to my new C8 yesterday, and everything was working hunky-dory – until today.

It seems that most every zigbee SENSOR and MOST of my Zigbee switches/plugs have stopped communicating.

I’m running
Zigbee channel 24 – has been for years

I have rebootedthe hub, rebooted Zigbee radio, rebuilt the zigbee network, raised the power from 16 to 20, lowered the power from 20 to 12, shut down/removed power/waited/powered back up – all to no avail.

I have a LOT of zigbee contact sensors that have stopped responding. If I factory reset them and repair them, they get recognized and the light goes green for a few seconds, then back to blinking blue, then solid green, then blinking blue…eventually the add device fails out claiming a bad zigbee network.


Sorry to hear this.

Can you add in info on the brand/type of the devices and generally which Zigbee repeaters you have?

@tony @jtp10181

1 Like

Is your old hub powered off? Otherwise it may be conflicting with the new hub.

Try setting power to 8, that will be the same as the C7 was.

Then try pairing a device again.

1 Like

Yes, my old hub was powered off before the new one was powered on.

I have a variety of Contact Sensors - mostly SmartThings devices. Even new ones won't pair. I have other brands that also won't reconnect.

Frustrated, I have removed the C8, and returned the C7 to service. MOST devices have immediately returned (including my SmartThings Contact Sensors), but a few seem to be "lost" forever - I may have to repair them.


Got ALL of my Zigbee devices back on-line with my old C7, although a few had to be "woken up". Oddly, Zigbee logs showed that my SENSORS reconnected first, followed by the switches.

I'm suspecting a bad C8...since the Zigbee lost EVERYTHING after (almost exactly) 24 hours...

Hopefully Hubitat support will have some insights... @bobbyD ???

Physically swap the antennas and see if things work?

If things had NEVER worked, I might have tried that - but ALL of my Zigbee devices were working fine for 24 hours, then they ALL dropped off at once (while nobody was home to have touched anything).

So, for now, I'm happily running everything on my C7, abeit that Z-Wave is slower now that everything isn't 1 hop away any more...

1 Like

A new release is in progress, probably next week, that includes more fixes for Zigbee issues. You may want to watch how that goes and decide if you want to try another dive into your C8. I'd wait until then if I was you (and if I was me). :wink:

1 Like

Is the hub still powered on and online (with radios disabled in this case)?
I'd like to take a look at the engineering logs as long as bringing the hub up will not interfere with the network running on the C7.

Sorry but No, it’s powered off for now. I’m afraid it may be too risky to power it up since it also houses many cloud gateway services…

I’m curious - is there a way to get the C8 running the latest code before restoring the C7 backup? Or is that necessary?

When I migrated, the C8 booted up in a release several dots behind what the C7 is currently running (and it was backed up with that more current release also). I couldn’t upgrade the C8 until it had rebooted with the backup - could things have gotten sorrupted by that (temporary) version mismatch?

You should have no issue updating the C8 after starting it up regardless of any migration or backups being restored to it.

For example, with someone who's never used Hubitat before the C8 needs to work out of the box like a normal new hub and and be upgradeable to the newest firmware without any other requirements.

I would think that you could unscrew the antennas, bring up the C-8 and immediately disable the apps and then the radios. Then @gopher.ny could check the engineering logs before you do a soft reset and update the firmware. I updated to the latest firmware version on mine before migrating the cloud backup from my C-5. I wonder if your C-8 was running the legacy Zigbee stack since that fix was in a recent update. My C-5 was still on the new Zigbee stack from a beta last year and that seemed to transfer to the C-8.

The point is that the backup was made from a newer release than was installed on the C8, and I had to restore the backup before I could upgrade the firmware.

I don’t think the instructions say “boot up your C8 and register it as a new device, upgrade the firmware, and THEN restore the backup” - but I am now thinking that is exactly what I should have done…

1 Like

I restored my C7 migration backup and then updated the FW on my C8 when it arrived, so it shouldn't matter, didn't for me and others who reported doing it in that order. So that should not be a source of problems for you, my C8 has been (mostly) running fine, and as of .121 has been pretty much normal again.

So far, so good.

Here's what I have done.

  1. upgraded my C7 to
  2. physically/manually verified that all my Zigbee devices were working
    • I had to re-add some of them to get them reconnected
  3. repaired and verified my Z-Wave network, ensuring all devices were connected & working
  4. made a new cloud backup of my C7
  5. shut down the C7
  6. removed the C8's antennae
  7. powered up the C8
  8. shut off both Z-Wave and Zigbee radios on the C8
  9. changed the C8 to used the static IP address of my old C7
  10. upgraded the C8 to and rebooted
  11. migration restored the C7 backup onto the C8
  12. reattached the C8 antennas
  13. after reboot, verified both Z-Wave and Zigbee were enabled again
  14. initiated a Z-Wave rebuild
  15. manually verified that all my Zigbee devices were connected & working
    • again, I had to re-Add 2 devices (I now suspect one of my GE Zigbee dimmers is flaky)
  16. manually rebuilt several devices that failed in the Z-Wave rebuild
  17. realized that my Mesh wasn't working both ways - had to reconnect from the OTHER hub, using the Update function to change the hub ID.
  18. verified that my basic automations still worked (door opens, light goes on, etc.)
    • physically turned on/off every switched device in my home
    • opened/closed every door
  19. Opened/Closed the key cloud apps on my C8
    • Echo, Life360, MyQ, Bond (user contributed version), Ring (unofficial), Homebridge V2 (user version)

At this point, everything SEEMS to be working as it should. I'll next take a backup, and reboot the C8. Then I'll see what happens.

Note that I HAVE NOT rebuilt the Zigbee network...maybe I should do that?

If it works leave it alone...

1 Like

Don't see these being re-attached in your steps...


Why remove them?